Bug 164794

Summary: Konversation should support TLS certificates for connections (for oftc)
Product: konversation Reporter: Stuart Prescott <bugs.kde.org>
Component: generalAssignee: Konversation Developers <konversation-devel>
Status: RESOLVED FIXED    
Severity: wishlist CC: hein
Priority: NOR    
Version: 1.0.1   
Target Milestone: ---   
Platform: Debian stable   
OS: Linux   
Latest Commit: Version Fixed In:

Description Stuart Prescott 2008-06-23 23:28:02 UTC
Version:           1.0.1 (using KDE 3.5.8)
Installed from:    Debian stable Packages
OS:                Linux

OFTC supports TLS certificate authentication.

http://www.oftc.net/oftc/NickServ/CertFP

It would be nice for Konversation users to be able to take advantage of this connection and authentication method.
Comment 1 Eike Hein 2012-04-02 11:01:11 UTC
*** Bug 259850 has been marked as a duplicate of this bug. ***
Comment 2 Eike Hein 2012-04-07 00:32:50 UTC
Git commit 9a0496ebccb1456da43ac887466249e1d830ff0a by Eike Hein.
Committed on 07/04/2012 at 02:32.
Pushed by hein into branch 'KDE/4.8'.

Make the previously no-op private key setters mostly work.

M  +18   -7    kdecore/network/ktcpsocket.cpp

http://commits.kde.org/kdelibs/9a0496ebccb1456da43ac887466249e1d830ff0a
Comment 3 Eike Hein 2012-04-07 01:24:11 UTC
Git commit 9e495d1fb440ecabac6949a0096b964b0975b015 by Eike Hein.
Committed on 07/04/2012 at 03:23.
Pushed by hein into branch 'master'.

Add support for SSL Client Certificate authentication using PEM files.

The additional info label unfortunately makes the Qt 4.8 regression
in QFormLayout even more annoying; I'll have to deal with this later.

M  +4    -0    ChangeLog
M  +3    -0    src/identity.cpp
M  +6    -1    src/identity.h
M  +38   -37   src/identitydialog.cpp
M  +38   -2    src/identitydialog.ui
M  +12   -6    src/irc/server.cpp
M  +2    -2    src/viewer/viewtreeitem.cpp

http://commits.kde.org/konversation/9e495d1fb440ecabac6949a0096b964b0975b015