Bug 161986

Summary: support the facebook chat
Product: kopete Reporter: m.wege
Component: New plugin wishesAssignee: Duncan Mac-Vicar Prett <duncan>
Status: RESOLVED FIXED    
Severity: wishlist CC: a.m.p.boelens, bugs, chgonzalezg, devurandom, dhaval, duncan, facorread, finex, florian_staudacher, giga, ict, mike, nferenc, opensourcecat, rap, risto, sir_kalot, smithjd15, steffen, tejasdinkar
Priority: NOR    
Version: 0.12.7   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description m.wege 2008-05-12 08:16:55 UTC
Version:           0.12.7 (using 3.5.9, Kubuntu (hardy) 4:3.5.9-0ubuntu7.1)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.24-17-generic

Description says it all. Would be cool if kopete would support the new chat function in facebook. Since other messengers are starting to support it, it should be possibile.
See at: http://www.allfacebook.com/2008/05/adium-to-support-facebook-chat/
Comment 1 FiNeX 2008-05-12 13:38:06 UTC
Facebook is a growing reality. Supporting it should be interesting!
Comment 2 m.wege 2008-05-14 07:08:22 UTC
This news sounds like I can close my wish again:
http://feeds.feedburner.com/~r/allfacebook/~3/289810669/
Unfortunately the source is not linked. But I guess it is ok. So I close the wish and reopen it just in case this news turns out to be not true.
Comment 3 m.wege 2008-05-14 07:09:24 UTC
Closing wish, Facebook announced to support Jabber/XMPP.
Comment 4 FiNeX 2008-05-14 09:53:54 UTC
Wonderful!
Comment 5 Ramon Antonio Parada (brainsqueezer) 2008-08-08 09:13:27 UTC
Facebook will not add Jabber support until they launch their own client. Bug should not be marked as resolved.

Pidgin is supporting Facebook.
Comment 6 Pino Toscano 2008-09-27 21:40:53 UTC
Wish still valid, reopening.
Comment 7 Pino Toscano 2008-09-27 21:41:17 UTC
*** Bug 171757 has been marked as a duplicate of this bug. ***
Comment 8 m.wege 2008-11-08 00:50:52 UTC
Since it doesn't look like facebook is opening up directly, it would be really great if FB-chat could be supported like in other messengers.
Comment 9 Störm Poorun 2008-11-23 15:48:05 UTC
I'm with Pidgin now until kopete gets Facebook chat support. A lot of people are using facebook chat as their main IM now - mainly because it tends to attract a wider cross section of the populus - who wouldn't otherwise use IM.
Hope Kopete can catch up soon! Is anyone working on a fb plugin? Anyone want support?
Comment 10 Risto H. Kurppa 2008-12-05 23:13:09 UTC
I second the wish, would be nice not to have to have a FB window open all the time because of the chat..
Comment 11 Dhaval Patel 2009-02-06 00:27:15 UTC
Is anyone working on this? I am certainly looking forward to the day when Kopete supports Facebook IM.
Comment 12 Florian Staudacher 2009-02-17 23:01:04 UTC
It would be great to have the FB chat in an app rather than in a browser window!

Please consider it ...
Comment 13 Fabio Correa 2009-02-17 23:46:00 UTC
Is there any way to help developing the plugin?
Comment 14 m.wege 2009-03-24 01:46:01 UTC
Is this something which can only be done by an Kopete internal or would it be possible by someone who want to get into it? If it possible for externals, it would be cool if there would be a kind of profile (what needs to be done, what qualifications are needed). Then it could be announced on the commit-diggest and/or the dot. May be there is someone up for the fame?
Comment 15 Steffen Schaumburg 2009-03-25 16:34:52 UTC
@14: I'm not a KDE/Kopete dev but I don't see any reason why an external couldn't make this.
Comment 16 Tejas Dinkar 2009-03-26 08:11:54 UTC
I am submitting this as my proposal for Google Summer of Code
Comment 17 m.wege 2009-03-26 09:49:22 UTC
This sounds very cool. I hope you succeed :-) 

May be, I do not know how different the work for this would be, you could design it in way that it is easy to pick the IM-functionality of other social networks. There is MyVZ/StudiVZ/SchulerVZ (a facebook clone in Germany, Austria and Switzerland with 10 million users) and I heard Myspace (I don't use that) which has also messaging.
Comment 18 Salvatore Brigaglia 2009-04-08 19:45:31 UTC
this would be absolutely awesome!
Comment 19 Jamie Smith 2009-05-02 04:10:12 UTC
Facebook Activity Stream looks like it could be parsed for Facebook wall posts / chat as a plugin for Kopete.
Comment 20 Duncan Mac-Vicar Prett 2009-05-20 10:50:21 UTC
I take this enhancement, as I already got the first usable version:

see: http://duncan.mac-vicar.com/blog/archives/541
Comment 21 Salvatore Brigaglia 2009-05-20 14:23:05 UTC
(In reply to comment #20)
> I take this enhancement, as I already got the first usable version:
> 
> see: http://duncan.mac-vicar.com/blog/archives/541

I would really like to help you testing this.
Comment 22 Dhaval Patel 2009-08-02 18:38:28 UTC
Is there a package available for Kubuntu 9.04 (Jaunty)? I would help test it as well.
Comment 23 Dennis Schridde 2009-08-02 23:36:49 UTC
http://github.com/dmacvicar/kopete-facebook/tarball/release_0_1_3 is the latest source tarball?
Comment 24 Dennis Schridde 2009-08-03 11:49:38 UTC
Gentoo ebuild available in http://bugs.gentoo.org/show_bug.cgi?id=280153
A patch was needed to fix linking: http://bugs.gentoo.org/attachment.cgi?id=200005

You should link against QtNetwork and QtGui (you use both in your code).

QJson links against QtCore, but is missing to setup the library path *?*
Could be a bug in QJson's pkgconfig, or you destroy the already setup path somehow, I am not sure about that.
Comment 25 Dennis Schridde 2009-08-03 11:58:35 UTC
First feedback:
- In the setup dialogue you ask for a password, but Kopete itself asks for the password again just after clicking OK.
- There is no visible feedback whether the connection was successfull or not, or whether we are connected at all. (gray facebook icon, or similar)
- Afterwards nothing happens. No new buddies in my list, nothing.
Comment 26 Dennis Schridde 2009-08-03 12:06:52 UTC
(In reply to comment #25)
> - Afterwards nothing happens. No new buddies in my list, nothing.
Sorry, there does something happen. Just not as much as I assumed:
I have a new category "Facebook", which shows myself as being offline. My Friends are missing there.

Question: How did you do this without me every having to register a "Kopete/Facebook" application to Facebook? How do you access the data?
Comment 27 Dennis Schridde 2009-08-03 12:09:07 UTC
You cause a crash on exit:
Application: Kopete (kopete), signal: Segmentation fault
[KCrash Handler]
#5  0x0000000000ff3b5a in ?? ()
#6  0x00007f38e5fde155 in Kopete::Account::~Account() () from /usr/lib64/libkopete.so.4
#7  0x00007f38cc4035b3 in ?? () from /usr/lib64/kde4/kopete_facebook.so
#8  0x00007f38e424aa0b in QObjectPrivate::deleteChildren() () from /usr/lib64/qt4/libQtCore.so.4
#9  0x00007f38e4250d3e in QObject::~QObject() () from /usr/lib64/qt4/libQtCore.so.4
#10 0x00007f38e6032e72 in Kopete::Protocol::~Protocol() () from /usr/lib64/libkopete.so.4
#11 0x00007f38cc3feac5 in ?? () from /usr/lib64/kde4/kopete_facebook.so
#12 0x00007f38e602ec48 in ?? () from /usr/lib64/libkopete.so.4
#13 0x00007f38e60285d7 in ?? () from /usr/lib64/libkopete.so.4
#14 0x00007f38e300bb55 in ?? () from /lib/libc.so.6
#15 0x00007f38e300bbb5 in exit () from /lib/libc.so.6
#16 0x00007f38e2ff39fd in __libc_start_main () from /lib/libc.so.6
#17 0x0000000000412069 in _start ()
Comment 28 Matt Rogers 2009-09-16 04:35:20 UTC
There's an external facebook plugin now. I think we can go ahead and close this bug. It's being shipped in Kubuntu Karmic and openSUSE for sure. I don't doubt that other distros will pick it up soon, if they haven't already.