Bug 161434

Summary: minimize animation plugin couses non-stop repainting of screen
Product: [Plasma] kwin Reporter: Sebastian Kuźlak <sebastiankuzlak>
Component: compositingAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED FIXED    
Severity: normal    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description Sebastian Kuźlak 2008-04-30 02:26:00 UTC
Version:            (using Devel)
Installed from:    Compiled sources
Compiler:          gcc 4.2.3 

to reproduce:
- turn on show paint and minimize animation plugins and hit apply.
- minimize a window
and now we can see entire screen repainting. on my athlon 2400xp+ it takes form 20-40% of cpu time.
Comment 1 Martin Flöser 2008-04-30 09:40:24 UTC
Reason is that the method progress() of TimeLine is called to check if the animation is still running. But method value() should be used as the progress is not increased if time is added.
Comment 2 lucas 2008-06-11 17:14:46 UTC
Does this bug still occur? Although the code has not been changed I cannot reproduce it.
Comment 3 Martin Flöser 2008-06-11 17:24:42 UTC
This bug has been fixed by Sebastian Kügler: http://websvn.kde.org/?view=rev&revision=803465

(strange that the bug has not been closed automatically...)