Bug 160617

Summary: Same image gets opened to both sides of view when draggin image to right side
Product: digikam Reporter: Fri13 <friiduh>
Component: Usability-Drag&DropAssignee: Digikam Developers <digikam-bugs-null>
Status: RESOLVED FIXED    
Severity: normal CC: kdebugs
Priority: NOR    
Version: 0.9.4   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In: 0.9.4

Description Fri13 2008-04-09 15:25:31 UTC
Version:            (using Devel)
Installed from:    Compiled sources
OS:                Linux

When the user drags image from thumbnail view on Light Table to left side, it gets opened there. Then if user drags other image to right side, that image gets opened to right and left side.

Same dosn't happend when using only a keyboard shortcuts (ctrl+L/R) so draggin activates it too.
It dosn't matter is there set from settings to sync both sides or loading image to right side when selecting. Draggin to right sides always open it both sides.
Comment 1 Mikolaj Machowski 2008-04-09 18:48:09 UTC
Confirming.
Comment 2 Andi Clemens 2008-05-30 21:46:57 UTC
*** Bug 161467 has been marked as a duplicate of this bug. ***
Comment 3 Andi Clemens 2008-07-03 19:06:43 UTC
SVN commit 827717 by aclemens:

fixed drag & drop behavior of lighttable.

1. drop image(s) in left pane:
the image will be displayed in the left pane

2. drop image(s) in right pane:
the image will be displayed in the right pane

3. fill light table (F6):
the first image of the added images will be displayed in the left, the
second in the right pane. All the others are added to the thumbbar.

4. append images to light table (CTRL+F6):
Images are only appended to thumbbar, not displayed automatically.

5. drop images in thumbbar:
Images are only appended to thumbbar, not displayed automatically.

CCBUGS:160617

 M  +1 -1      digikam/albumiconview.cpp  
 M  +9 -9      utilities/lighttable/lighttablewindow.cpp  
 M  +1 -1      utilities/lighttable/lighttablewindow.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=827717
Comment 4 Andi Clemens 2008-07-03 19:10:26 UTC
*** Bug has been marked as fixed ***.
Comment 5 caulier.gilles 2008-07-07 08:52:40 UTC
Andi,

Note : This patch is not yet ported to KDE4. still to do. I set this entry in the list of TODO from KDE4 svn reprository (just to unforget).

Gilles
Comment 6 Andi Clemens 2008-07-07 09:31:47 UTC
SVN commit 828996 by aclemens:

backport commit #827717 from KDE3 branch
CCBUGS:160617

 M  +1 -1      digikam/albumiconview.cpp  
 M  +8 -15     utilities/lighttable/lighttablewindow.cpp  
 M  +1 -1      utilities/lighttable/lighttablewindow.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=828996