Bug 157523

Summary: Kate terminal prevents shortcuts to work
Product: kate Reporter: Bráulio Barros de Oliveira <brauliobo>
Component: generalAssignee: KWrite Developers <kwrite-bugs-null>
Status: RESOLVED INTENTIONAL    
Severity: wishlist CC: adaptee, cullmann, divided.mind, konsole-devel, linuxfever, samjnaa
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Bráulio Barros de Oliveira 2008-02-09 15:36:25 UTC
Version:           3.0.1 (using 4.0.1 (KDE 4.0.1), Gentoo)
Compiler:          x86_64-pc-linux-gnu-gcc
OS:                Linux (x86_64) release 2.6.24-gentoo

When using kate terminal (is has focus), its shortcut (for me Atl+1), and probably others, does not work anymore, so I cant hide the terminal using the same shortcut
Comment 1 Anders Lund 2008-02-13 09:25:36 UTC
This is a problem with konsole
Comment 2 Robert Knight 2008-02-15 19:48:20 UTC
This is related to Bug #157496
Comment 3 Bráulio Barros de Oliveira 2008-09-11 18:37:25 UTC
is this passive of fixing? maybe a hierarchy structure for the shortcuts...
Comment 4 Robert Knight 2008-09-11 19:16:04 UTC
Hi,

This is Kate's problem now.  It needs to respond to the overrideShortcut() signal from the Konsole part and then set the override parameter to true or false to indicate whether the shortcut should be triggered or whether the key combination should be sent to the terminal instead.
Comment 5 Rafał Rzepecki 2009-11-17 15:05:51 UTC
*** Bug 169748 has been marked as a duplicate of this bug. ***
Comment 6 Rafał Rzepecki 2009-11-17 15:12:16 UTC
Currently some shortcuts work and some don't. Eg. ctrl+shift+f12 properly defocuses, but shift+f12 doesn't. 

This needs to either be fixed or properly documented; I'm not sure if this fits within the scope of this bug, though. Thoughts?
Comment 7 Nikos Papas 2010-08-13 10:34:34 UTC
I still have the same problem in KDE 4.5.0 -- kubuntu packages
Comment 8 Nikos Papas 2011-03-07 23:38:37 UTC
Same problem in 4.6.1 -- kubuntu packages
Comment 9 Nikos Papas 2011-04-08 20:35:50 UTC
Still in 4.6.2...
Comment 10 Jekyll Wu 2011-10-21 05:48:39 UTC
By default, konsole kpart sends all key combinations containing only one modifier(Shift/Ctrl/Alt) to the terminal process, thus overriding potential shortcut.  So Alt+F doesn't work while Ctrl+Shift+F still works in kate.

As Robert has said in comment #4, that behavior can be controlled by host apps by responding to the overrideShortcut(QKeyEvent*, bool&) signal.
Comment 11 Christoph Cullmann 2012-11-03 12:14:50 UTC
Git commit 861d7ed350f9e81d3e18d30d0aa6ca832ba9506d by Christoph Cullmann.
Committed on 03/11/2012 at 13:14.
Pushed by cullmann into branch 'master'.

let konsole not eat half of all shortcuts

M  +13   -3    kate/plugins/konsole/kateconsole.cpp
M  +6    -0    kate/plugins/konsole/kateconsole.h
M  +10   -0    kate/plugins/project/kateprojectinfoviewterminal.cpp
M  +6    -0    kate/plugins/project/kateprojectinfoviewterminal.h

http://commits.kde.org/kate/861d7ed350f9e81d3e18d30d0aa6ca832ba9506d
Comment 12 Dominik Haumann 2012-11-04 13:16:02 UTC
I heavily used the reverse search in konsole through CTRL+R, which now is not possible anymore, as it now triggers search & replace.
Any comments on that? ;)
Comment 13 Christoph Cullmann 2012-11-04 13:17:11 UTC
Then fix it and let it overwrite ctrl-r :P
Comment 14 Christoph Cullmann 2012-11-09 19:43:23 UTC
the overwrite control is sensefree, as there is no sane way to query the matching QKeyEvent for the user configured QAction QKeySequences, back to old behavior, some shortcuts shall not be used for console switching.
Comment 15 Christoph Cullmann 2012-11-09 19:44:30 UTC
Git commit c0df718eb49f1b988067c656200bc74f5fa5b725 by Christoph Cullmann.
Committed on 09/11/2012 at 20:43.
Pushed by cullmann into branch 'master'.

let console eat shortcuts again
we can't senseful match against QKeySequences of the terminal plugin actions
Related: bug 309723

M  +3    -3    kate/plugins/konsole/kateconsole.cpp
M  +3    -3    kate/plugins/project/kateprojectinfoviewterminal.cpp

http://commits.kde.org/kate/c0df718eb49f1b988067c656200bc74f5fa5b725
Comment 16 Dominik Haumann 2012-11-12 07:44:41 UTC
To show/hide the terminal quickly, you can bind a shortcut to "Show Terminal" in the "Configure Shortcuts" dialog. To switch focus, you can also use the "Focus Terminal" action.

If you bind a shortcut to one of these and get used to it, this may be a good workaround for this issue, as like Christoph said, it's unfixable...