Bug 148195

Summary: k3b still crashes my system ...
Product: [Applications] k3b Reporter: Phil Miller <philm>
Component: generalAssignee: Sebastian Trueg <trueg>
Severity: crash CC: kingmph
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Compiled Sources   
OS: Linux   
Latest Commit: Version Fixed In:

Description Phil Miller 2007-07-25 12:33:00 UTC
Version:           1.0.3 (using KDE KDE 3.5.7)
Installed from:    Compiled From Sources
Compiler:          GCC 4.1-20070528 build from source
OS:                Linux

Hi there. I reported this bug http://bugs.kde.org/show_bug.cgi?id=147663 and added a comment to that one too: https://bugs.kde.org/show_bug.cgi?id=147676. Today I updated my system to the newest packages I've in my distro: http://pastebin.ca/632961

To the bug 147676 i can confirm that it is fixed with the empty media issue: http://pastebin.ca/632963

But when I remove all discs from my drives I see only this in the terminal:

could not open device /dev/scd1 (No such file or directory)
/dev/sr0 resolved to /dev/sr0
/dev/sr0 is blockdevice(0)
/dev/sr0 seems to be cdrom
bus:0, id:0, lun:0
(k3bDevice::Device) /dev/sr0 : init()
(k3bDevice::Device) /dev/sr0 feature: CD Mastering
(k3bDevice::Device) /dev/sr0 feature: CD Track At Once
(k3bDevice::Device) /dev/sr0 feature: CD-RW Media Write Support
(k3bDevice::Device) /dev/sr0 feature: DVD+R
(k3bDevice::Device) /dev/sr0 feature: DVD+RW
(k3bDevice::Device) /dev/sr0 feature: DVD+R DoubleLayer
(k3bDevice::Device) /dev/sr0 feature: DVD-R / -RW write
(k3bDevice::Device) /dev/sr0 feature: Rigid Restricted Overwrite
unknown profile: 2
dataLen :60
checking for TAO
checking for SAO
checking for SAO-R96P
checking for SAO-R96R
checking for RAW-R16
checking for RAW-R96P
checking for RAW-R96R

then my pc freezes in x86 and x86_64 and the light of HoldShift starts blinking on my keyboard.

My Distro is a gnome-based one. For k3b I install these packages:

kdelibs cdrtools cdrdao dvd+rw-tools transcode vcdimager mad libvorbis libsamplerate iceauth libmusicbrainz lame flac ffmpeg

You can check the versions here: http://pastebin.ca/632961

So how can I create a log of the crash to get you more info about this?

These are my drives:


Version 1.0.1 still works fine on my distro but not the newer one. I really don't know why.
Hope we can fix this. Will disconnect my burner from the mainboard and replace it, maybe this will help.
You told me that you don't change anything for the drive detection, are you shure?

Quote: Fixed supported write speed detection on some devices
Comment 1 Phil Miller 2007-07-25 12:53:35 UTC
Now I removed all discs from the drives and put in an empty CD-R to the dvd burner. K3B starts with this log: http://pastebin.ca/632995

As soon as I remove the disc my system crashes again. Also it crashes if there is a Commercial Video-DVD or a DVD-R/-RW/+R/+RW in the drive.

Seems K3B detects my DVD burner as CD burner and get crasy about that. Hope this helps.

Comment 2 Phil Miller 2007-07-25 13:04:12 UTC
To complete this bugreport here the log of k3b 1.0.1 on my system also with empty DVD-R 8x media in the dvd burner drive: http://pastebin.ca/633007

It works with that version, so there must be some changes in the device detection ...
Comment 3 Phil Miller 2007-08-24 20:13:50 UTC
Today I updated my LG-DVD-Burner to the newest firmware 1.06A. Still get the total system crash. Then I replaced the drive with another DVD-Burner from Toshiba-Samsung. The model SH-S182 with the firmware version SB06.

Same result there. Then I change the IDE ports from port one to port two and tried master and slave. On all cases my system crashes. Seems the DVD-detection is somehow broken on DVD-Burners. With the old version 1.0.1 all works. So what did you change then?
Comment 4 Phil Miller 2007-08-25 21:21:43 UTC
Well an update to unstable branch works now for me. Seems to be some new versions of the dependencies. Here is the new packages-list I installed on my pc:

Comment 5 Ranando 2007-09-22 19:45:31 UTC
Getting the same problem on my system with much the same description. The system freezes in exactly the same spot. 2 seconds later, my system reboots. 

OS:     openSuSE 10.2
Kernel: 2.6.19-4-rt (JAD kernel)
Drives: 5,0,0   500) 'LITE-ON ' 'DVDRW LH-20A1P  ' 'KL0A' Removable CD-ROM
        5,1,0   501) 'CENDYNE ' '522452AU        ' '1.20' Removable CD-ROM

I've tried using the build from Packman. Does the same thing. Tried re-compiling without k3bsetup2. Still does the same thing. The problem is in the initial detection routines. If k3bsetup is run immediately after installation, the crash happens
Comment 6 markuss 2010-03-16 16:02:49 UTC
In an attempt to clean up old bugs that are not valid for K3b 2.0 (=KDE SC 4.x port) anymore, this is now being marked as UNMAINTAINED.
If this bug is still valid for 2.0, please reopen it.