Bug 143478

Summary: unpredictable crashes with dIMAP
Product: kmail Reporter: Jan Torben Heuer <mail>
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: NOR    
Version: 1.9.5   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Jan Torben Heuer 2007-03-26 11:59:44 UTC
Version:           1.9.5 (using KDE 3.5.5, Kubuntu (edgy) 4:3.5.5-0ubuntu3.1)
Compiler:          Target: i486-linux-gnu
OS:                Linux (i686) release 2.6.17-11-generic

Sorry, I cannot tell you what I am doing, sometimes it crashes in the background sometimes When I'm reading mails...

I am using disconnected imap, maybe there is a problem? I am NOT using filtering! But searches.

Here is the stack-trace:
(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
[..]
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1242416336 (LWP 4985)]
[New Thread -1280926816 (LWP 5066)]
[New Thread -1272534112 (LWP 5065)]
[New Thread -1264141408 (LWP 5064)]
[New Thread -1255748704 (LWP 5063)]
(no debugging symbols found)
[...]
(no debugging symbols found)
[KCrash handler]
#6  0x00000000 in ?? ()
#7  0xb55f5f7a in KMFolderImap::flagsToStatus ()
   from /usr/lib/libkmailprivate.so
#8  0xb5612f33 in KMFolderCachedImap::slotGetMessagesData ()
   from /usr/lib/libkmailprivate.so
#9  0xb5614532 in KMFolderCachedImap::qt_invoke ()
   from /usr/lib/libkmailprivate.so
#10 0xb6f9f957 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#11 0xb6a82bfd in KIO::TransferJob::data () from /usr/lib/libkio.so.4
#12 0xb6a82c78 in KIO::TransferJob::slotData () from /usr/lib/libkio.so.4
#13 0xb6ac06d9 in KIO::TransferJob::qt_invoke () from /usr/lib/libkio.so.4
#14 0xb6f9f957 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#15 0xb6a7f41e in KIO::SlaveInterface::data () from /usr/lib/libkio.so.4
#16 0xb6ae03c3 in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#17 0xb6ade75a in KIO::SlaveInterface::dispatch () from /usr/lib/libkio.so.4
#18 0xb6a8f43c in KIO::Slave::gotInput () from /usr/lib/libkio.so.4
#19 0xb6ace360 in KIO::Slave::qt_invoke () from /usr/lib/libkio.so.4
#20 0xb6f9f957 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#21 0xb6fa026e in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#22 0xb732ccdb in QSocketNotifier::activated () from /usr/lib/libqt-mt.so.3
#23 0xb6fc2516 in QSocketNotifier::event () from /usr/lib/libqt-mt.so.3
#24 0xb6f36b88 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#25 0xb6f389b7 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#26 0xb765fdb2 in KApplication::notify () from /usr/lib/libkdecore.so.4
#27 0xb6ec9389 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#28 0xb6f28f81 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/libqt-mt.so.3
#29 0xb6eddea7 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#30 0xb6f5125e in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#31 0xb6f5106e in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#32 0xb6f38731 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#33 0x0805ad81 in ?? ()
#34 0xbfde24f0 in ?? ()
#35 0x00000001 in ?? ()
#36 0x00000001 in ?? ()
#37 0x00000000 in ?? ()

Sorry, hope it helps anyway...

Jan
Comment 1 Tommi Tervo 2007-03-26 13:00:18 UTC

*** This bug has been marked as a duplicate of 106030 ***