Bug 116946

Summary: include kate project management from kde3.4 as option
Product: [Applications] kate Reporter: Christian Schulze <lynx>
Component: generalAssignee: KWrite Developers <kwrite-bugs-null>
Status: RESOLVED FIXED    
Severity: wishlist CC: burningice, kari.argillander, seem.iges
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: openSUSE   
OS: Linux   
URL: http://kate-editor.org/2012/08/12/project-management-take-three/
Latest Commit: Version Fixed In: 4.10
Attachments: patch

Description Christian Schulze 2005-11-23 14:31:56 UTC
Version:            (using KDE KDE 3.5.0)
Installed from:    SuSE RPMs
OS:                Linux

Since i was heavily using the project management of kate in kde3.4, i would like to have an option for that in the settings-menu. A plugin which includes/restores the project management would be fine too.
At the moment i can't see the advantage of the new session management, at least it's harder to use.

It would be nice to choose between them!
Comment 1 Hogne Titlestad 2005-12-02 10:10:09 UTC
Yes, the project management system should rather be extended than removed. 
Comment 2 Christian Loose 2005-12-02 14:00:05 UTC
*** Bug 117396 has been marked as a duplicate of this bug. ***
Comment 3 cedric 2005-12-03 00:27:53 UTC
I vote for this bug because I really often use the project management in Kate, and I currently have many kate projects that are unusable !
The tree view of the project was good and I really don't like to keep open all files that I want to use ! This cause some kate plugins like "file tab" unusable.

Please, at least provide a plugin to re-enable it !
Comment 4 onsen-neko 2005-12-04 11:18:24 UTC
I Agree. The sessionmanagment is horrible and completly unusable for greater projects. The project-extensions allow me to choose a single file from a set of files, but a session open ALL files of the set :(
Comment 5 Mathias Kraus 2005-12-07 17:20:58 UTC
*** This bug has been confirmed by popular vote. ***
Comment 6 Mathias Kraus 2005-12-07 17:22:04 UTC
I Agree. The project management was very comfortable and I would appreciate if it came back.
Comment 7 onsen-neko 2006-01-09 16:04:19 UTC
Under http://bugs.kde.org/show_bug.cgi?id=119800 i have set an alternative idea for the missing project management.
Comment 8 Kevin Krammer 2006-01-24 01:32:23 UTC
I have just voted for this one as well and downgraded to my older version from 3.4.3

As an interim workaround it would be nice if the session could at least save the directory of the file browsing plugin in the sidebar

Christoph is still my personal KDE super hero but Aaron gets a lot closer after this :)
Comment 9 Anders Lund 2006-01-24 13:43:13 UTC
On Tuesday 24 January 2006 01:32, Kevin Krammer wrote:
> As an interim workaround it would be nice if the session could at least
> save the directory of the file browsing plugin in the sidebar


I have that on my list of improvements to make (along with other things that 
should be (optionally) saved with sessions.
Comment 10 Ranma 2006-01-25 02:44:55 UTC
Same here, I was going to start working in my project today after the upgrade and couldn't open my project file. I just cannot see how sessions can be a replacement for the kate projects. Please return this feature.
Is there a patch or something we could use to re-enable this feature in this relase?
BTW, this isn't noted in the Changelog!!, I always read the changelog for the applications I use most before upgrading and there is no notice of this.
Comment 11 Martin Baute 2006-06-12 09:43:24 UTC
> *** This bug has been confirmed by popular vote. *** 

It would be nice to hear some feedback on this. Why was the feature removed in the first place? It cannot be that an upgrade of a frequently-used application breaks a major feature without so much as a changelog entry (or a statement by the maintainers on a bug that "has been confirmed by popular vote" but otherwise gone without feedback for half a year.

Kate project management worked just fine for me. Now I had to spend an hour or so importing my project to Eclipse because suddenly KDE is without a project-capable text editor...
Comment 12 David Priebel 2006-06-16 05:16:56 UTC
I too would like to see the feature back.  I work on programs with hundreds of source files in many directories and interspersed are files other than sources.  The ability to only add certain files and have them in the tree structure allowed me to switch between sources easily and only show the sources I was actually working on or needed to look at rather than everything.

I like the style of a project better than sessions because the way it organized the files and facilitated opening more sources.  That and an actual physical file being placed in the directory (other users can open it up).
Comment 13 Dominik Haumann 2006-07-07 11:59:49 UTC
Lars and Christian have written a projectmanager plugin for Kate in KDE 3.5. It works pretty well but still could need some love ;) It does not support the projects from <= KDE 3.4. You can temporarily download it here:
http://www.gmdsoft.de/haumann/kde/projectmanager-0.1.tar.gz

Both Lars and Christian said they do not have much time to further work on it, so if anyone wants to pick it up go ahead - and please share your improvements you make :)
Comment 14 cedric 2006-07-08 18:08:05 UTC
Created attachment 16925 [details]
patch

I write a little patch that fix some bugs ad add some features :

- save a correct project file with recursive folders. I use a recursive
function to avoid problems and write more clear code.
- show the file extension in the view, and save them in the project file.
- set correctly the directory for the openfile/directory dialog box
- use a kdialog instead of a qdialog based widget to create a new project.
- automatically add .kateprj extention to the project file.
- dont clear the current workspace when create a new workspace
- forbid to open the workspace
~/.kde/share/apps/kate/projects/kateprojectmanager.xml
- give the possibility to add multiple files in one time in one directory.

apply it to the original package provided by Dominik Haumann.
if you encouter problems or bugs with this patch, let me know it.

thank to Lars and Christian for providing this nice project managment plugin
for kate :)
Comment 15 Dominik Haumann 2006-07-20 18:18:09 UTC
Just for info, the plugin moved to sf and kde-apps:
- http://www.kde-apps.org/content/show.php?content=42653
- http://sourceforge.net/projects/kate-prj-mng/
Comment 16 Kari Argillander 2009-01-11 00:55:19 UTC
I don't see any port of this in KDE4 we need it, please.
Comment 17 Wolfgang Wallner 2009-06-09 23:29:04 UTC
Confirming the Kari Argillander's statement. I'm using Kate 3.2.3 (KDE 4.2.3) and tried to compile and install the current version of the kate-project-plugin, but I had no success.

On the sourceforge page of the plugin a KDE4 version was announced, but there has not been any developtment activity for years now :(

Is there really no way include project support in the mainline of kate, just as it was back in KDE 3.4?

Projects are very usefull, especially if you are working on the same file on different computers, because the project information was stored within the project folder.
With session, this information is stored somewhere in .kde/share/apps/kate/sessions and there is no easy way to just unplug an USB memory stick, go somewhere else, and continue the work on another computer.

nice greets
Comment 18 Andreas Pakulat 2009-06-09 23:42:08 UTC
(In reply to comment #17)
> On the sourceforge page of the plugin a KDE4 version was announced, but there
> has not been any developtment activity for years now :(
> 
> Is there really no way include project support in the mainline of kate, just as
> it was back in KDE 3.4?

No, because apparently there's nobody interested in doing the work. Ten thousand users wanting a feature doesn't mean anything in open source world if there's no developer wanting to actually implement the feature.
Comment 19 Dominik Haumann 2012-08-16 08:36:31 UTC
In KDE 4.10, there will be a Projects plugin again:
- http://kate-editor.org/2012/08/05/project-management/
- http://kate-editor.org/2012/08/06/project-management-take-two/
- http://kate-editor.org/2012/08/12/project-management-take-three/

It even is integrated with other plugins such as Search & Replace or the Build Plugin.

You can try it already now by following http://kate-editor.org/get-it/
Feedback is very much appreciated.