Version: 1.5.0 (using KDE KDE 3.5.8) Installed from: Compiled From Sources Compiler: gcc (GCC) 4.1.2 OS: Linux Changing the "Unique name" of a power spectrum doesn't change the names of the spectrum's slave vectors. Steps to reproduce: 1. Create and plot a power spectrum, and note it's name (say, "foo"). 2. Edit Spectrum -> change "Unique Name" to something else (say, "bar"). 3. Open, say, the Edit Curve dialogue for the spectrum and note the X and Y vectors associated with the curve, which are the slave vectors of the spectrum. Result: Although the spectrum is now called "bar", the slave vectors associated with it are still called "foo/freq" and "foo/sv" (as evident in the Edit Curve dialogue). Expected Result: Name changes should propagate to slave vectors, so these should be called "bar/freq" and "bar/sv".
Additionally, this behaviour is copied to the .kst file, corrupting it.
This is caused by problems with the hierarchical naming scheme and is also a problem for histograms, spectrograms, and plugins - possible more.
SVN commit 745324 by arwalker: CCBUG:153153 fix hierarchical naming structure for spectra, histograms, and spectrograms M +1 -1 libkstapp/kstcsddialog_i.cpp M +3 -3 libkstapp/ksteqdialog_i.cpp M +4 -1 libkstapp/ksthsdialog_i.cpp M +1 -1 libkstapp/kstpsddialog_i.cpp M +14 -1 libkstmath/kstcsd.cpp M +2 -0 libkstmath/kstcsd.h M +21 -28 libkstmath/kstequation.cpp M +14 -2 libkstmath/ksthistogram.cpp M +2 -0 libkstmath/ksthistogram.h M +19 -7 libkstmath/kstpsd.cpp M +8 -6 libkstmath/kstpsd.h WebSVN link: http://websvn.kde.org/?view=rev&revision=745324
SVN commit 745352 by arwalker: CCBUG:153153 Fix hierarchical naming convention for vectorView, basicPlugin, and cPlugin M +0 -2 libkst/kstobject.h M +1 -2 libkstapp/kstbasicdialog_i.cpp M +1 -4 libkstapp/kstplugindialog_i.cpp M +4 -1 libkstapp/kstvvdialog_i.cpp M +27 -1 libkstmath/kstbasicplugin.cpp M +3 -2 libkstmath/kstbasicplugin.h M +30 -6 libkstmath/kstcplugin.cpp M +4 -3 libkstmath/kstcplugin.h M +38 -1 libkstmath/kstvectorview.cpp M +2 -0 libkstmath/kstvectorview.h WebSVN link: http://websvn.kde.org/?view=rev&revision=745352
SVN commit 745668 by arwalker: BUG:153153 Fix hierarchical naming convention for event monitor M +9 -9 ksteventmonitor_i.cpp M +19 -9 ksteventmonitorentry.cpp M +4 -3 ksteventmonitorentry.h WebSVN link: http://websvn.kde.org/?view=rev&revision=745668