Bug 99653 - Adding option to show tray icon only for unread feeds (like kmail)
Summary: Adding option to show tray icon only for unread feeds (like kmail)
Status: RESOLVED WORKSFORME
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist with 86 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 145729 184547 198336 203307 267582 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-02-18 01:30 UTC by Fabio Rossi
Modified: 2014-01-16 14:12 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabio Rossi 2005-02-18 01:30:05 UTC
Version:            (using KDE KDE 3.3.2)
Installed from:    Gentoo Packages

I would like to see an option for the system tray icon of akregator (stand alone or inside kontact). Is it possible to show the tray icon only when there are unread feeds (with a counter)? This behaviour would be like that of kmail.
Comment 1 Jason 'vanRijn' Kasper 2005-07-29 00:19:28 UTC
Just voted for this, and would really like to see this happen.  If someone can find the relevant code in kmail that does this functionality, I would try to find time making a patch for this in akregator.  

Thanks aKregator haxx0rz!  =:)
Comment 2 greatbunzinni 2005-09-11 21:52:23 UTC
*** This bug has been confirmed by popular vote. ***
Comment 3 Juha Tuomala 2008-10-12 13:12:14 UTC
I think this has been solved already, bug report is so old that perhaps it has just been forgotten?
Comment 4 Juha Tuomala 2008-10-12 13:16:36 UTC
Settings -> General -> "Show tray icon"
Comment 5 Fabio Rossi 2008-10-12 13:27:20 UTC
Which version are you using? I'm still with KDE 3.5.9...
Comment 6 Juha Tuomala 2008-10-12 13:41:30 UTC
I've kde 4.1.2 now but I think this was available in 3.5.x too.
Comment 7 Fabio Rossi 2008-10-12 14:10:17 UTC
My request was about an option to have the tray icon visible only when there are unread feeds, now the icon is always visible also without feeds to read.
Comment 8 Pascal d'Hermilly 2009-01-19 23:51:08 UTC
*** Bug 145729 has been marked as a duplicate of this bug. ***
Comment 9 Jonathan Marten 2009-02-17 16:55:28 UTC
*** Bug 184547 has been marked as a duplicate of this bug. ***
Comment 10 Ben Boeckel 2009-05-28 06:16:28 UTC
Could KNode also get a tray icon and act as KMail? Should I open another bug for KNode?
Comment 11 Christophe Giboudeaux 2009-07-04 16:30:44 UTC
*** Bug 198336 has been marked as a duplicate of this bug. ***
Comment 12 Christophe Giboudeaux 2010-03-29 00:49:34 UTC
*** Bug 203307 has been marked as a duplicate of this bug. ***
Comment 13 Christophe Giboudeaux 2011-03-03 22:28:32 UTC
*** Bug 267582 has been marked as a duplicate of this bug. ***
Comment 14 Todd 2011-03-03 22:34:12 UTC
This should be possible with the new notification spec, and it is easy to override if someone wants to show it all the time.
Comment 15 Todd 2011-09-05 09:05:30 UTC
I don't think it even needs to be an option, since the system tray has a built-in option that lets users always show or always hide the icon.  Akregator would just need to tell the system tray that it isn't important when there are no unread messages, and the user can decide what to do.

Aaron recently put a call out for developers to fix these sorts of issues:
http://aseigo.blogspot.com/2011/08/system-tray-icon-hiding.html
Comment 16 Maarten De Meyer 2014-01-16 14:12:57 UTC
Recent version of akregator is only visible in the tray when there are unread articles. (4.12.60)

Thanks.