Bug 98482 - Freeze while restoring session, if MySQL support is enabled
Summary: Freeze while restoring session, if MySQL support is enabled
Status: RESOLVED NOT A BUG
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-02-03 08:59 UTC by Vlad Grigorescu
Modified: 2006-06-11 12:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vlad Grigorescu 2005-02-03 08:59:18 UTC
Version:            (using KDE KDE 3.3.2)
Installed from:    Compiled From Sources
Compiler:          GCC 3.4.3.20050110 
OS:                Linux

Built amarok 1.2 Beta 4, using "./configure --enable-mysql".  It worked fine the first time it ran.  After shutting down my computer, and trying to start it again, it froze everything, keyboard, mouse, CTRL+ALT+BKSPACE wouldn't work.  I have reconfigured it without mysql support, and it ran fine.  

amarok 2>amarok.log:

http://www.grigorescu.org/amarok2.log
Comment 1 Sami Nieminen 2005-02-06 17:58:19 UTC
It seems like your MySQL database is broken: "MYSQL QUERY FAILED: Can't open file: 'statistics.MYI'. (errno: 145)". You could try to create a new database and see if you still get the same problem.

Of course it should not cause all those problems you had, but I wonder if those were really because of amarok...
Comment 2 Vlad Grigorescu 2005-02-06 18:01:36 UTC
But it worked fine with amarok 1.2 beta3, and I haven't changed anything in MySQL between installations.
Comment 3 Greg Meyer 2005-03-19 06:44:20 UTC
Can you please try and reproduce with current cvs or maybe 1.2.2? Thanks.
Comment 4 Alexandre Oliveira 2005-03-20 02:07:21 UTC
That "Can't open file: 'statistics.MYI'" is a MySQL error.

Try to repair the table:
$ mysql -p -u amarok
(Opens a command line client for mysql, change amarok to whatever you user is called. It will prompt for your password.)
USE amarokdb;
(Again, change amarokdb to whatever you use.)
REPAIR TABLE statistics EXTENDED;
(You need lots of free disk space to that on huge databases. Do the same for other tables that gives you the same error message.)
(If you get any error while trying to repair, just drop the table:)
DROP TABLE statistics;
(And reescan your collection.)

drop will delete the table, what is a problem only for the statistics one (as you will lose all stats), but at least that you'll make things work again.

I'd close this, as it's a MySQL problem, not amaroK's fault, but amaroK shouldn't freeze when getting these errors from the db, it should report them to the user and keep going without a collection. Opinions?
Comment 5 Ian Monroe 2005-03-20 02:44:34 UTC
There is a definite need for more error handling in the database code. Currently only the mysql database has some when it tries to connect. I'll take a look, I think its probably something best left for 1.3.
Comment 6 Alexandre Oliveira 2005-06-27 06:05:14 UTC
No reason to keep this open, it was invalid.