Bug 97568 - Clicking on a partially-scrolled-off tab closes it (if close button on right is enabled)
Summary: Clicking on a partially-scrolled-off tab closes it (if close button on right ...
Status: RESOLVED FIXED
Alias: None
Product: konversation
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konversation Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-21 02:11 UTC by Nathaniel W. Turner
Modified: 2006-04-27 11:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nathaniel W. Turner 2005-01-21 02:11:20 UTC
Version:           0.16 #2075 (using KDE 3.3.2,  (3.1))
Compiler:          gcc version 3.3.5 (Debian 1:3.3.5-6)
OS:                Linux (i686) release 2.6.8-2-k7

This was filed in the Debian BTS, and I've confirmed that the behavior still exists in today's CVS build:

If you configure konversation to put close buttons on the right of each tab, and there is a tab that is partially hidden on the right side of the tab bar, and you click on the visible part of the tab to activate it (which doesn't have a close button), it will zoom to the left and your click will be sent to the close button and the tab will close.
Comment 1 Ismail Donmez 2005-08-07 15:10:14 UTC
This is now fixed.
Comment 2 Nathaniel W. Turner 2005-08-07 20:08:01 UTC
cartman, can you explain how this is fixed?  the setting in question now appears to do nothing -- is that what you mean?  If so, I don't mind losing this "feature", but it should be done cleanly; the checkboxes should be removed from the prefs dialog, too.
Comment 3 Ismail Donmez 2005-08-07 20:25:27 UTC
You are right nturner. I overlooked that. Sorry.
Comment 4 Ismail Donmez 2005-12-15 17:46:23 UTC
Re-assign.
Comment 5 Eike Hein 2006-01-07 06:19:02 UTC
*** Bug has been marked as fixed ***.
Comment 6 Nathaniel W. Turner 2006-02-01 18:44:49 UTC
I am concerned that this bug has not been addressed properly.  There is currently a checkbox under "Tab Bar" called "Show close button on the right side of the tab bar".  Checking this box has no effect.

I cannot, therefore, check to see if *this* bug has been fixed because of that bug.  I'm concerned that if that bug (the checkbox that does nothing) is fixed such that that checkbox does something again, *this* bug will reappear.

Please either remove the checkbox setting that does nothing, or make it do something again (and if you do the latter, please check that *this* bug is really fixed, and let me know so I can close the corresponding Debian bug report.)

Cheers, and thanks for your hard work,
nate
Comment 7 Eike Hein 2006-02-01 19:48:58 UTC
The checkbox you mention works fine for me, I am unable to reproduce any problems with it.