Bug 95690 - [test case]background-images don't appear for input elements
Summary: [test case]background-images don't appear for input elements
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Unclassified
Component: khtml renderer (show other bugs)
Version: 3.3.1
Platform: Debian testing Linux
: NOR wishlist with 125 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 75756 115110 115846 116935 118817 129208 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-12-22 20:51 UTC by Brian Beck
Modified: 2008-02-19 20:05 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
A simple HTML page to test the backgound-image property (197 bytes, text/html)
2004-12-22 20:53 UTC, Brian Beck
Details
The background-image that the site and the test page uses (138 bytes, image/gif)
2004-12-22 20:54 UTC, Brian Beck
Details
Screenshot of how Konqueror renders the input elements (216.22 KB, image/png)
2004-12-22 20:59 UTC, Brian Beck
Details
Screenshot of how Firefox renders the input elements (222.64 KB, image/png)
2004-12-22 21:01 UTC, Brian Beck
Details
Easier test case (274 bytes, text/html)
2005-08-04 15:30 UTC, Tommi Tervo
Details
background-image bug for input field (50.22 KB, image/jpeg)
2006-10-20 12:04 UTC, Rene Plattner
Details
textarea testcase (271 bytes, text/html)
2007-08-16 22:08 UTC, Guillaume Martres
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Beck 2004-12-22 20:51:37 UTC
Version:           3.3.1 (using KDE KDE 3.3.1)
Installed from:    Debian testing/unstable Packages
Compiler:          gcc version 3.3.5 (Debian 1:3.3.5-4) 
OS:                Linux

The input elements on the http://www.buyblue.org/ website are set to have a background image.  The inputs are located on the upper right hand side of the page.  The background-image displays in IE6 and Firefox, but not Konqueror.  Here is an example of one of the input elements:

<input type="text" name="attribute4" />

The css that defines the input element looks like this:

input {
      background-image: url(images/form_bggradient.gif);
      background-repeat: repeat-x;
      border: 1px solid #0A51A1;
      width: 130px;
      font-family:Arial, Helvetica, sans-serif;
      color:#000000;
      margin: 2px;
}

I tried removing all the attributes except the background-image to see if there was some sort of conflict, but still it did not work.

I made a dumbed down version of the page (only the input with the style, and still it didn't work.)

I tried using another widget set thinking the problem may lay there, but it didn't work.  (I am using Plastik, and I changed to Keramik.)

Thank you for looking at this.
Comment 1 Brian Beck 2004-12-22 20:53:16 UTC
Created attachment 8775 [details]
A simple HTML page to test the backgound-image property
Comment 2 Brian Beck 2004-12-22 20:54:26 UTC
Created attachment 8776 [details]
The background-image that the site and the test page uses
Comment 3 Brian Beck 2004-12-22 20:59:50 UTC
Created attachment 8777 [details]
Screenshot of how Konqueror renders the input elements
Comment 4 Brian Beck 2004-12-22 21:01:00 UTC
Created attachment 8778 [details]
Screenshot of how Firefox renders the input elements
Comment 5 Tommi Tervo 2005-08-04 15:30:05 UTC
Created attachment 12079 [details]
Easier test case
Comment 6 Allan Sandfeld 2005-08-04 16:02:22 UTC
CSS on form elements is optional.
Comment 7 Tommi Tervo 2005-08-17 15:14:03 UTC
*** Bug 75756 has been marked as a duplicate of this bug. ***
Comment 8 Maksim Orlovich 2005-10-26 14:47:44 UTC
*** Bug 115110 has been marked as a duplicate of this bug. ***
Comment 9 Tommi Tervo 2005-11-07 10:20:47 UTC
*** Bug 115846 has been marked as a duplicate of this bug. ***
Comment 10 Tommi Tervo 2005-11-23 16:14:08 UTC
*** Bug 116935 has been marked as a duplicate of this bug. ***
Comment 11 Tommi Tervo 2005-12-22 09:32:17 UTC
*** Bug 118817 has been marked as a duplicate of this bug. ***
Comment 12 hanno 2006-01-09 16:43:41 UTC
Although CSS is optional on forms, this is a bug, because khtml only ignores some of them.

A good example to see this is www.onlinetvrecorder.com, where you have a form with a background-image and white text on it. khtml ignores the background-image, but interprets the white text, so you have white-on-white.

This wouldn't be a problem if khtml would ignore css completely on the form - but this half-implementation causes problems.
Comment 13 sts 2006-02-10 10:49:20 UTC
reporter.. please change the status from wish to bug!
Comment 14 Allan Sandfeld 2006-02-11 14:46:14 UTC
CSS is not designed to be applied for form controls. The look and feel of form controls is fully up to the browser. It is however defacto standard to apply as many CSS properties as possible in the native widgets.

New standards such as WebForms is trying hard to overcome this unspecified area. The following paragraph is from WebForm 2 from the 10th january 2006:

8.1. Styling form controls
The CSS working group is expected to develop a language designed, amongst other things, for the advanced styling of form controls. In the meantime, technologies such as [HTC] and [XBL] can be used as guides for what is expected. 
UAs, in the absence of such advanced styling information, may render form controls described in this draft as they wish. It is recommended that form controls remain faithful to the look and feel of the system's global user interface. 
CSS 2.1 explicitly does not define how CSS applies to form controls. [CSS21]

--

As for www.onlinetvrecorder.com. They should as always have defined a fallback background-color in case the background-image fails to load.
Comment 15 Pete 2006-07-10 03:02:08 UTC
This is really annoying, the background image does get applied while the page is rendering, but once that is done it is removed again!
Comment 16 Rene Plattner 2006-10-20 11:59:10 UTC
I also have the problem that konqueror doesn't show the background image (png) of an input field at my homepage (http://www.fczirl.at)!
Comment 17 Rene Plattner 2006-10-20 12:04:13 UTC
Created attachment 18200 [details]
background-image bug for input field

Screenshot of KHTML Bug! KHTML renderer cannot display background image in
input field.  source: http://www.fczirl.at
Comment 18 arne anka 2006-11-23 10:11:08 UTC
still true for konqueror 3.5.5 of debian/sid.
especially annoying because there seems to be no mechanism to provide some kind of alternative information if the iamge is not rendered.
i use <input type='button'> w/ background-image as icon and konqueror not rendering the image leaves the user w/ a blank button (type='image' is not an option).
Comment 19 illogic-al 2007-01-06 17:08:10 UTC
*** Bug 129208 has been marked as a duplicate of this bug. ***
Comment 20 Germain Garand 2007-01-13 02:43:06 UTC
SVN commit 622796 by ggarand:

allow full styling of the background of form controls

BUG: 95690, 94646



 M  +1 -8      css/cssstyleselector.cpp  
 M  +23 -0     css/html4.css  
 M  +4 -0      css/quirks.css  
 M  +9 -8      rendering/render_box.cpp  
 M  +3 -2      rendering/render_box.h  
 M  +4 -2      rendering/render_line.cpp  
 M  +2 -2      rendering/render_object.h  
 M  +54 -34    rendering/render_replaced.cpp  
 M  +11 -1     rendering/render_replaced.h  
Comment 21 Guillaume Martres 2007-08-16 21:54:51 UTC
This bug is marked as fixed but it is still present in Konqueror 3.5.7, the same problem appear with background-image of textarea(see for example http://www.mario-museum.net/forum/?f=2&view=46&pg=end#last )
Comment 22 Guillaume Martres 2007-08-16 22:05:07 UTC
oops, the testcase doesn't work because http://www.buyblue.org/images/form_bggradient.gif but the problem still exists with button (see http://bugs.kde.org/show_bug.cgi?id=115846 ) and textarea(I'll attach a testcase).
Comment 23 Guillaume Martres 2007-08-16 22:08:47 UTC
Created attachment 21408 [details]
textarea testcase
Comment 24 Peter Thomassen 2008-02-19 18:03:39 UTC
Is there any progress regarding this bug? I'd also like to see it fixed, because p.ex. in http://www.daniel-hechter-news.de/empfehlen/ you must guess where data is to be entered.

Thanks,
Peter
Comment 25 Peter Thomassen 2008-02-19 18:05:22 UTC
Please reopen.
Comment 26 Daniel Mircea 2008-02-19 18:37:09 UTC
It's quite interesting that once this was fixed, it was quickly implemented in webkit (Safari 3) yet here we are, one year later - still not working.
Suffice to say it will work in kde 4.1, if konqueror will use webkit rather than khtml.
Comment 27 Maksim Orlovich 2008-02-19 20:05:42 UTC
Works perfectly fine in 4.0.1.