Bug 95050 - aKregator needs a handbook
Summary: aKregator needs a handbook
Status: RESOLVED FIXED
Alias: None
Product: docs.kde.org
Classification: Websites
Component: general (show other bugs)
Version: 0.5
Platform: unspecified Linux
: NOR wishlist with 10 votes (vote)
Target Milestone: ---
Assignee: aKregator haxx0rz
URL:
Keywords:
: 138222 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-12-13 07:34 UTC by Luther
Modified: 2007-07-28 23:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luther 2004-12-13 07:34:35 UTC
Version:           1.0-beta8 (using KDE 3.3.1,  (3.1))
Compiler:          gcc version 3.3.5 (Debian 1:3.3.5-3)
OS:                Linux (i686) release 2.4.26

aKregator Handbook (F1 Help file) appears not to be installed with beta7 and beta8.

The Help/aKregator Handbook link should be removed (or temporarily hidden) or a temporary placeholder help file written and included with the package to fulfil the link and F1 keystroke call.
Comment 1 Lauri Watts 2005-01-04 01:14:13 UTC
Usual placeholder made for 3.4, to commit after freeze is done. 

Still urgently needs documentation written though.
Comment 2 Philip Rodrigues 2005-07-28 16:00:33 UTC
The beginnings of a handbook are at http://akregator.pwsp.net/wiki/Handbook?v=104g . I will convert what's done so far to docbook, then it's back to the akregator devels.
Comment 3 Philip Rodrigues 2005-12-15 16:15:36 UTC
"akregator haxx0rz," did I do what I offered to in #2? (I can't remember now). If not, please ping me and I should have time to do it.
Comment 4 Frank Osterfeld 2005-12-15 18:24:50 UTC
No, iirc we said that I should provide screenshots and that you would convert the stuff in the wiki. And then time passed...
Comment 5 Philip Rodrigues 2006-12-02 22:39:51 UTC
*** Bug 138222 has been marked as a duplicate of this bug. ***
Comment 6 Anne-Marie Mahfouf 2006-12-03 09:45:01 UTC
OK, I found the wiki doc which is a start. I'll convert it to docbook to see what it looks like.
In Configuration Options I'd like a few precisions about the Advanced tab (Archive choice: what is it for? How do you Configure it?)
Also a few lines about Konqueror plugins and command line options.
I note there is no QWhatsThis help either so users have no hints at all about the options.

I am not sure what can be included in KDE 3.5.6 considering the translators will have to do it all from scratch... If nothing is included, KHelpCenter should be fixed so when you click on Applications -> Internet -> Akregator it should not return an error.
Comment 7 Anne-Marie Mahfouf 2006-12-03 19:27:46 UTC
SVN commit 610046 by annma:

forward port of fixing akregator doc in KHelpCenter
CCBUG=95050


 M  +1 -1      akregator.desktop  


--- trunk/KDE/kdepim/akregator/src/akregator.desktop #610045:610046
@@ -5,7 +5,7 @@
 Exec=akregator %i -caption "%c"
 Icon=akregator
 Type=Application
-DocPath=akregator/akregator.html
+DocPath=akregator/index.html
 GenericName=RSS Feed Reader
 GenericName[fr]=Lecteur de flux RSS
 GenericName[x-test]=xxRSS Feed Readerxx
Comment 8 Anne-Marie Mahfouf 2006-12-03 20:10:45 UTC
SVN commit 610044 by annma:

fix doc not found in KHelpCenter when browsing applications manuals
CCBUG=95050


 M  +1 -1      akregator.desktop  


--- branches/KDE/3.5/kdepim/akregator/src/akregator.desktop #610043:610044
@@ -4,7 +4,7 @@
 Exec=akregator %i %m -caption "%c"
 Icon=akregator
 Type=Application
-DocPath=akregator/akregator.html
+DocPath=akregator/index.html
 GenericName=RSS Feed Reader
 GenericName[bg]=Четец на новости RSS
 GenericName[ca]=Lector d'enllaços RSS
Comment 9 Anne-Marie Mahfouf 2006-12-10 17:29:10 UTC
I forgot to CC this bug report but I committed to trunk the start of Akregator manual.
See http://lists.kde.org/?l=kde-commits&m=116576795703930&w=2

If the translators agree, I'll commit to 3.5 branch but maybe it'll be too much work for them.
Comment 10 Anne-Marie Mahfouf 2006-12-11 13:59:05 UTC
SVN commit 612438 by annma:

Add Akregator User Manual, not complete but a good start
Got green light from translators
CCBUG=95050


 AM            add-feed.png  
 AM            add-feed2.png  
 AM            add-folder.png  
 AM            add-folder2.png  
 AM            advanced-tab.png  
 AM            appearance-tab.png  
 AM            archive-tab.png  
 AM            browser-tab.png  
 AM            general-tab.png  
 M  +1109 -23  index.docbook  
 AM            main-window.png  
 AM            main-window2.png  
 AM            main-window3.png  
 AM            main-window4.png  
 AM            quick-filter.png  
Comment 11 Richard Johnson 2007-07-28 23:06:26 UTC
Handbook is in 3.5.x and looks complete. If it is not, I urge you to reopen this report if need be. Thanks.