Bug 94646 - [test case] css property background-color "transparent" not working on submit button
Summary: [test case] css property background-color "transparent" not working on submit...
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Unclassified
Component: khtml forms (show other bugs)
Version: 3.2.2
Platform: unspecified Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 96106 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-12-08 03:40 UTC by Simeon Lodge
Modified: 2007-01-13 02:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
test case (207 bytes, text/html)
2005-08-18 12:40 UTC, Tommi Tervo
Details
same testcase, remove typo preventing it to work. "type/ccs" => "type/css" (207 bytes, text/html)
2007-01-13 02:36 UTC, Germain Garand
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simeon Lodge 2004-12-08 03:40:30 UTC
Version:           3.2.2 (using KDE 3.2.2,  (testing/unstable))
Compiler:          gcc version 3.3.3 (Debian 20040401)
OS:                Linux (i686) release 2.4.25-1-386

[class definition]

input.button {
        font-size: 8pt;
        border-style: none;
        border-width: 0px;
        background-color: transparent;
        padding: 0.1ex;
        text-decoration: none;
        color: purple;
        font-weight: bold;
        text-transform: capitalize;
}

[html]

<input name="search" value="search &gt;&gt;" type="submit" class="button">

The intention is to make the submit button disappear leaving just the text (I want my buttons and links to be visually similar), however I get a regular grey button with a regular border.  Other properties like font size and color are working however.
Comment 1 Simeon Lodge 2004-12-08 03:45:21 UTC
Actually, now that I look more closely, the capitalize property isn't working either.
Comment 2 Maksim Orlovich 2005-01-01 17:41:22 UTC
*** Bug 96106 has been marked as a duplicate of this bug. ***
Comment 3 Tommi Tervo 2005-08-18 12:40:34 UTC
Created attachment 12252 [details]
test case
Comment 4 Germain Garand 2007-01-13 02:36:54 UTC
Created attachment 19264 [details]
same testcase, remove typo preventing it to work. "type/ccs" => "type/css"
Comment 5 Germain Garand 2007-01-13 02:43:06 UTC
SVN commit 622796 by ggarand:

allow full styling of the background of form controls

BUG: 95690, 94646



 M  +1 -8      css/cssstyleselector.cpp  
 M  +23 -0     css/html4.css  
 M  +4 -0      css/quirks.css  
 M  +9 -8      rendering/render_box.cpp  
 M  +3 -2      rendering/render_box.h  
 M  +4 -2      rendering/render_line.cpp  
 M  +2 -2      rendering/render_object.h  
 M  +54 -34    rendering/render_replaced.cpp  
 M  +11 -1     rendering/render_replaced.h