Bug 94134 - malic acid (level 19) missing a OH bit?
Summary: malic acid (level 19) missing a OH bit?
Status: RESOLVED FIXED
Alias: None
Product: katomic
Classification: Applications
Component: general (show other bugs)
Version: 2.0
Platform: unspecified Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Dave Corrie
URL:
Keywords:
: 94133 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-11-29 21:41 UTC by Ana Guerrero (Debian KDE maintainers)
Modified: 2006-04-27 11:12 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ana Guerrero (Debian KDE maintainers) 2004-11-29 21:41:43 UTC
Version:           2.0 (using KDE 3.3.1,  (3.1))
Compiler:          gcc version 3.3.5 (Debian 1:3.3.5-2)
OS:                Linux (i686) release 2.6.9-1-686

[this is Debian Bug#283486, http://bugs.debian.org/283486, submitted by Adrian 'Dagurashibanipal' von Bidder <avbidder@fortytwo.ch>.]

Hi,

I just noticed that malic acid (level 19) is not, according to
wikipedia, the chemical compound that is asked for in that level.

greetings
-- vbi

<http://en.wikipedia.org/wiki/Malic_acid>

* * *

It seems to me that a missing O-H is missing in one of the Carbon atoms, if Wikipedia is correct.
Comment 1 Adeodato Simó 2004-11-29 21:43:07 UTC
*** Bug 94133 has been marked as a duplicate of this bug. ***
Comment 2 Albert Astals Cid 2005-02-20 13:09:10 UTC
You can see http://www.fao.org/documents/show_cdr.asp?url_file=/DOCREP/X3860E/X3860E24.htm has the same structural formula as wikipedia article
Comment 3 Dave Corrie 2005-08-13 22:57:36 UTC
I am not a chemist, but... the molecule shown in level 19 appears to be Oxalic Acid:

http://www.chemicalland21.com/arokorhi/industrialchem/organic/OXALIC%20ACID.htm
http://chemistry.about.com/library/graphics/bloxalic.htm
http://en.wikipedia.org/wiki/Oxalic_acid

If noone objects then I'll change the name of the level to 'Oxalic Acid' in a few days time. This avoids altering the level which would make the game play differently. And we can always add a level for Malic Acid in future...
Comment 4 Nicolas L. 2005-08-23 17:11:57 UTC
please change the name you're absolutly right this is not malic acid but as you told oxalic acid. I am 100% certain of that :)
Comment 5 Dave Corrie 2005-08-26 01:38:25 UTC
SVN commit 453359 by davec:

Correct name of molecule.
BUG: 94134


 M  +1 -1      level_19  


--- branches/KDE/3.5/kdegames/katomic/levels/level_19 #453358:453359
@@ -1,5 +1,5 @@
 [Level]
-Name=Malic Acid
+Name=Oxalic Acid
 atom_1=3-D
 atom_2=2-ceD
 atom_3=3-ae