Bug 92898 - kwallet integration in krdc
Summary: kwallet integration in krdc
Status: RESOLVED FIXED
Alias: None
Product: krdc
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: RedHat Enterprise Linux Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Jaison Lee
URL:
Keywords:
: 114660 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-11-08 10:35 UTC by David Anderson
Modified: 2005-10-20 21:25 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Anderson 2004-11-08 10:35:33 UTC
Version:            (using KDE KDE 3.3.1)
Installed from:    RedHat RPMs
OS:                Linux

Krdc doesn't appear to have any integration with kwallet.

As a sysadmin, I have at least a dozen remote VNC servers that I need to be able to log in to. Regularly I have to open my password spreadsheet to look them up...

Integration with kwallet would be very useful, time-saving, and more secure.
Comment 1 Martin Koller 2005-01-18 15:20:32 UTC
*** This bug has been confirmed by popular vote. ***
Comment 2 David Anderson 2005-02-21 13:55:35 UTC
Hey Mr. maintainer, I note that this RFE is now the most of all open tickets for krdc... 
http://bugs.kde.org/buglist.cgi?short_desc_type=allwordssubstr&short_desc=&long_desc_type=allwordssubstr&long_desc=&product=krdc&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&bugidtype=include&bug_id=&votes=1&chfieldvalue=&order=bugs.votes

Can you give us any encouragement about whether it's a planned feature or not?
Comment 3 tim 2005-02-21 17:59:25 UTC
I don't have any feature plans right now, and I am not going to maintain krdc after KDE's 3.x cycle. 

Patches are always welcome, of course :)
Comment 4 Jaison Lee 2005-06-26 14:45:57 UTC
I think I can get this working. Stay tuned for updates. :)
Comment 5 Jaison Lee 2005-07-04 03:25:18 UTC
SVN commit 431349 by jlee:

FEATURE: 92898
KRDC now has KWallet support. Both VNC and RDP are supported, although
RDP is a little rudimentary since it's just a frontend. KWallet usage
can be toggled per host. Password files and URL passwords are still
supported, and serve as alternatives to KWallet. RDP now makes use of
the standard password dialog if using KWallet. 




 M  +1 -1      Makefile.am  
 M  +10 -0     events.h  
 M  +13 -1     main.cpp  
 M  +4 -0      preferencesdialog.cpp  
 M  +52 -1     rdp/krdpview.cpp  
 M  +16 -2     rdp/rdphostpref.cpp  
 M  +3 -0      rdp/rdphostpref.h  
 M  +16 -0     rdp/rdpprefs.ui  
 M  +9 -0      rdp/rdpprefs.ui.h  
 M  +1 -1      vnc/Makefile.am  
 M  +89 -8     vnc/kvncview.cpp  
 M  +16 -2     vnc/vnchostpref.cpp  
 M  +3 -0      vnc/vnchostpref.h  
 M  +16 -0     vnc/vncprefs.ui  
 M  +9 -0      vnc/vncprefs.ui.h  
Comment 6 David Anderson 2005-07-04 10:51:16 UTC
Thank you very much, Jaison!
Comment 7 David Anderson 2005-07-04 10:53:39 UTC
P.S. I wonder if you're interested into getting some kind of kwallet support for SSH somehow? As a sysadmin, the lack of kwallet support for these two (SSH and krdc) has been the major drain on my memory... I don't know what your motivation for kwallet support in krdc was.

http://bugs.kde.org/show_bug.cgi?id=81067
http://bugs.kde.org/show_bug.cgi?id=97419
Comment 8 Jaison Lee 2005-07-04 16:06:45 UTC
My motivation was the same as yours; It will be a tremendous help to have. :)
I'll take a look at those other items and see what I think about them.


Comment 9 James Smith 2005-07-04 17:57:28 UTC
Why not just use a keypair for ssh? This is a lot cleaner IMO.

BTW, thanks Jaison! Great work! =)
Comment 10 David Anderson 2005-07-27 15:40:18 UTC
Keypairs are distributed - they have to be installed on the server. We don't want this. KWallet is centralised.
Comment 11 Jaison Lee 2005-10-20 21:25:04 UTC
*** Bug 114660 has been marked as a duplicate of this bug. ***