Bug 92606 - kmail handles spaces wrong in mail list
Summary: kmail handles spaces wrong in mail list
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: 1.7.1
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2004-11-02 21:13 UTC by Stefan Winter
Modified: 2009-04-09 12:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot with two identical mails and wrong UI display (170.62 KB, image/png)
2004-11-02 21:14 UTC, Stefan Winter
Details
source of the mail from the previous attachment (14.35 KB, text/plain)
2008-04-16 21:42 UTC, Stefan Winter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Winter 2004-11-02 21:13:14 UTC
Version:           1.7.1 (using KDE 3.3.0, SuSE)
Compiler:          gcc version 3.3.4 (pre 3.3.5 20040809)
OS:                Linux (i686) release 2.6.8-24.3-default

When a message is selected in the list, sometimes spaces go away, sometimes some are added.
The screenshot shows such a situation: I received some Newsletter twice (identical content). When I select one mail, spaces in the subject and sender get messed up.
This UI misbehaviour is reproducible, but there's something interesting to it: when KMail loses its focus and gets it again, the display is correct again (this is really weird).
It seems that it only happens on online IMAP inbox folders (not on disconnected IMAP).
Comment 1 Stefan Winter 2004-11-02 21:14:24 UTC
Created attachment 8142 [details]
Screenshot with two identical mails and wrong UI display
Comment 2 Thomas McGuire 2007-07-25 00:10:21 UTC
Can you please attach such a message? Maybe the subject header is strange.
Comment 3 Stefan Winter 2008-04-16 21:42:53 UTC
Created attachment 24358 [details]
source of the mail from the previous attachment

This is the mail from the screenshot. I retrieved it from an old archive on
GMail, so the Received: headers are different, but that shouldn't matter.
Note that organisation and subject use embedded encoding hints. It looks like
this might have been the problem.
Comment 4 Michael Leupold 2008-09-14 12:44:57 UTC
I can't reproduce this bug using your testcase any longer on trunk r860752. I guess this might have been fixed somewhere along the way to KDE4.
Comment 5 Stefan Winter 2008-12-03 12:16:56 UTC
Hi,

thanks for the note. I will try out KDE 4.2 to see if it really works. I will close the bug then.

Stefan
Comment 6 Stefan Winter 2009-04-09 12:30:51 UTC
Just tried on KDE 4.1.3, and I can confirm the behaviour is gone. Closing the bug.