Bug 91864 - kword crashes when importing TeX files
Summary: kword crashes when importing TeX files
Status: RESOLVED FIXED
Alias: None
Product: kword
Classification: Miscellaneous
Component: filters (show other bugs)
Version: 1.5 or before
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Ariya Hidayat
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-22 00:17 UTC by Ben Burton
Modified: 2009-10-04 09:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Burton 2004-10-22 00:17:24 UTC
Version:           1.3.3 (using KDE KDE 3.3.0)
Installed from:    Debian testing/unstable Packages
OS:                Linux

Received through the Debian BTS (#277348):

- Create a TeX-file, e.g. by echo "" > xxx.tex
   However the contents of the file don't matter.

- Start Kword

- File -> Import -> Give xxx.tex as file to import.

- Kword says: Eine Datei des folgenden Typs ließ sich nicht importieren: 

   text/x-tex
   (in English: A file of the following type could'nt be imported:)
   After pressing "OK" the kword-window closes, but the process doesn't 
exit.

If kword was started from the console, the following messages appear:

QString::arg(): Argument missing: ????, /home/kalisch/Desktop/
koffice (filter manager): ERROR: Couldn't create a valid filter chain!


I have two complaints:
- kword should not crash
- There should be a possibility to import tex-files as ascii-files 
without the need to rename them.

(end of original report)

FWIW, I can also reproduce this on my machine, even with a vaild TeX file (i.e., not just an empty TeX file).  It does seem like kword is crashing (it wouldn't exit normally during a File-Import, plus although the window dies the process does not), though the KDE crash handler does not appear.

Thanks - Ben.
Comment 1 Sebastian Sauer 2006-03-16 19:35:59 UTC
Not reproducable for me with KO 1.5 Beta2.

@Ben: Could you provide a backtrace or at least test if the bug is still valid? Thanks in advance :)
Comment 2 Sebastian Sauer 2006-08-18 23:34:32 UTC
Marked as fixed since it's still not reproducable. Please feel free to reopen the report if the case still exists for you. Thanks in advance :)