Bug 87163 - kaddressbook empties resource on some conditions (data lost)
Summary: kaddressbook empties resource on some conditions (data lost)
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kab3
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: FreeBSD Ports FreeBSD
: VHI grave with 161 votes (vote)
Target Milestone: ---
Assignee: Tobias Koenig
URL:
Keywords:
: 106754 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-08-13 23:52 UTC by Fernando Schapachnik
Modified: 2009-08-05 16:13 UTC (History)
12 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
resourcefile.diff (2.61 KB, text/x-diff)
2006-02-16 17:56 UTC, Michael Reiher
Details
resourcefile2.diff (3.33 KB, text/x-diff)
2006-02-16 17:56 UTC, Michael Reiher
Details
another X logfile (3.88 KB, text/plain)
2006-02-14 22:00 UTC, Carsten Pfeiffer
Details
a patch trying to address the problem (5.51 KB, patch)
2006-02-16 17:56 UTC, Carsten Pfeiffer
Details
an updated patch (18.28 KB, patch)
2006-02-19 23:38 UTC, Carsten Pfeiffer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fernando Schapachnik 2004-08-13 23:52:24 UTC
Version:            (using KDE KDE 3.2.3)
Installed from:    FreeBSD Ports
Compiler:          gcc version 2.95.4 20020320 [FreeBSD] 
OS:                FreeBSD

I think this bug is similar to # 62598.
Although I see this anormal behavior since my first day at 3.2.3 (was using 3.1 before), didn't report earlier since I couldn't identify a replay scenario, which I have found just today.

Using kaddressbook with a file resource in a slow computer.
-Load the addressbook.
-Find an entry, modify it, press Ok.
-Then click Save before the contact list reloads on-screen. This takes aprox. 3 to 4 seconds on my machine.
-std.vcf ends up empty (0 bytes). Maybe (depending on timing) there is a std.vcf_<something> containing the changed data.

Also happens when adding new contacts.

If more info is required, please let me know.
Comment 1 Tobias Koenig 2004-08-20 03:31:38 UTC
Hi,

do you use the embedded editor or the editor in the separated dialog?

Ciao,
Tobias
Comment 2 Fernando Schapachnik 2004-08-20 12:41:16 UTC
Not quite sure of what the embedded editor is, but I mean the editing window that pops up when you double-click a contact on the contact-list.

Regards.

Fernando.
Comment 3 Tobias Koenig 2005-01-06 15:33:08 UTC
*** Bug 95693 has been marked as a duplicate of this bug. ***
Comment 4 Tobias Koenig 2005-08-01 22:12:35 UTC
*** Bug 107711 has been marked as a duplicate of this bug. ***
Comment 5 Arne Schmitz 2005-08-02 09:05:44 UTC
I might add that this only seems to happen when using the standard resource. I am now using a dedicated address book for some weeks now, and did not have any data losses.
Comment 6 Marcus Better 2005-08-10 18:04:37 UTC
I have a similar problem with an address book file in an sftp:// resource. The file is truncated to 0 bytes every time I log out from KDE. I suppose kaddressbook starts a write operation when it is about to shut down, but never finishes before it exits.

This happens every time I log out, even if I didn't make any changes to the address book.
Comment 7 Tobias Koenig 2005-08-12 11:02:21 UTC
*** Bug 110528 has been marked as a duplicate of this bug. ***
Comment 8 Tobias Koenig 2005-08-12 11:08:03 UTC
*** Bug 103589 has been marked as a duplicate of this bug. ***
Comment 9 Tobias Koenig 2005-08-16 20:14:54 UTC
*** Bug 106754 has been marked as a duplicate of this bug. ***
Comment 10 Lajos Kuti 2005-08-20 16:15:15 UTC
Hello,

I think, something similar is happening to me too.
My Kaddressbook, keeps adding some std.vcf_<something>s every time I add a new contact and I can't find the contacts I've just added and saved.

Now, every time I add a new contact, I need to delete those std.vcf_<something>s before I save the new entry.

I'm using KDE 3.3.0 and Kaddressbook 3.3, SuSE 9,2

I do use the right mouse click menu to open the email address in the address book. Shouldn't I?








Comment 11 Tobias Koenig 2005-08-22 10:19:43 UTC
On Sat, Aug 20, 2005 at 02:15:17PM -0000, Lajos Kuti wrote:
> Hello,

Hi,

> I think, something similar is happening to me too.
> My Kaddressbook, keeps adding some std.vcf_<something>s every time
> I add a new contact and I can't find the contacts I've just added and saved.

That's another bug which was already fixed in 3.4, please update.

Ciao,
Tobias
Comment 12 Felix Berger 2005-10-09 01:43:58 UTC
The bug described in the last comments still exists in KDE 3.4.2.

I recreated my file resource from scratch and imported my contacts to make sure it's not a problem with upgrading addressbook formats.

Home directories are on an nfs mount in case it's a locking problem.
Comment 13 David Saxton 2005-10-11 21:57:11 UTC
This bug is still present in KDE pre-3.5 (or at least the version I checked out from subversion a few weeks ago) - sometime in the last week I lost all my contacts :( - I don't know how it happened as I don't use the address book much.

Please fix.
Comment 14 Dominik Karall 2005-11-17 21:28:06 UTC
This bug is present in KDE 3.5-rc1 too!! It's confusing that there are a lot of std.vcf files created:

$ ls -t -l .kde/share/apps/kabc/std.vcf*
-rw-r--r--  1 dominik users  1034 17. Nov 21:17 .kde/share/apps/kabc/std.vcf
-rw-r--r--  1 dominik users  1034 17. Nov 21:17 .kde/share/apps/kabc/std.vcf_4
-rw-r--r--  1 dominik users   880 16. Nov 00:21 .kde/share/apps/kabc/std.vcf_3
-rw-r--r--  1 dominik users   731 15. Nov 15:08 .kde/share/apps/kabc/std.vcf_2
-rw-r--r--  1 dominik users     0 14. Nov 16:49 .kde/share/apps/kabc/std.vcf_1
-rw-r--r--  1 dominik users  3886 13. Nov 21:17 .kde/share/apps/kabc/std.vcf_7
-rw-r--r--  1 dominik users  3702 12. Nov 15:00 .kde/share/apps/kabc/std.vcf_6
-rw-r--r--  1 dominik users  3702  4. Nov 15:37 .kde/share/apps/kabc/std.vcf_5
-rw-r--r--  1 dominik users 16729 20. Mai 20:13 .kde/share/apps/kabc/std.vcfIAyumc.new
-rw-r--r--  1 dominik users     0 16. Mai 2005  .kde/share/apps/kabc/std.vcfQFgWua.new
-rw-r--r--  1 dominik users     0 29. Apr 2005  .kde/share/apps/kabc/std.vcfRRgy3b.new
-rw-r--r--  1 dominik users     0 10. Apr 2005  .kde/share/apps/kabc/std.vcfSxgnyb.new
-rw-r--r--  1 dominik users     0 28. Feb 2005  .kde/share/apps/kabc/std.vcfi45nmb.new
-rw-r--r--  1 dominik users 14786 10. Feb 2005  .kde/share/apps/kabc/std.vcfLyx6Da.new
-rw-r--r--  1 dominik users 14786  6. Feb 2005  .kde/share/apps/kabc/std.vcfP95Iaa.new
-rw-r--r--  1 dominik users 14786  1. Feb 2005  .kde/share/apps/kabc/std.vcfYC3oLb.new
-rw-r--r--  1 dominik users 14786 28. Jan 2005  .kde/share/apps/kabc/std.vcfp95iCa.new
-rw-r--r--  1 dominik users     0 20. Dez 2004  .kde/share/apps/kabc/std.vcfcCdHec.new
-rw-r--r--  1 dominik users 14485 17. Dez 2004  .kde/share/apps/kabc/std.vcflGtnFa.new
-rw-r--r--  1 dominik users     0 10. Dez 2004  .kde/share/apps/kabc/std.vcfeegplb.new
-rw-r--r--  1 dominik users     0  3. Dez 2004  .kde/share/apps/kabc/std.vcfAPROhc.new
-rw-r--r--  1 dominik users     0 28. Nov 2004  .kde/share/apps/kabc/std.vcfn9GXZa.new
-rw-r--r--  1 dominik users     0 19. Nov 2004  .kde/share/apps/kabc/std.vcfPljWgc.new
-rw-r--r--  1 dominik users 13269 15. Nov 2004  .kde/share/apps/kabc/std.vcfhk6Vic.new
-rw-r--r--  1 dominik users 10482  1. Okt 2004  .kde/share/apps/kabc/std.vcfMiXrfb.new
-rw-r--r--  1 dominik users 10482  1. Okt 2004  .kde/share/apps/kabc/std.vcf2V2Hqc.new
-rw-r--r--  1 dominik users  9971 20. Sep 2004  .kde/share/apps/kabc/std.vcfw34mhb.new

I hope it will be fixed in KDE 3.5 final, as I think this bug is really annoying for users.
Comment 15 Michael Reiher 2005-11-18 00:29:17 UTC
Ah, thanks for the reminder...

A few weeks ago I made the attached patch and did a little rotating of my X 
logs (see end of this message) to possibly find out whats going on. 

This really should be fixed in some or the other way for 3.5! Loosing data is 
the worst that can happen! What I mean is, if it's currently not possible to 
find the real cause of these losses, then at least some precautions should be 
taken to avoid data loss as good as possible. At the moment the actually 
existing backups are plain useless, as they are rotated away silently and 
user has no chance to react! Aside from the real cause, it actually doesn't 
matter whats wrong. There can always be a reason why saving fails, a bug in 
the saving alghorithm, program or system crash, disk full or what ever. So 
this precaution would generally be useful. What could be done IMO is this: 

 - 1. Don't save the addressbook if the written file size is 0. As this 
indicates that something went wrong during save. Give an error to the user. 
This should also abort a running logout. (A solution for saving an 
intentionaly empty addressbook would need to be found, though)

 - 2. Don't do a backup if the original file has size 0 (never, intentionally 
empty or error doesn't matter). In this case there is nothing to backup.

This should make sure that a) the user knows about the problem and b) the 
existing backups don't get rotated away silently.

 - 3. On addressbook startup: if addressbook file size is 0, but there are 
backups, ask the user to restore. (Again intentional empty addressbooks have 
to be handled in some way.)

The problem is that I have no idea about the internals of 
kaddressbook/kdepim to provide a proper solution. I'm already glad I 
found the place where the backup apparently happens :) But hopefully it still 
helps in some way. The attached patch is mostly for illustration of what I 
mean by 1. and 2. But, it basically seems to work and prevent data loss. It 
doesn't address the issue of intentionally empty addressbooks. Also the 
addressBook()->error() apparently doesn't abort shutdown.

Looking at the logs, could it be that there are more than one processes or 
threads trying to save at the same time and get in the way? Some of my logs 
("######### RESOURCE: ...") are missing even though they should be there.

Please, find some solution for this problem!

Greetings

Michael


The X logs from failure cases. This always during KDE shutdown. I only grepped 
the kabc messages. If you need more, I have the full logs still around.

----- Failure case 1 ------------------------------------------------------

kabc: StdAddressBook::saveAll()
kabc: AddressBook::requestSaveTicket()
kabc: ResourceFile::requestSaveTicket()
kabc: Lock::lock()
kabc: -- lock 
name: /home/michael/.kde/share/apps/kabc/lock/_home_michael_.kde_share_apps_kabc_std.vcf.lock
kabc: ######### RESOURCE: Saving file seems successful! Size > 0: 13956. 
Making it permanent!
kabc: stale temp file detected /tmp/kde-michael/kontactG72bsa.tmp
kabc: AddressBook::requestSaveTicket()
kabc: ResourceFile::requestSaveTicket()
kabc: Lock::lock()
kabc: -- lock 
name: /home/michael/.kde/share/apps/kabc/lock/_home_michael_.kde_share_apps_kabc_std.vcf.lock
kabc: -- lock unique 
name: /home/michael/.kde/share/apps/kabc/lock/_home_michael_.kde_share_apps_kabc_std.vcflv3t8ryw
kabc: AddressBook::save()
kabc: ResourceFile::save()
kabc: ######### RESOURCE: Original file size > 013956. Doing backup!
kabc: ######### RESOURCE: Saving file probably failed! Size is 0. ABORTING 
save!
kabc: ######### RESOURCE: Saving file failed!
kabc: StdAddressBook::saveAll()
kabc: AddressBook::requestSaveTicket()
kabc: ResourceFile::requestSaveTicket()
kabc: Lock::lock()
kabc: -- lock 
name: /home/michael/.kde/share/apps/kabc/lock/_home_michael_.kde_share_apps_kabc_std.vcf.lock
kabc: -- lock unique 
name: /home/michael/.kde/share/apps/kabc/lock/_home_michael_.kde_share_apps_kabc_std.vcfU31XuCyB
kabc: AddressBook::save()
kabc: ResourceFile::save()
kabc: ######### RESOURCE: Original file size > 013956. Doing backup!
kabc: ######### RESOURCE: Saving file probably failed! Size is 0. ABORTING 
save!
kabc: ######### RESOURCE: Saving file failed!


----- Failure case 2 ------------------------------------------------------

kabc: ######### RESOURCE: Saving file seems successful! Size > 0: 13956. 
Making it permanent!
kabc: stale temp file detected /tmp/kde-michael/kontactnwAiab.tmp
kabc: StdAddressBook::saveAll()
kabc: AddressBook::requestSaveTicket()
kabc: ResourceFile::requestSaveTicket()
kabc: Lock::lock()
kabc: -- lock 
name: /home/michael/.kde/share/apps/kabc/lock/_home_michael_.kde_share_apps_kabc_std.vcf.lock
kabc: -- lock unique 
name: /home/michael/.kde/share/apps/kabc/lock/_home_michael_.kde_share_apps_kabc_std.vcfVUY7oep2
kabc: AddressBook::save()
kabc: ResourceFile::save()
kabc: ######### RESOURCE: Original file size > 013956. Doing backup!
kabc: ######### RESOURCE: Saving file probably failed! Size is 0. ABORTING 
save!
kabc: ######### RESOURCE: Saving file failed!


----- Failure case 3 ------------------------------------------------------

kabc: StdAddressBook::saveAll()
kabc: AddressBook::requestSaveTicket()
kabc: ResourceFile::requestSaveTicket()
kabc: stale temp file detected /tmp/kde-michael/kontacttxt9Wa.tmp
kabc: StdAddressBook::saveAll()
kabc: AddressBook::requestSaveTicket()
kabc: ResourceFile::requestSaveTicket()
kabc: Lock::lock()
kabc: -- lock 
name: /home/michael/.kde/share/apps/kabc/lock/_home_michael_.kde_share_apps_kabc_std.vcf.lock
kabc: -- lock unique 
name: /home/michael/.kde/share/apps/kabc/lock/_home_michael_.kde_share_apps_kabc_std.vcfryrCbntQ
kabc: AddressBook::save()
kabc: ResourceFile::save()
kabc: ######### RESOURCE: Original file size > 013956. Doing backup!
kabc: ######### RESOURCE: Saving file probably failed! Size is 0. ABORTING 
save!
kabc: ######### RESOURCE: Saving file failed!


Created an attachment (id=13521)
resourcefile.diff
Comment 16 Michael Reiher 2005-11-21 23:14:29 UTC
I changed my patch (see attachment) a little to handle the case where an 
intentionally empty addressbook(or rather resource) is about to be saved. So 
that it still gets saved desipte ending up with an empty file. My thought for 
the problem of loosing data was, that there is actually something to save (as 
my addressbook is not empty) but saving fails for some reason and the file 
ends up empty. However now with the changes, I found the the resource appears 
to be empty! At least that's what my check yields. And as the saving routine 
uses the same code (I took it from there), nothing is being saved! Also 
during my last KDE shutdown I shortly saw a message box. I can't exactly 
remember what it said, but it was something along the lines "error: resource 
std.vcf is locked by korgac". So it appears to me that there is something 
wrong with locking? And that the resource is saved even though it is locked? 
And thus it saves the enries it can't get, i.e. none?

CCing to kde-pim (I'm not subscribed), as this seems a bit grave and there was 
no reaction yet. Maybe a solution can still be found for 3.5?

Greets 

Michael


Created an attachment (id=13586)
resourcefile2.diff
Comment 17 Michael Reiher 2005-11-21 23:37:25 UTC
Grrr, forgot the new output (and the CCing ..)

Kabc output from the last KDE shutdown (note that the resource is said to be 
empty at the end):

kabc: StdAddressBook::saveAll()
kabc: AddressBook::requestSaveTicket()
kabc: ResourceFile::requestSaveTicket()
kabc: Lock::lock()
kabc: -- lock 
name: /home/michael/.kde/share/apps/kabc/lock/_home_michael_.kde_share_apps_kabc_std.vcf.lock
kabc: -- lock unique 
name: /home/michael/.kde/share/apps/kabc/lock/_home_michael_.kde_share_apps_kabc_std.vcf8mUgnevX
kabc: AddressBook::save()
kabc: ResourceFile::save()
kabc: ######### RESOURCE: Original file size > 0: 14265. Doing backup!
kabc: ######### RESOURCE: Resource is not empty.
kabc: ######### RESOURCE: Saving file seems successful! Size > 0: 14265. 
Making it permanent!
kabc: AddressBook::requestSaveTicket()
kabc: ResourceFile::requestSaveTicket()
kabc: Lock::lock()
kabc: -- lock 
name: /home/michael/.kde/share/apps/kabc/lock/_home_michael_.kde_share_apps_kabc_std.vcf.lock
kabc: stale temp file detected /tmp/kde-michael/kontactynSfya.tmp
kabc: StdAddressBook::self()
kabc: StdAddressBook::saveAll()
kabc: AddressBook::requestSaveTicket()
kabc: ResourceFile::requestSaveTicket()
kabc: Lock::lock()
kabc: -- lock 
name: /home/michael/.kde/share/apps/kabc/lock/_home_michael_.kde_share_apps_kabc_std.vcf.lock
kabc: -- lock unique 
name: /home/michael/.kde/share/apps/kabc/lock/_home_michael_.kde_share_apps_kabc_std.vcfLFWLnyKS
kabc: AddressBook::save()
kabc: ResourceFile::save()
kabc: ######### RESOURCE: Original file size > 0: 14265. Doing backup!
kabc: ######### RESOURCE: Resource is empty.
kabc: ######### RESOURCE: Saving file seems successful! Resource intentionally 
empty. Making it permanent!
Comment 18 Tobias Koenig 2005-11-29 20:20:40 UTC
*** Bug 117294 has been marked as a duplicate of this bug. ***
Comment 19 Iñaki Baz Castillo 2005-12-27 12:40:35 UTC
Yesterday I lost all my kontacts in KDE 3.5. I had to restore them form a .kde/share/apps/kabc/std.vcfXXXXXXXXXXX.
Comment 20 Arne Schmitz 2006-01-07 14:55:09 UTC
Using KDE 3.5.0, still having the bug. At this time I sometimes just get a error message dialog saying 'Error', and nothing else. Since this is upon logout, I cannot click on the Ok button fast enough.
Comment 21 Carsten Pfeiffer 2006-02-02 12:40:20 UTC
I had experienced this bug quite often with Debian packages of KDE 3.5.0. When I compiled kdelibs myself to debug this, it didn't happen anymore, so far. Also with recent Debian packages of KDE 3.5.1, it didn't happen, yet.

Will monitor this.
Comment 22 Iñaki Baz Castillo 2006-02-02 14:47:15 UTC
> I had experienced this bug quite often with Debian packages of KDE 3.5.0.
> When I compiled kdelibs myself to debug this, it didn't happen anymore, so
> far. Also with recent Debian packages of KDE 3.5.1, it didn't happen, yet.


Yesterday I had this problem (empty data of contacts) with a Kubuntu KDE 
3.5.0. I upgraded to 3.5.1 and the problem still occurred.

Runing kaddressbook from a Konsole I saw an error about the binary format of 
the std.vcf file, so it couldn't save it.

I saw the properties of my Kaddressbook resource and it was a binary format 
instead of Vcard. I needed to create another resource as Vcard and copy the 
contacs to it and delete the old and corrupted first resource.

I think the bug is because the format of the local file resource changes 
accidentally the Vcard format to binary. Maybe?
Comment 23 Carsten Pfeiffer 2006-02-13 11:19:34 UTC
OK it happened again with KDE 3.5.1, so I'll try to debug this when I find some time.
Comment 24 Carsten Pfeiffer 2006-02-14 22:00:18 UTC
Created attachment 14701 [details]
another X logfile

Just for reference, here's another X logfile showing how my addressbook was
eaten during KDE shutdown.
Comment 25 Roland Wolters 2006-02-15 17:32:18 UTC
I have a similar problem here with KDE 3.5.1, Fedora Core, kde-redhat rpms.

Somtimes, after editing kaddressbook accounts, I get an error when I shut down KDE: the error sayy something about a file locked and korgac (was never fast enough to write it down, I will try to be fast enough next time) - when that happens, the main std.vcf is empty, and kaddressbook shows no more entries.
I avoid that problem through shutting down kontact after I edited the contacts inside (I always start kaddressbook inside of kontact).

I never found any entry in .xsession-errors - are there other error files I should have a look at?
Comment 26 Carsten Pfeiffer 2006-02-16 17:56:26 UTC
Created attachment 14721 [details]
a patch trying to address the problem

I'd welcome if anyone could apply this patch and report back if it fixes the
problem. See also http://lists.kde.org/?l=kde-core-devel&m=114010859216234&w=2
Comment 27 Carsten Pfeiffer 2006-02-19 23:38:14 UTC
Created attachment 14783 [details]
an updated patch

This obsoletes the previous patch. It fixes KTempFile and KSaveFile usage and
also fixes the net plugin.
Comment 28 Carsten Pfeiffer 2006-03-06 22:33:01 UTC
I declare this fixed. I haven't had any addressbook losses anymore and haven't heard of anyone else losing it either. The patch from 2006-02-19 23:38:14 is in SVN, both trunk and 3.5-branch.
Comment 29 Winfried Dobbe 2006-03-06 22:41:01 UTC
Thanks so much for fixing this one!
Comment 30 Bjarne Wichmann Petersen 2006-03-29 22:06:23 UTC
I've just upgraded to 3.5.2 today (kubuntu packages) and my addressbooks got wiped clean. Restored it from an older (2 days) std.vcf-file.
Comment 31 Carsten Pfeiffer 2006-03-30 10:22:45 UTC
On Wednesday 29 March 2006 22:06, Bjarne Wichmann Petersen wrote:

> ------- I've just upgraded to 3.5.2 today (kubuntu packages) and my
> addressbooks got wiped clean. Restored it from an older (2 days)
> std.vcf-file.


Are you sure you already ran 3.5.2? Did you restart KDE after installing? When 
did you lose your addresses? On shutdown or somewhen in between?

Cheers,
Carsten
Comment 32 p92 2006-04-30 14:56:25 UTC
I can confirm this to in kde 3.5.2 on kubuntu dapper !  I still don't know how to reproduce this.
Comment 33 p92 2006-05-26 21:34:19 UTC
still occuring - this is a showstopper for me :(
-rw-rw---- 1 pascal pascal 0 2006-05-26 03:26 pc_perso.vcf
 -rw-rw---- 1 pascal pascal 102731 2006-05-22 04:51 pc_perso.vcf_1
 -rw-rw---- 1 pascal pascal 102667 2006-05-23 05:33 pc_perso.vcf_2
 -rw-rw---- 1 pascal pascal 0 2006-05-24 02:48 pc_perso.vcf_3
 -rw-rw---- 1 pascal pascal 0 2006-05-25 02:23 pc_perso.vcf_4
 -rw-rw---- 1 pascal pascal 0 2006-05-26 03:26 pc_perso.vcf_5
 -rw-rw---- 1 pascal pascal 102677 2006-05-20 11:21 pc_perso.vcf_6
 -rw-rw---- 1 pascal pascal 102701 2006-05-21 14:37 pc_perso.vcf_7

with 

ii  kdelibs        3.5.2-0ubuntu18       core libraries from the official KDE release
ii  kdelibs-bin    3.5.2-0ubuntu18       core binaries for all KDE applications
ii  kdelibs-data   3.5.2-0ubuntu18       core shared data for all KDE applications
ii  kdelibs4-dev   3.5.2-0ubuntu18       development files for the KDE core libraries
ii  kdelibs4c2a    3.5.2-0ubuntu18       core libraries for all KDE applications
Comment 34 Carsten Pfeiffer 2006-05-30 11:33:32 UTC
When did this happen? At logout time kmail/kontact/kabc shutdown? Or just in the middle of doing something?

Did you change the addressbook before (i.e. edit/remove/add an entry)?
Comment 35 p92 2006-06-01 01:30:34 UTC
As I said before, for me I cannot reproduce this at will. I tried all sort of changes end situations without triggering the bug by myself.

I seems to happen when I use kshutdown to shutdown the station after a delay. But not often nor systematically.
Comment 36 Konrad Twardowski 2006-06-01 11:05:24 UTC
KAddressBook 3.5, KDE 3.5.2 (Kubuntu packages)

Steps to reproduce:
1. Backup and delete your current address book directory (~/.kde/share/apps)
2. Backup and delete your current address book config (~/.kde/share/config/kaddressbookrc)
3. Run "kaddressbook"
4. [The address book is empty by default]
5. [The resource is "~/.kde/share/apps/kabc/std.vcf" by default]
6. Click File -> New Contact
7. Enter "a", "b", "c" in the first three fields, then click "OK"
8. Logout (K Menu -> Logout... -> End Current Session)
9. Login again
10. Run "kaddressbook"
11. [Address book is empty -- oh no!]
12. In the "~/.kde/share/apps/kabc" directory I have two files: std.vcf (0 size) and std.vcf_4 (with data entered in step "7")
13. WTF? ;-)
Comment 37 Iñaki Baz Castillo 2006-08-31 22:25:02 UTC
Is this bug really FIXED?

I use KDE 3.5.4 in Kubuntu Dapper and all the days lost my contacts in a SSH vcard file, all the days.

I have opened other Bug #133346 relating it. I have opened it because this bug appears as FIXED so I don't know if people will read my report here.

Regards.
Comment 38 Marcus Better 2007-03-26 15:01:29 UTC
I have this problem with an addressbook on a slow NFS share. When I log out, I see a progress dialog that shows the addressbook is being written. It is apparently interrupted by the logout process, and the address book gets truncated to zero bytes.

This is a Debian system with kdelibs 3.5.6.r1.dfsg.1-2.
Comment 39 Tobias Koenig 2009-08-05 16:13:35 UTC
The development of the old KAddressBook will be discontinued for KDE 4.4.
Since the new application has the same name, but a completly new code base we close all bug reports against the old version and ask the submitters to resend there reports against the new product.