Bug 86542 - kapptemplate: Please support adding a KDE component to an existing source tree
Summary: kapptemplate: Please support adding a KDE component to an existing source tree
Status: RESOLVED NOT A BUG
Alias: None
Product: kapptemplate
Classification: Developer tools
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Kurt Granroth
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-08-04 03:58 UTC by Ben Burton
Modified: 2008-04-26 13:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Burton 2004-08-04 03:58:15 UTC
Version:            (using KDE KDE 3.2.3)
OS:                Linux

Received through the Debian BTS (#261269):

kapptemplate's only mode of operation seems to be "create a new KDE project".  It doesn't seem to be possible (and in fact some of the configure functions it defines make it /im/possible) to add a KDE component to an existing, autoconfiscated project, preferably as an optional feature (that can be disabled in configure).

Thanks!
Comment 1 Stephan Kulow 2004-08-04 11:23:47 UTC
kapptemplate isn't really maintained I think. And such a feature is definitly beyond a template - your user should try kdevelop :)
Comment 2 Anne-Marie Mahfouf 2008-04-26 13:51:31 UTC
out of KAppTemplate scope.
In KDE 4.1, KAppTemplate projects are compatible with KDevelop so you'll be able to easily generate the same template from within KDevelop.

KAppTemplate is only a template generator, nothing more. Once the project is generated, you read the included README and then you're on your own!

KAppTemplate is maintaiined again by myself!