Bug 86535 - Add tolerance for bad blog entries
Summary: Add tolerance for bad blog entries
Status: RESOLVED INTENTIONAL
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 100044 102979 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-08-04 00:51 UTC by Pierre Habouzit
Modified: 2006-04-27 11:11 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre Habouzit 2004-08-04 00:51:32 UTC
Version:            (using KDE KDE 3.2.3)

Package: akregator
Version: 1.0-beta5-2
Severity: normal

On the current Planet Debian collection, akregator is stuck on AJK's
'Orlando' post. On the other hand, Liferea shows an error 'missing xlm
entity' triggered by a (presumably ill-formatted) entry by Erick Schubert.

It would be nice if akregator could tolerate crappy input and sail around it.

Thanks, Dirk

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.4.26-1-686
Locale: LANG=en_US, LC_CTYPE=en_US

Versions of packages akregator depends on:
ii  kdelibs4                  4:3.2.3-3      KDE core libraries
ii  libart-2.0-2              2.3.16-6       Library of functions for 2D graphi
ii  libc6                     2.3.2.ds1-14   GNU C Library: Shared libraries an
ii  libfam0c102               2.7.0-5        client library to control the FAM 
ii  libgcc1                   1:3.4.1-5      GCC support library
ii  libice6                   4.3.0.dfsg.1-6 Inter-Client Exchange library
ii  libjpeg62                 6b-9           The Independent JPEG Group's JPEG 
ii  libpcre3                  4.5-1.1        Perl 5 Compatible Regular Expressi
ii  libpng12-0                1.2.5.0-6      PNG library - runtime
ii  libqt3c102-mt             3:3.2.3-4      Qt GUI Library (Threaded runtime v
ii  libsm6                    4.3.0.dfsg.1-6 X Window System Session Management
ii  libstdc++5                1:3.3.4-7      The GNU Standard C++ Library v3
ii  libx11-6                  4.3.0.dfsg.1-6 X Window System protocol client li
ii  libxext6                  4.3.0.dfsg.1-6 X Window System miscellaneous exte
ii  libxrender1               0.8.3-7        X Rendering Extension client libra
ii  xlibs                     4.3.0.dfsg.1-6 X Window System client libraries m
ii  zlib1g                    1:1.2.1.1-5    compression library - runtime

-- no debconf information
Comment 1 Sashmit Bhaduri 2004-08-04 03:25:24 UTC
i'd be nice to have the attached feed
Comment 2 Pierre Habouzit 2004-08-04 21:56:42 UTC
The feed has been manually corrected and doesn't exist anymore.
THe problem was an "&" wasn't written as a "&" but as a & followed by a space.

I didn't get if it was in the body or in the title of the feed.

Comment 3 Sashmit Bhaduri 2004-08-04 23:03:54 UTC
yeah, that's malformed XML, which qdom doesn't handle at all
Comment 4 Teemu Rytilahti 2005-02-26 23:08:06 UTC
*** Bug 100044 has been marked as a duplicate of this bug. ***
Comment 5 Frank Osterfeld 2005-04-15 18:24:36 UTC
*** Bug 102979 has been marked as a duplicate of this bug. ***
Comment 6 Eckhart Wörner 2005-04-22 23:31:30 UTC
In my opinion, this bug should get closed.
As far as I understand it, this means preparsing the feeds for every crap the people write. This is error-prone and also unneccessary.
It is *really* not Akregator's task to correct feeds that do not conform with the XML specifications. INHO the only real effect is the negative one we can see at HTML.
Comment 7 Eckhart Wörner 2005-04-24 20:53:43 UTC
As I said above, no real need for this.