Bug 84285 - Arabic filenames with extenstions doesn't dispaly properly in konqueror
Summary: Arabic filenames with extenstions doesn't dispaly properly in konqueror
Status: RESOLVED WORKSFORME
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal with 21 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-06-30 23:57 UTC by Munzir Taha
Modified: 2007-04-28 01:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Munzir Taha 2004-06-30 23:57:43 UTC
Version:            (using KDE KDE 3.2.2)
Installed from:    Unspecified Linux

As you know Arabic is a RTL language. If I have an Arabic filename with an extension the extension appears to the left of the filename which shouldn't be the case.

htm.CIBARA
Actually it should be
CIBARA.htm

This looks very odd in ListView view mode for example because it looks as if the filenames are not sorted properly though it is.

note: the name ARABIC is written in reverse as CIBARA to reflect the RTL behaviour.
Comment 1 Mark A. Taff 2006-08-31 06:41:53 UTC
Muunzir,

Can you confirm if this is still happening in KDE 3.5.4?

Thanks.
Comment 2 Munzir Taha Obeid 2006-08-31 11:00:16 UTC
Yes, Mark
I am now using KDE 3.5.4 and same bug is there. Actually, not just the ListView but all the views give the same problem. If the bug is not clear or you need any screenshots, drop me a note, please.
Comment 3 Youssef Chahibi 2006-09-03 04:35:53 UTC
Sounds to me that this bug is invalid. Konqueror file sorter should follow the logically typed noun, therefore the extension is the last. I think Konqueror's behavior is a normal bidi behavior, which is definitely correct. If your desired behavior happens, then a filename with an Arabic extension will be displated صورة.بحر rather than بحر.صورة.
Comment 4 Mark A. Taff 2006-09-03 06:07:33 UTC
I have put this bug down to be reviewed by a Konqi dev to clarify if this is a bug or as-designed(invalid) behavior.  I suspect it would be as-designed, as file extentions are don't carry much weight in *nix.
Comment 5 Diego Iastrubni 2007-04-28 00:40:13 UTC
I can see this also in Hebrew. But I tend to agree with Yussef CHAHIBI - this should be closed as invalid. The direction of the reading is right-to-left: first read the file name (in arabic) last the extensions (in english).

Lets close this as "invalid" please.
Comment 6 Munzir Taha 2007-04-28 01:09:13 UTC
Ok I also tends to agree now it's not a bug. As Mark pointed out "as file extentions are don't carry much weight in *nix". I would mark it as resolved and you can close it as INVALID THIS IS NOT WINDOWS ;)