Bug 83689 - Support printing of arbitrary date ranges
Summary: Support printing of arbitrary date ranges
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Unclassified
Component: printing (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 84481 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-06-20 08:04 UTC by Brad Hards
Modified: 2009-01-08 06:01 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brad Hards 2004-06-20 08:04:57 UTC
Version:            (using KDE Devel)

This bug is the wishlist part of bug:83688, which I incorrectly ascribed to bug:73722.

bug:83688 describes a usability problem associated with printing month view. It would be nice if printing could support arbitrary start and end dates - this is most important to me in month view, but I could see some use for this in week view too (for example, printing from a given Wednesday to the following Tuesday).

This wish is different to bug:73722 in that this wish is for arbitrary dates, rather than for a given whole month.
Comment 1 Reinhold Kainhofer 2004-07-22 13:11:24 UTC
*** Bug 84481 has been marked as a duplicate of this bug. ***
Comment 2 Ed Matthews 2006-03-17 05:26:01 UTC
I'd like to be able to print six weeks, rather like the month view, starting on a selected date.  Then I could get a whole semester in three pages.

Thanks for a great piece of software!
Comment 3 Reinhold Kainhofer 2006-11-02 19:24:10 UTC
Reassigning all KOrganizer bug reports and wishes to the newly created 
korganizer-devel mailing list.
Comment 4 Matt Rogers 2009-01-08 06:01:53 UTC
SVN commit 907451 by rgoodheart:

These changes also address some print overflow issues that were still 
happening but were not reported.

GUI:
        gui changes to configuration dialogs

BUG: 102473  
        Print month does not produce color output - events now in category 
colors 
BUG: 144809  
        Calendar will not print in color - category colors for 
incidence,day,week and month 
BUG: 102598  
        Print Locations,Descriptions, etc. on Filofax week pages - additional 
info added  
BUG: 104731  
        include date when printing month view on paper - date now printed on 
the bottom of page
BUG: 167751  
        Printing jounral entries with richtext from korganizer print html-tags
        rich text is converted to plain text before printing for now on all 
print types rather than printing the html 

FEATURE: 71908   
        calendar-print: option to switch on lines would be great - added 
optional note lines
FEATURE: 83689   
        Support printing of arbitrary date ranges - day range supports 
arbitrary range
        (patch from David Faure incorporated  - feature in day print to print 
selected range on one page
FEATURE: 110690  
        Print "Month view" does not print all events - triangle printed in 
lower right hand side of display box if the print overflows the box and all 
information is not displayed 



 M  +164 -114  calprintdayconfig_base.ui  
 M  +96 -31    calprintdefaultplugins.cpp  
 M  +9 -0      calprintdefaultplugins.h  
 M  +95 -90    calprintincidenceconfig_base.ui  
 M  +48 -18    calprintmonthconfig_base.ui  
 M  +248 -106  calprintpluginbase.cpp  
 M  +45 -6     calprintpluginbase.h  
 M  +41 -13    calprinttodoconfig_base.ui  
 M  +50 -34    calprintweekconfig_base.ui  

WebSVN link: http://websvn.kde.org/?view=rev&revision=907451