Bug 82009 - $LANG is not set by the KDE locate settings
Summary: $LANG is not set by the KDE locate settings
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_language (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal with 65 votes (vote)
Target Milestone: ---
Assignee: John Layt
URL:
Keywords:
: 86752 106342 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-05-22 17:14 UTC by Diederik van der Boor
Modified: 2018-05-17 10:42 UTC (History)
12 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diederik van der Boor 2004-05-22 17:14:19 UTC
Version:            (using KDE KDE 3.2.2)
Installed from:    Gentoo Packages
OS:                Linux

I've changed the language of my desktop environment to Dutch, but it seamed that a lot of applications (console and gtk) didn't have Dutch translations. However, if the "LANG" variable is set, these applications have Dutch messages as well.

My question is, could kdeinit/kcontrol be fixed, so it sets the LANG environment variable? (then newly started applications should appear with a different locate setting) Thans in advice.
Comment 1 Nicolas Goutte 2004-05-22 17:17:47 UTC
If this bug is conformed, perhaps better $LC_ALL should be changed, as it has higher priority (and Mandrake works with $LC_ALL not with $LANG .)

Have a nice day!
Comment 2 András Manţia 2006-03-02 22:54:04 UTC
Confirmed with 3.5.1. Firefox and OpenOffice does not follow KDE's language setting because of this. Quite annoying in a multi-language environment, where the user has a choice to select the language on startup, but still sees some applications in English.
Comment 3 András Manţia 2006-03-02 23:35:04 UTC
Adding Coolo here, as the wish 86752 (same issue) was assigned to him.
Comment 4 András Manţia 2006-03-02 23:35:19 UTC
*** Bug 86752 has been marked as a duplicate of this bug. ***
Comment 5 Ismail Donmez 2006-04-18 15:04:15 UTC
Agreed with Nicolas, if we are ever implementing this we should set $LC_ALL so it works everywhere.
Comment 6 Dotan Cohen 2008-05-01 14:41:58 UTC
Agreed. It is confusing to some users why they selected a language yet some apps do not use that language.
Comment 7 Anonymous bin ich 2008-11-18 09:24:38 UTC
As far as I know, some of the applications do need "C" locale to be set (LC_COLLATE="C" ?). I would rather suggest setting only LANG.

Regarding Mandrake, I am sure there are some applications which need one of the LC_ variables. They never need LC_ALL.
Comment 8 John Layt 2010-08-07 21:05:53 UTC
Wouldn't this be a KDM issue, when the user logs in it should set the session environment variables as required?  The big problem is that it is very hard to 

What happens if the user is running GDM to log into KDE?

What happens if the desktop is not KDE, should we then ignore the KDE settings and use the host desktop settings instead?
Comment 9 John Layt 2010-08-07 21:07:49 UTC
Bah, pushed enter too soon...

The big problem is it is very hard to translate our country and language setting into a locale string supported by the host system.
Comment 10 John Layt 2010-08-07 21:19:11 UTC
*** Bug 106342 has been marked as a duplicate of this bug. ***
Comment 11 Oceanwatcher 2010-08-07 21:48:08 UTC
Whatever happens, I think we should all agree that the situation we have right now can not continue.

There are software developers that do not use anything else than locale to be sure they do not have to do anything special for KDE, Gnome, Xfce etc.

So whatever is done, it should be able to configure the following (taken from my own situation):

I am Norwegian, using Norwegian keyboard. (nb-NO)
I live in Brazil, so I need Brazilian units - Metric, Celsius, currency=BRL etc. (pt-BR)
We speak English in the house and all computers use English. So EVERYTHING including the name of days of the week in a calendar (and months) in all interfaces must be in English. (en-US or en-GB)

My problem right now is that I have some programs where almost everything is correct, but the name of days and months come up in Brazilian Portuguese.

Now - if I set units in KDE to Brazilian, why should not the corresponding settings in locale not follow?

It is all about make a system possible to use by average users. How do you explain to an average user that they have to edit language settings in the GUI, and then in a CLI?

And if a mix of KDE, Gnome etc. worries you? Why not make a setting in KDE (that defaults to YES) "Update locale when I change regional settings in KDE?".

Advanced users running multiple DE's can go and set it to NO. The average user will never need to think about it - it just behaves as expected.
Comment 12 Eike Hein 2018-05-17 10:42:57 UTC
I believe LANG is set these days, at least the Language KCM in 5.13 certainly writes it out.