Bug 80792 - all php files searched in php project root URL even if they are inside a subdir
Summary: all php files searched in php project root URL even if they are inside a subdir
Status: RESOLVED FIXED
Alias: None
Product: kdevelop
Classification: Unclassified
Component: Language Support: PHP (show other bugs)
Version: 3.0.1
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KDevelop Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-05-02 18:22 UTC by Imre Péntek
Modified: 2007-01-14 20:30 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Imre Péntek 2004-05-02 18:22:26 UTC
Version:           3.0.1 (using KDE KDE 3.2.0)
Installed from:    Unspecified Unix
Compiler:          gcc version 3.3.2 Configured with: /var/uhubuild/work/compile/configure --prefix=/usr --infodir=/usr/share/info --mandir=/usr/share/man --enable-languages=c,c++,objc,java,f77,pascal --enable-shared --with-gnu-as --with-gnu-ld --with-system-zlib --host=i386-pc-linux-gnu
OS:          Linux

So I created a php project into ~/public_html/php/ I put some files into some subdirs of this dir, and if I try to execute these files using apache and loopback it searches them in ~/public_html/php/ and hence these can't be executed. :(
But it runs them correctly if parsed using a php ELF executable interpreter.
Comment 1 frank 2005-11-24 19:50:07 UTC
i can confirm this bug with kdevelop-3.3.0-rc1
Comment 2 Imre Péntek 2006-04-12 17:57:35 UTC
In automake manager at the middle I click the second leftmost button, and kdevelop crashes. I cannot reproduce by intention.
Comment 3 Imre Péntek 2006-04-12 17:58:20 UTC
Well sorry, disregard my previous post.
Comment 4 Andreas Pakulat 2007-01-14 20:23:30 UTC
SVN commit 623419 by apaku:

Use project-relative path for opening php projects in web-mode.
BUG:80792


 M  +1 -1      phpsupportpart.cpp  


--- branches/kdevelop/3.4/languages/php/phpsupportpart.cpp #623418:623419
@@ -283,7 +283,7 @@
       KParts::ReadOnlyPart *ro_part = dynamic_cast<KParts::ReadOnlyPart*>(partController()->activePart());
       if (ro_part) {
          if ( configData->getInvocationMode() == PHPConfigData::Web )
-            file = ro_part->url().fileName();
+            file = URLUtil::relativePath( project()->projectDirectory(), ro_part->url().path() );
          else
             file = ro_part->url().path();
       }
Comment 5 Imre Péntek 2007-01-14 20:30:40 UTC
thanks.