Bug 79916 - 100% CPU usage after clicking into the editor window
Summary: 100% CPU usage after clicking into the editor window
Status: RESOLVED NOT A BUG
Alias: None
Product: quanta
Classification: Miscellaneous
Component: general (show other bugs)
Version: 3.2.1
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: András Manţia
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-04-18 22:05 UTC by Uwe Gansert
Modified: 2004-04-20 22:07 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Uwe Gansert 2004-04-18 22:05:11 UTC
Version:           3.2.1 (using KDE 3.2.1, SuSE)
Compiler:          gcc version 3.3.3 (SuSE Linux)
OS:          Linux (i686) release 2.6.4-52-default

this might have something to do with #73741 but I'm not so sure.
On SUSE Linux 9.1 i586 quanta uses 100% CPU power after clicking into the editor window. I compiled it on my own (quanta-3.2.1.tar.bz2 from download.kde.org) to be sure it's not a SUSE package bug. The same behaviour with the self compiled version.
I can start quanta and everything is fine, then, I can click on the left tree or into the menus and everything is fine but as soon as I click into the editor window, the cpu usage goes up to 100% and stays there until I close quanta.
Comment 1 András Manţia 2004-04-18 22:11:46 UTC
I'd like to see the behavior when you use the CVS version or 3.2.2 
(should appear in days on the KDE FTP servers).

Comment 2 Uwe Gansert 2004-04-19 21:45:50 UTC
I talked to the SUSE KDE guys too and they gave me a new kdelibs3 packet.
That packet solves the problem - so it's more a SUSE 9.1 bug than a quanta bug. 
Since the new kdelibs packet has version number 3.2.2 I don't know if this is a general kdelibs3-3.2.1 bug or a SUSE specific kdelibs3-3.2.1 bug.
Anyway, the new kdelibs3 packet (3.2.2) will be available for SUSE 9.1 users via online update or via ftp.
So, if you hear about this problem again, you know it might be the broken kdelibs3 packet.
Okay, now I can play around with quanta :)
Comment 3 András Manţia 2004-04-20 22:07:36 UTC
So it looks like a packaging (or kdelibs?) bug, after all.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.2 (GNU/Linux)

iD8DBQFAhYK/TQdfac6L/08RAoSPAKCLliodL9j3990joZNJXRGSzhmwDACfWV4E
nupGS2J2+/+DtmKtjLNJRSU=
=kfXx
-----END PGP SIGNATURE-----