Bug 79775 - REGRESSION: Ark won't extract: "*tar.gz" files using service menu: Extract Here.
Summary: REGRESSION: Ark won't extract: "*tar.gz" files using service menu: Extract Here.
Status: RESOLVED DUPLICATE of bug 79550
Alias: None
Product: ark
Classification: Unclassified
Component: general (show other bugs)
Version: 2.1.9
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Helio Castro
URL:
Keywords:
: 81655 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-04-16 21:24 UTC by James Richard Tyrer
Modified: 2004-05-15 22:48 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Error Message Box (12.98 KB, image/png)
2004-04-16 21:25 UTC, James Richard Tyrer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Richard Tyrer 2004-04-16 21:24:23 UTC
Version:           2.1.9 (using KDE KDE 3.2.2)
Installed from:    Compiled From Sources
Compiler:          GCC 3.3.3 
OS:          Linux

REGRESSION:

Upgrading to KDE-3.2.2 CVS has broken Ark.

I have uninstalled, did make distclean, and reinstalled, but it still doesn't work.

I right click a "*.tar.gz" file and choose:

	Actions -> Extract Here

I get the attached error box.

--
JRT
Comment 1 James Richard Tyrer 2004-04-16 21:25:33 UTC
Created attachment 5664 [details]
Error Message Box
Comment 2 Georg Robbers 2004-04-16 22:35:03 UTC

*** This bug has been marked as a duplicate of 79713 ***
Comment 3 James Richard Tyrer 2004-04-18 09:47:26 UTC
Really bad news.  This is not a duplicate. :-(  It is a new problem.  

I still can't extract a "*.tar.gz" file with the RMB: Actions -> Extract Here.

I have installed:

http://webcvs.kde.org/cgi-bin/cvsweb.cgi/kdeutils/ark/tar.cpp?rev=1.24.2.2&content-type=text/x-cvsweb-markup

and I have a current CVS of KDE_3_2_BRANCH (less than 12 hours old).

But I downloaded this by hand, and did make clean && make && make install on ark just to be sure.  Restarted KDE and the problem is still there. :-(

Please note the error message.  This is NOT the same as the message I got a couple of days ago before the new 'tar.cpp'.

Yes all of my utils are there:

[root@localhost WORK]# which tar
/bin/tar
[root@localhost WORK]# which gzip
/bin/gzip
[root@localhost WORK]# which gunzip
/bin/gunzip
[root@localhost WORK]# which bzip2
/usr/bin/bzip2
[root@localhost WORK]# which bunzip2
/usr/bin/bunzip2

I tried it with a: "*.tar" file and it works.  I tried it with a: "*.tar.bz2" file and it doesn't work.

--
JRT
Comment 4 Georg Robbers 2004-04-18 13:18:02 UTC

*** This bug has been marked as a duplicate of 79550 ***
Comment 5 Georg Robbers 2004-05-15 22:48:13 UTC
*** Bug 81655 has been marked as a duplicate of this bug. ***