Bug 79559 - language definition for spell checking
Summary: language definition for spell checking
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.5.3
Platform: OpenSUSE Linux
: NOR wishlist with 75 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-04-13 16:14 UTC by Pierre Burri
Modified: 2008-04-09 12:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pierre Burri 2004-04-13 16:14:30 UTC
Version:           1.5.3 (using KDE 3.1.1)
Installed from:    SuSE
Compiler:          gcc version 3.3 20030226 (prerelease) (SuSE Linux)
OS:          Linux (i686) release 2.4.20-4GB

I write emails every day in german, french and english. Every time I want to change the language, I have to go through 

Einstellungen/Settings -> Rechschreibprüfung/Spell Checking 

to define the desired language before I can start to check the spelling. Wouldn'it make more sense to be able to change the language in the spell checker windows? At least it would be very practical and faster. This is about the only feature I'm missing in KMail, otherwise I just love it.
Thank you for this great program.
Pierre Burri, linux teacher, administrator, fan and propagator :-)
Comment 1 Melchior Franz 2005-05-31 18:32:47 UTC
I'd like to have something like that, too. Ideally, it would simply be an "Action" per installed language, available in the toolbar config dialog. I would then be able to add a "German" and a "US-English" toolbar button to my composer window. (To make it prettier, I would also assign nice flag icons to the buttons. No need to code that, of course.) The buttons would act like radio-buttons, that is: at any time the currently selected language would be reflected as lowered button. None if the autoSpellCheck feature decided that my writings don't resemble any of the configured languages. But at any time I would also be able to select one particular language by pressing its button.
Comment 2 Jacek Piotrowski 2006-04-02 15:08:07 UTC
*** This bug has been confirmed by popular vote. ***
Comment 3 Jacek Piotrowski 2006-04-02 15:41:25 UTC
It would be nice if the default language was stored in account settings, so that if one uses different languages for different e-mail accounts, he wouldn't have to switch the spell checker forth and back.
Comment 4 Ingo Klöcker 2006-04-03 01:01:59 UTC
Since KDE 3.4 (or probably even earlier) one can change the language/dictionary in the spell checking dialog.

With respect to comment #3: The dictionary for automatic spellchecking is stored in the identity setting. Unfortunately, the spell checking dialog uses another dictionary setting.
Comment 5 Davide Rondini 2007-12-08 11:35:01 UTC
I think it should be very useful to introduce a per-contact basis language: if anyone uses more than a language to write his emails, surely he will use always the same language for the same contact person. So, it will be useful to set a default language, but to include a field in kaddressbook to set the default language you use to communicate with such a person. In alternative, as already suggested in comment #1, a button to select language spell checker, like Thunderbird does. 
Comment 6 Melchior Franz 2007-12-08 11:42:35 UTC
Don't know how far the spellchecking architecture in KDE4 is usable already, but it is supposed to make this wishlist item obsolete. "Sonnet" uses the right spellchecking automatically, on a per-sentence/paragraph basis.
Comment 7 Ronaldo Reis Júnior 2008-04-09 12:35:31 UTC
I agree the comment #5 and #1. Kmail has a on-the-fly spell check, but don't change the language on the fly. If I start a mail and my language is defined as portuguese and I writing in English, I cant change my language to spell check on-the-fly work with this new language. The new language work in the the spell check window, but not on the spell check on-the-fly. Now I try to look how to make the on-the-fly check to change and it not change.

Unfortunately the spell check on-the-fly in KDE programs is very precarious compared with others systems like thunderbird, firefox, emacs, etc.