Bug 79302 - Using "Up" button to exit a kio-slave causes problems for copy/paste, delete, etc
Summary: Using "Up" button to exit a kio-slave causes problems for copy/paste, delete,...
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: RedHat Enterprise Linux Linux
: NOR normal with 30 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 166093 169898 170807 174736 202338 205655 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-04-08 20:29 UTC by Wojciech Jarosz
Modified: 2009-11-02 20:16 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wojciech Jarosz 2004-04-08 20:29:54 UTC
Version:            (using KDE KDE 3.2.1)
Installed from:    RedHat RPMs

Using the "Up" button to navigate out of a tar or zip kio slave has incorrect behavior, but using the "Back" button works correctly. When using the "Up" button, "Move to trash" is disabled, and also copy/paste do not work. Seems that when using the "Up" button, konqueror still seems to think it is showing a tar file and therefore doesn't allow to paste or move to trash.

Reproduce:
Open a tar or zip file using the kio slave. select a file within the tar, and "copy." Use the "Up" button to move out of the tar file, and try to paste. An error is recieved saying: "Creating folders is not supported with protocol tar," or, "Writing to tar is not supported," depending on if you tried to copy a folder or file. This does not happen when using the "Back" button instead. Also, the "Move to trash" context item is disabled when leaving a tar kio slave using the "Up" button.
Comment 1 Mircea Bardac 2005-08-02 01:41:12 UTC
I have some comments in another bug on the "Up" action. They are about the KParts, but I feel like the comments could be easily addapted for KIOSlaves.

Here is the link: http://bugs.kde.org/show_bug.cgi?id=58672#c10

I think KIOSlaves should behave like:
a) KParts with attribute canNavigate==true in that comment.
Comment 2 Médéric Boquien 2008-08-05 16:41:44 UTC
*** Bug 166093 has been marked as a duplicate of this bug. ***
Comment 3 Dario Andres 2008-12-05 00:00:40 UTC
*** Bug 170807 has been marked as a duplicate of this bug. ***
Comment 4 Dario Andres 2008-12-05 00:03:40 UTC
*** Bug 169898 has been marked as a duplicate of this bug. ***
Comment 5 FiNeX 2009-08-03 00:29:31 UTC
*** Bug 202338 has been marked as a duplicate of this bug. ***
Comment 6 FiNeX 2009-08-03 00:30:53 UTC
from bug #202338
1) start konqueror
2) click on a compressed file (call it "test.tar")
-> the file content will be displayed like a normal folder
-> the URI is tar:// ... path ... /test.tar/

3) click "Up" button or press ALT+Up
-> the URI (on the location bar) will be: tar:// ... path .../

It is not only a naming problem: if you try to paste a file while the address
is wrong, it will be impossible. I don't know if there are other side effects.


Two notes: 
- dolphin behave right instead.
- pressing ALT+Left (or clicking on "BACK" action) is correct too.
Comment 7 FiNeX 2009-08-30 15:56:34 UTC
*** Bug 205655 has been marked as a duplicate of this bug. ***
Comment 8 Frank Reininghaus 2009-09-16 14:56:48 UTC
*** Bug 207572 has been marked as a duplicate of this bug. ***
Comment 9 David Faure 2009-09-21 13:12:14 UTC
SVN commit 1026290 by dfaure:

Backport for KDE-4.3.2, and close the master bug:
The redirection from zip to file wasn't appearing in konqueror because
zip:/tmp/ != zip:/tmp => do comparison without trailing slash.
BUG: 79302


 M  +2 -1      dolphinpart.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1026290
Comment 10 FiNeX 2009-09-21 17:42:55 UTC
@David: did you fix trunk too?
Comment 11 Frank Reininghaus 2009-09-21 22:44:20 UTC
(In reply to comment #10)
> @David: did you fix trunk too?

He did, see bug 207572 comment 2.
Comment 12 Frank Reininghaus 2009-11-02 20:16:36 UTC
*** Bug 174736 has been marked as a duplicate of this bug. ***