Bug 79042 - Shares with Arabic filenames don't behave properly
Summary: Shares with Arabic filenames don't behave properly
Status: RESOLVED WORKSFORME
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: 4.0.3
Platform: Mandrake RPMs Linux
: NOR normal with 161 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2004-04-04 12:59 UTC by Munzir Taha Obeid
Modified: 2018-10-27 04:03 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Munzir Taha Obeid 2004-04-04 12:59:44 UTC
Version:            (using KDE KDE 3.2.0)
Installed from:    Mandrake RPMs

If I right click a folder with with an Arabic filename to share it two problem happen
1. Right click -> share will always show it as Not shared in Local Net Sharing tab.

2. No icon (the plug which appears beneath the folder icon as an indicator of a share) doesn't show

The last point (#2) may need to be filed as a separate bug because I notice that even with English names it shows only if View -> Icon size is set to Large or Small but not with Huge and Medium

I am using Mandrake 10
Comment 1 Jan Schaefer 2004-11-10 10:16:47 UTC
This problem is still in KDE 3.3 if using simple file sharing. With advanced file sharing it works as expected (at least for German umlauts, cannot test Arabic characters here). 
The problem lies in the fileshareset script which gives the following error when calling it with a directory name that contains German umlauts:

Err: illegal path /home/jan/ütest
Comment 2 Ahmad Okda 2004-11-10 13:07:57 UTC
sow hat do u mean by advanced file sharing?, can u explain please
Comment 3 Jan Schaefer 2004-11-10 13:17:16 UTC
In KDE 3.3 you can now decide between advanced and simple file sharing. This can be changed in the control center under "network/file sharing".
The simple file sharing is the same as before, it uses a suid-root script called fileshareset to allow users to share folders from their home folder without knowing the root password.
The advanced file sharing is new and does not use any suid-root script. 
To share folders with the advanced file sharing the user have to know the root password, or must have write access to the Samba and NFS configuration files.
This can be done by creating a new group fileshare which owns these configuration files and put the desired users into that group. 

Comment 4 Munzir Taha 2004-11-14 14:28:51 UTC
Thanks Jan for the info, I will download KDE 3.3 and test this for Arabic

If it works then we need to only to solve this bug:
https://bugzilla.samba.org/show_bug.cgi?id=1338
Comment 5 Andrew Wang 2008-05-05 03:15:45 UTC
This is still present in versions 3.5.9 and 4.0.3 for "simple filesharing", the folder does appear to actually be shared, but the right click menu "Share" still shows itself as not being shared.
Comment 6 Janek Bevendorff 2012-06-18 19:33:36 UTC
There hasn't been any activity on this issue for some time. Please check if this issue is still valid for Konqueror 4.8.4 or later.
Comment 7 Andrew Crouthamel 2018-09-23 02:27:49 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 8 Andrew Crouthamel 2018-10-27 04:03:19 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!