Bug 78981 - crash when adding multiple WAV files to Audio-CD project
Summary: crash when adding multiple WAV files to Audio-CD project
Status: RESOLVED FIXED
Alias: None
Product: k3b
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Sebastian Trueg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-04-03 17:32 UTC by quin
Modified: 2005-02-15 18:31 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description quin 2004-04-03 17:32:16 UTC
Version:           0.11.9 (using KDE 3.2.1, SuSE)
Compiler:          gcc version 3.3 20030226 (prerelease) (SuSE Linux)
OS:          Linux (i686) release 2.4.20-4GB-athlon

k3b (0.11.9, Packman RPM) often crashes when multiple WAV files are added to an Audio-CD project. This might be related to bug 74144 (k3b crashes when adding multiple mp3s to an audio project).

Here is a trace:
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[New Thread 16384 (LWP 5020)]
[New Thread 32769 (LWP 5074)]
[New Thread 65539 (LWP 5078)]
0x4193dd2a in waitpid ()
   from /lib/libpthread.so.0
#0  0x4193dd2a in waitpid () from /lib/libpthread.so.0
#1  0x40f04cd9 in KCrash::defaultCrashHandler(int) ()
   from /opt/kde3/lib/libkdecore.so.4
#2  0x4193c895 in __pthread_sighandler () from /lib/libpthread.so.0
#3  <signal handler called>
#4  0x413c2cb4 in QListViewItem::sortChildItems(int, bool) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#5  0x413c33b8 in QListViewItem::enforceSortOrder() const ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#6  0x413c12b5 in QListViewItem::sort() () from /usr/lib/qt3/lib/libqt-mt.so.3
#7  0x413ce3d0 in QListView::sort() () from /usr/lib/qt3/lib/libqt-mt.so.3
#8  0x407d80dc in K3bAudioListView::slotUpdateItems() ()
   from /opt/kde3/lib/libk3bproject.so.2
#9  0x407d834c in K3bAudioListView::qt_invoke(int, QUObject*) ()
   from /opt/kde3/lib/libk3bproject.so.2
#10 0x412e3516 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#11 0x412e33b7 in QObject::activate_signal(int) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#12 0x40702929 in K3bDoc::changed() () from /opt/kde3/lib/libk3bproject.so.2
#13 0x407d43c1 in K3bAudioDoc::slotTrackChanged() ()
   from /opt/kde3/lib/libk3bproject.so.2
#14 0x407d469e in K3bAudioDoc::qt_invoke(int, QUObject*) ()
   from /opt/kde3/lib/libk3bproject.so.2
#15 0x412e35e1 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0x412e33b7 in QObject::activate_signal(int) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0x407e3939 in K3bAudioTrack::changed() ()
   from /opt/kde3/lib/libk3bproject.so.2
#18 0x407d552e in K3bAudioDoc::AudioTrackStatusThread::run() ()
   from /opt/kde3/lib/libk3bproject.so.2
#19 0x41276005 in QThreadInstance::start(void*) ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0x41936c60 in pthread_start_thread () from /lib/libpthread.so.0
Comment 1 Cesar 2004-04-19 12:57:24 UTC
I have also suffered the same crashed.
I added some files to an audio project, then I changed the directory in the selector, then dragged some more files, and k3b crashed.
I use Debian Sid k3b package (Version: 0.11.9-1).


This is the backtrace:

(no debugging symbols found)...Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 885)]
[New Thread 32769 (LWP 938)]
[New Thread 229379 (LWP 952)]
(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...0x41183bfb in waitpid () from /lib/libpthread.so.0
#0  0x41183bfb in waitpid () from /lib/libpthread.so.0
#1  0x40f58b78 in ?? () from /usr/lib/libkdecore.so.4
#2  0x00000014 in ?? ()
#3  0x40e87dc0 in KCrash::defaultCrashHandler () from /usr/lib/libkdecore.so.4
#4  0x41182815 in __pthread_sighandler () from /lib/libpthread.so.0
#5  <signal handler called>
#6  0x41d98b41 in QListViewItem::sortChildItems () from /usr/lib/libqt-mt.so.3
#7  0x41d9923d in QListViewItem::enforceSortOrder ()
   from /usr/lib/libqt-mt.so.3
#8  0x41d972b5 in QListViewItem::sort () from /usr/lib/libqt-mt.so.3
#9  0x41da4198 in QListView::sort () from /usr/lib/libqt-mt.so.3
#10 0x4076708e in K3bAudioListView::slotUpdateItems ()
   from /usr/lib/libk3bproject.so.2
#11 0x407672ef in K3bAudioListView::qt_invoke ()
   from /usr/lib/libk3bproject.so.2
#12 0x41cc0d16 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#13 0x41cc0bd4 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#14 0x406929ab in K3bDoc::changed () from /usr/lib/libk3bproject.so.2
#15 0x407634b3 in K3bAudioDoc::slotTrackChanged ()
   from /usr/lib/libk3bproject.so.2
#16 0x40763d72 in K3bAudioDoc::qt_invoke () from /usr/lib/libk3bproject.so.2
#17 0x41cc0d9c in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#18 0x41cc0bd4 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#19 0x4077265b in K3bAudioTrack::changed () from /usr/lib/libk3bproject.so.2
#20 0x407643a5 in K3bAudioDoc::AudioTrackStatusThread::run ()
   from /usr/lib/libk3bproject.so.2
#21 0x41c58f2a in QThreadInstance::start () from /usr/lib/libqt-mt.so.3
#22 0x4117ce51 in pthread_start_thread () from /lib/libpthread.so.0
#23 0x415f964a in clone () from /lib/libc.so.6
Comment 2 djk 2004-09-04 14:30:28 UTC
Some other info.
This bug appends quite often on my computer so I "tested it" ;) a lot (debian unstable, I used several k3b releases - 0.11.14 yet, and I think I remember the same problem on woody release).

The probelm is unpredictable :
1. sometimes adding files (from konqueror or inside k3b) is ok, and if you try the same operation, it can crash.
2. It does not depend on the file format - i tried with ogg, mp3 & wav (and not audio formats, that are skipped of course). Different encoding quality, also.
3. It does not depend on the number of files : even if I'd say that the more files you have, the more risks you can expect. Sometimes, trying to add files in splitted lists isn't enough : I even tried file by file, it does not crash on the same file.
4. Notice that after that kind of crash, some k3b PID are still in the system, you have to "killall", because the problem gets more frequent.

Finally, it doesn't seem to be related to other KDE components, because in SID, I used at least 3 releases (3.1x, 3.2x and now 3.3), it's still there.

Quite boring I'd say.

Jacques
------------
Here is the stack :

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 6252)]
[New Thread 32769 (LWP 6299)]
[New Thread 720898 (LWP 6343)]
[KCrash handler]
#6  0x414c5571 in QListViewItem::sortChildItems () from /usr/lib/libqt-mt.so.3
#7  0x414c5cba in QListViewItem::enforceSortOrder ()
   from /usr/lib/libqt-mt.so.3
#8  0x414c3c65 in QListViewItem::sort () from /usr/lib/libqt-mt.so.3
#9  0x414d0ee8 in QListView::sort () from /usr/lib/libqt-mt.so.3
#10 0x40873802 in K3bAudioListView::slotUpdateItems ()
   from /usr/lib/libk3bproject.so.2
#11 0x4087477f in K3bAudioListView::qt_invoke ()
   from /usr/lib/libk3bproject.so.2
#12 0x413e8486 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#13 0x413e8334 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#14 0x4079d0eb in K3bDoc::changed () from /usr/lib/libk3bproject.so.2
#15 0x4086f973 in K3bAudioDoc::slotTrackChanged ()
   from /usr/lib/libk3bproject.so.2
#16 0x40870232 in K3bAudioDoc::qt_invoke () from /usr/lib/libk3bproject.so.2
#17 0x413e850c in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#18 0x413e8334 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#19 0x4087faeb in K3bAudioTrack::changed () from /usr/lib/libk3bproject.so.2
#20 0x40870998 in K3bAudioDoc::AudioTrackStatusThread::run ()
   from /usr/lib/libk3bproject.so.2
#21 0x4137f2aa in QThreadInstance::start () from /usr/lib/libqt-mt.so.3
#22 0x418b5e51 in pthread_start_thread () from /lib/libpthread.so.0
#23 0x41ba869a in clone () from /lib/libc.so.6
Comment 3 Sebastian Trueg 2004-09-14 08:35:53 UTC
fixed (or better: hacked to work). will release soon.
Comment 4 Alexandros Papadopoulos 2004-10-13 23:18:38 UTC
Seeing this over here too, quite often I might add. My stack trace is identical to the one posted by Jacques. Would love to see it fixed! Thanks.
Comment 5 Krystof Zacek 2004-11-09 16:00:24 UTC
Hi, did I miss something? I am using the latest Debian package for K3b -  0.11.17-1 and still see K3b crashing when adding multiple wav files to audio project. Can you please let us know which version is it (will be) fixed in?

Thanks and keep up this awsome work!
Comment 6 schulze.sebastian 2005-02-15 17:11:58 UTC
This is still a problem to me, even with latest k3b 0.11.20 on Suse 9.2 with standard smp-kernel (2.6.8 ?). Any type .wav .ogg .mp3 .ape same result, when selecting multiple files to the project.
If I put single files step by step to the project it works, but this is not a very  good workaround for me.
Comment 7 Sebastian Trueg 2005-02-15 18:31:40 UTC
ok, fixed in cvs for 0.12. there will probably be no fix in the 0.11 tree since I do not know the reason of the crash and cannot reproduce it.