Bug 75304 - KB is not KiB (modern metric system and binary multiples)
Summary: KB is not KiB (modern metric system and binary multiples)
Status: RESOLVED DUPLICATE of bug 57240
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Mandrake RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-02-15 20:40 UTC by Js Lebacq
Modified: 2004-02-17 17:11 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Js Lebacq 2004-02-15 20:40:02 UTC
Version:            (using KDE KDE 3.2.0)
Installed from:    Mandrake RPMs

In Konqueror, we can read things like that in a file properties :

«35,2 KB (36 033)»

Well, it's false and doubtful, because:
36 033 B = 36,033 KB
36 033 B = 35,2 KiB

It's the same problem in french (Giga instead of Gibi for example)

See http://physics.nist.gov/cuu/Units/binary.html for more explanations.



Also, it could be a good idea to let the user choose between the metric system and the binary system. Personnaly, I prefer the metric system:
- the manufacturers of computer storage devices usually use the metric system
- It's easier to compare GB and KB.

That second point is a wish, but IMHO it is associated to the first point, wich is a bug.
Comment 1 Stephan Binner 2004-02-17 17:11:25 UTC

*** This bug has been marked as a duplicate of 57240 ***