Bug 75231 - korganizer: create a shortcut for web export
Summary: korganizer: create a shortcut for web export
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Cornelius Schumacher
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-02-14 16:44 UTC by Dominique Devriese
Modified: 2006-04-27 11:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
2004-07-30_KOrganizer_ShortCutsForPlugins_MenuAccels_Bug75231.patch (20.48 KB, patch)
2004-07-30 20:27 UTC, Reinhold Kainhofer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dominique Devriese 2004-02-14 16:44:31 UTC
Version:            (using KDE KDE 3.1.5)
Installed from:    Debian testing/unstable Packages

Hi,

Note: this is a forward of the following Debian bug report: http://bugs.debian.org/230789.

   It would be nice if i could export my To Do list and calendar with 
   a shortcut.  BTW the web export feature is a plugin. 

I confirmed the bug report: I cannot assign a shortcut to the action he's talking about in the "edit shortcuts" dialog.

thanks
domi
Comment 1 Reinhold Kainhofer 2004-07-30 20:27:33 UTC
This patch adds accels to all menu items of korganizer (serveral items were 
lacking those!), and it also makes all action collections of the plugins 
available in the shortcut dialog. Thus, this patch fixes bug 75231.

With the KKeyDialog we cannot use the static KKeyDialog::configure, but have 
to create a KKeyDialog, and manually add all actionCollection()'s of all 
KOrg::Part's. For this I had to add a method getActionCollection to the 
KOrg::MainWindow interface to make available it's actioncollection, too.

Also, since the actions in the key dialog will be displayed in a different 
category (parent item in the list view), I added a pure virtual method 
QString shortInfo() const to the KOrg::Part class. This method returns the 
name of the part, like "Exchange Plugin" or "Project View Plugin", and is 
currently only used as parent item in the shortcut dialog, but there might be 
more uses in the future.

Unfortunately KDE is in feature and string freeze for KDE 3.3, so I cannot 
apply this patch before kde 3.3 is released. This also means that the fix 
will only be released with kde 3.4...

Cheers,
Reinhold


Created an attachment (id=6935)
2004-07-30_KOrganizer_ShortCutsForPlugins_MenuAccels_Bug75231.patch
Comment 2 Dominique Devriese 2004-07-30 22:48:10 UTC
Reinhold Kainhofer writes:

> ------- Additional Comments From reinhold kainhofer com 2004-07-30
>         20:27 -------
> This patch adds accels to all menu items of korganizer (serveral
> items were lacking those!), and it also makes all action collections
> of the plugins available in the shortcut dialog. Thus, this patch
> fixes bug 75231.

Great, thanks
cheers
domi

Comment 3 Reinhold Kainhofer 2004-08-14 13:06:37 UTC
CVS commit by kainhofe: 

Make the ActionCollection of plugins also available in the shortcut dialog.
CCMAIL: 75231-done@bugs.kde.org


  M +27 -20    actionmanager.cpp   1.96
  M +2 -7      actionmanager.h   1.37
  M +0 -8      korganizer.cpp   1.178
  M +1 -2      korganizer.h   1.78
  M +0 -9      korganizer_part.cpp   1.62
  M +1 -2      korganizer_part.h   1.27
  M +2 -2      korganizer_part.rc   1.18
  M +2 -2      korganizerui.rc   1.54
  M +4 -0      interfaces/korganizer/mainwindow.h   1.15
  M +2 -0      interfaces/korganizer/part.h   1.9
  M +9 -4      plugins/exchange/exchange.cpp   1.23
  M +3 -1      plugins/exchange/exchange.h   1.9
  M +6 -1      plugins/projectview/projectview.cpp   1.12
  M +2 -1      plugins/projectview/projectview.h   1.4
  M +6 -1      plugins/webexport/webexport.cpp   1.15
  M +2 -1      plugins/webexport/webexport.h   1.8