Bug 7506 - landscape pages are not displayed correct - some chars ar missing
Summary: landscape pages are not displayed correct - some chars ar missing
Status: RESOLVED WORKSFORME
Alias: None
Product: kghostview
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Other
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Wilco Greven
URL:
Keywords:
: 46774 50858 (view as bug list)
Depends on:
Blocks:
 
Reported: 2000-08-04 18:19 UTC by Unknown
Modified: 2003-09-16 21:42 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
the test case (50.43 KB, application/octet-stream)
2003-04-08 21:46 UTC, Luís Pedro Coelho
Details
A pdf that doesn't display correctly (358.63 KB, application/pdf)
2003-09-16 21:42 UTC, Rene Horn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ferdinand Gassauer 2000-08-04 18:14:37 UTC
(*** This bug was imported into bugs.kde.org ***)

Hi
http://www.zamg.ac.at/klima/moue_hist/2000/07/WIEWARS.PDF
some characters are missing at the right side
-- 
(KDE 2 on SuSE 6.4 source: cvsup max 24 hours old from 
host=ferret.lmh.ox.ac.uk daily rebuild) 

mit freundlichen GrüÃen / with best regards
Ferdinand Gassauer

PS. 
Besuchen Sie doch auch unsere WEB-Seite
please visit our WEB-page
http://www.goesing.at
Comment 1 Ferdinand Gassauer 2000-08-25 17:31:48 UTC
Hi!
this is due to the fact that kghostview assumes "legal" instead of A4 .
A4 display is correct.
IMOH the legal/A4 issue is a SHIP STOPPER
most / all of the european KDE users going to have problems with format 
defaulting to legal.
-- 
(KDE 2 on SuSE 6.4 source: cvsup max 24 hours old from 
host=ferret.lmh.ox.ac.uk daily rebuild) 

mit freundlichen GrüÃen / with best regards
Ferdinand Gassauer

PS. 
Besuchen Sie doch auch unsere WEB-Seite
please visit our WEB-page
http://www.goesing.at
Comment 2 Ferdinand Gassauer 2000-09-19 21:00:48 UTC
Hi!
if it would default to legal more documents could be displayed
but it defaults to letter - that's the problem
(I got confused with all the formats ...)
-- 
(KDE 2 on SuSE 6.4 source: cvs max 24 hours old from 
 finwal03.tu-graz.ac.at daily rebuild) 

mit freundlichen GrüÃen / with best regards
Ferdinand Gassauer

PS. 
Besuchen Sie doch auch unsere WEB-Seite
please visit our WEB-page
http://www.goesing.at
Comment 3 Ferdinand Gassauer 2001-01-12 20:12:14 UTC
see  http://www.zamg.ac.at/klima/moue_hist/2000/07/WIEWARS.PDF
its printed top down instead left right
-- 
(KDE 2 on SuSE 7.0 source: cvs max 24 hours old from
 anoncvs.kde.org daily rebuild) 

mit freundlichen GrüÃen / with best regards
Ferdinand Gassauer

PS. 
Besuchen Sie doch auch unsere WEB-Seite
please visit our WEB-page
http://www.goesing.at
Comment 4 Ferdinand Gassauer 2001-05-19 16:59:33 UTC
Hi!
landscape format not recognized now
-- 
KDE 2 - current CVS on SuSE 7.1 X86Free 4.0.3

regards
Ferdinand Gassauer
mailto:f.gassauer@aon.at
mailto:gassauer@kde.org
http://www.goesing.at
Comment 5 Ferdinand Gassauer 2001-07-30 17:06:43 UTC
It' possible to view the file but printing does not position the file 
correctly
CVS from this morning 2 CEST
-- 
cu
ferdinand
on SuSE 7.0 current CVS
Comment 6 Ferdinand Gassauer 2001-08-05 12:20:09 UTC
-- 
KDE 2 - current CVS on SuSE 7.1 X86Free 4.1.0

regards
Ferdinand Gassauer
mailto:f.gassauer@aon.at
mailto:gassauer@kde.org
http://www.goesing.at
Comment 7 Ferdinand Gassauer 2001-12-29 21:13:04 UTC
Hi
i can supply the file if someone needs it
the file is displayed correctly with acroread
cu
ferdinand
Comment 8 Wilco Greven 2002-01-01 14:21:55 UTC
On Saturday 29 December 2001 22:13 you wrote:
> Hi
> i can supply the file if someone needs it
> the file is displayed correctly with acroread

I have on my harddisk (as I do with most of the files related to bugs). I k=
now=20
what's causing the bug and I'll try to fix it for KDE3.0.

Thanks for the offer greetings
Wilco
Comment 9 Wilco Greven 2002-08-22 12:57:19 UTC
Hello Ferdinand

I have made another try to fix this bug and as far as I can see it's not=20
possible to fix it in KGhostView. It would require changes to Ghostscript's=
=20
X11 driver. From what I understood from the Ghostscript people the way the=
=20
orientation is set by the X11 predates Ghostscript's PDF support and that'=
s=20
causing the problem. My plans for the future (I don't have a timeline for=
=20
that) are to add support for Ghostscript's display driver. That would give =
a=20
solution for the problem.

Greetings
Wilco
Comment 10 Wilco Greven 2002-11-09 21:36:59 UTC
*** Bug 46774 has been marked as a duplicate of this bug. ***
Comment 11 Wilco Greven 2003-01-07 22:58:36 UTC
*** Bug 50858 has been marked as a duplicate of this bug. ***
Comment 12 J E Drews 2003-03-08 19:40:14 UTC
KGhostView 0.13.2 in KDE 3.1.0 
Compiled from sources 
SuSE 8.1 
 
I tried to verify this bug but the URL 
http://www.zamg.ac.at/klima/moue_hist/2000/07/WIEWARS.PDF 
is no longer valid. I tested various pdf documents using different paper sizes and 
orientations and Kghostview worked just fine. 
Comment 13 Ferdinand Gassauer 2003-03-08 23:03:29 UTC
the links to the file is a bit hidden now 
 
http://www2.zamg.ac.at/index.php3?xmlval_ID_KEY[]=0044&xmlval_SEL_ID_KEY[]=0044&xmlval_PARENT_KEY[]=0005&xmlval_LINK_TYPE[]=main&xmlval_CONT_TYPE[]=single&xmlval_OPEN[]=030 
 
got to "Atkuelles" - "Klima-Monats
Comment 14 Luís Pedro Coelho 2003-04-08 21:46:33 UTC
Created attachment 1325 [details]
the test case

External links go stale, so I am posting the above linked file here.
Comment 15 Ferdinand Gassauer 2003-04-17 22:23:18 UTC
thanks :-)) 
Comment 16 Rene Horn 2003-09-16 21:42:08 UTC
Created attachment 2479 [details]
A pdf that doesn't display correctly

This bug shouldn't be closed yet.  I'm still having problems with it with
current stable versions of KDE (3.1.3).

In addition to this attachment, I also have this PDF stored semi-permanently at
the following:
http://rhorn.unixcab.org/CSClub%20advertisement.pdf

That link shouldn't go stale since it's on my web site.  It may go stale if
this bug is actually resolved.