Bug 74889 - Mail signing takes place on another virtual desktop
Summary: Mail signing takes place on another virtual desktop
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: encryption (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
: 76698 78381 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-02-10 23:55 UTC by Luke-Jr
Modified: 2008-11-08 00:17 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luke-Jr 2004-02-10 23:55:24 UTC
Version:            (using KDE KDE 3.2.0)
Installed from:    Gentoo Packages

I write an email on Desktop M (#16, I think, but that shouldn't matter). When I click the send button it appears to freeze, but it is because the passphrase prompt is on Desktop 1, where Kontact is open.
Comment 1 Ingo Klöcker 2004-02-11 11:21:53 UTC
That's IMO a kwin bug. Nevertheless I'll check whether we can workaround this in KMail. It annoys me as well.
Comment 2 Michiel 2004-04-18 17:49:20 UTC
I have that too, with konqueror browser e.g. on desktop 1, but asking for certificate/downloaddialog on desktop 4.
Comment 3 Michiel 2004-04-18 17:50:25 UTC
I have that too, with konqueror browser e.g. on desktop 1, but asking for certificate/downloaddialog on desktop 4.
Si it's not a kmail bug, but indeed more likely a kwin bug.
Comment 4 Luke-Jr 2004-06-19 11:36:47 UTC
I do not currently know the password for this mail account. Until my session times out, I will continue to respond as usual, but once it does I may not be able to check it until Yahoo resets my password.
If you wish your message to be read soon, I suggest forwarding/CCing it to lukejr@benedictine.edu also.
Hopefully, this won't go to mailing lists, but in case it does, Yahoo's help says it should only be sent once to each person anyway so this should be the only time you get it.

--------------------


Original Message:


X-Rocket-Track: 1: 100 ; SERVER=66.218.86.252
X-Originating-IP: [131.246.103.200]
Return-Path: <anonymous@ktown.kde.org>
Received: from 131.246.103.200  (HELO ktown.kde.org) (131.246.103.200)
  by mta320.mail.scd.yahoo.com with SMTP; Sat, 19 Jun 2004 02:36:08 -0700
Received: (qmail 12731 invoked by uid 30); 19 Jun 2004 09:36:01 -0000
Date: 19 Jun 2004 09:36:01 -0000
Message-ID: <20040619093601.12730.qmail@ktown.kde.org>
From: Stephan Binner <binner@kde.org>
To: luke7jr@yahoo.com
Sender: owner@bugs.kde.org
Reply-To: 74889@bugs.kde.org
Subject: [Bug 74889] Mail signing takes place on another virtual desktop 
Content-Type: text/plain; charset="utf-8" 
X-Bugzilla-URL: http://bugs.kde.org/  
X-Bugzilla-Reason: Reporter      

------- You are receiving this mail because: -------
You reported the bug, or are watching the reporter.
      
http://bugs.kde.org/show_bug.cgi?id=74889      
binner kde org changed:

           What    |Removed                     |Added
-----------------------------
_________________________________________________________
DO YOU YAHOO!?
Get your free @yahoo.com address at http://mail.yahoo.com

Comment 5 Lubos Lunak 2004-06-21 11:39:28 UTC
I'm not aware of any relevant kwin bug, so if you have latest qt+kdelibs+kdebase and the bug still exists, the dialog has most probably wrong parent window specified.
Comment 6 pitard.philippe 2004-06-24 18:19:28 UTC
I have all the above with Mandrake 10.0.
This bug kills the concept of virtual desktops
Thanks for a workaround soon!!
Comment 7 pitard.philippe 2004-06-24 18:23:42 UTC
I Have the same behaviour with Mandrake 10.0 KDE 3.2. Very annoying. Kills the 
virtual desktop concept.

Comment 8 Tom Albers 2004-10-09 23:10:13 UTC
*** Bug 76698 has been marked as a duplicate of this bug. ***
Comment 9 Tom Albers 2004-10-09 23:34:10 UTC
*** Bug 78381 has been marked as a duplicate of this bug. ***
Comment 10 Rolf Eike Beer 2007-09-19 19:15:14 UTC
Works for me (KDE 3.5.7)
Comment 11 Luke-Jr 2007-09-19 20:50:32 UTC
It works with gpg-agent. Try again with normal non-agent signing stuff?
Comment 12 Jaime Torres 2008-09-09 18:32:55 UTC
In 1.10.1 (kde 4.1.1), all the new windows have opened in the same virtual desktop as the parent window was.
Comment 13 Dominik Tritscher 2008-11-08 00:17:09 UTC
Tried the same with 1.10.3 and it works here to. I'm closing this.