Bug 72922 - Karbon renders colors incorrectly on ppc
Summary: Karbon renders colors incorrectly on ppc
Status: RESOLVED FIXED
Alias: None
Product: karbon
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Rob Buis
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-01-19 01:04 UTC by Ben Burton
Modified: 2008-05-22 01:00 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Burton 2004-01-19 01:04:28 UTC
Version:           1.2.95 (using KDE KDE 3.1.4)
Installed from:    Debian testing/unstable Packages
OS:          Linux

(Received through the Debian BTS as #226116.)

(I cannot reproduce this bug since I only have i386 machines to test on, but if you CC 226116-submitter@bugs.debian.org then you'll keep the original bug submitter in the loop. - Ben.)

Karbon14 seems to be suffering an endianness bug on PPC.  When a blank document is selected, the page appears as cyan.  Drawing a square and filling it with solid white also produces cyan on the canvas, even though the color (and *all* colors) appears correct in the color dialog.  Seems like the karbon14-specific canvas code is messing up the rgb values due to endianness assumptions.
Comment 1 Lee Braiden 2005-01-18 00:52:48 UTC
Any progress on this?  To provide a little more info...

When I select a circle, and set it's RGB value to black, that's fine.  When I then increase the R slider, nothing happens.  Increasing only the G slider makes it blue, while increasing only the B slider makes it green.
Comment 2 Michael Bannister 2005-06-27 09:38:31 UTC
filling a shape with a colour at 99% opacity works fine.  100% opacity and <bang> it goes wrong as described above.
Comment 3 Paolo Peruzzi 2006-06-26 09:43:38 UTC
Same for me, I have to use the 99% opacity. If I choose 100% "white" for example, it is displayed as cyan eventhough any other viewer application shows the save file correctly.
Comment 4 Jan Hambrecht 2008-05-22 01:00:33 UTC
I think this one can safely be closed now. Karbon in trunk does use Qt for all the drawing now, which does the right thing (TM) with regard to endianness.