Bug 70400 - New tabbing widget does not have scrolling buttons in RTL mode
Summary: New tabbing widget does not have scrolling buttons in RTL mode
Status: RESOLVED NOT A BUG
Alias: None
Product: kdelibs
Classification: Unclassified
Component: qt (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal with 59 votes (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-12-14 15:21 UTC by Oded Arbel
Modified: 2007-12-13 23:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oded Arbel 2003-12-14 15:21:12 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc 3.3.1 
OS:          Linux

The new tabbing widget in konqueror does not have scrolling buttons. the tab auto-resize solves most problems, but when a really large number of tabs are used, the extra tabs disappear at the end of the view and there is no way to get to them except by keyboard shortcuts (which are a mess, see Bug 62755).
Comment 1 Teemu Rytilahti 2003-12-14 17:07:37 UTC
Umm, hmm, I have those scrolling buttons in the right side of the tabbar, if there's a lot of tabs open.. So works for me, using today's head.
Comment 2 Oded Arbel 2003-12-14 17:33:46 UTC
Subject: Re:  New tabbing widget does not have scrolling buttons

> Umm, hmm, I have those scrolling buttons in the right side of the tabbar,
> if there's a lot of tabs open.. So works for me, using today's head.

Ohh. right, they do. :-)
Then I need to change the bug's title - they do appear, but always on the 
right side of the widget, and in RTL context (Hebrew, Arabic) they are 
invisible (probably something that has to do with the overflow problem in Bug 
70414).

Also - please check on your system - but in mine the left button doesn't work. 
if I'm looking at the first tab, then I can scroll right to the last tab, but 
I can't scroll back left.

Comment 3 Maksim Orlovich 2004-05-30 19:07:56 UTC
I can confirm by just creating a lot of tabs in designer started with -reverse. Qt: 3.3.3-snapshot-20040525 + qt-copy patches. 
Comment 4 Stephan Binner 2004-07-17 07:51:50 UTC
Confirmed by Trolltech as Issue N52768.
Comment 5 Diego Iastrubni 2007-12-13 23:02:20 UTC
Still happening in KDE3, but not in KDE4. 

Since this is an upstream issue. Lets close.