Bug 70053 - korganisizer doesn't support overnight working hours
Summary: korganisizer doesn't support overnight working hours
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Cornelius Schumacher
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-12-10 22:03 UTC by Riku Voipio
Modified: 2006-04-27 11:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Riku Voipio 2003-12-10 22:03:25 UTC
Version:            (using KDE KDE 3.1.4)
Installed from:    Debian testing/unstable Packages

from 
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=185957
--
Those of us working the night shift cannot set korganizer's idea of a workday overnight.  Example:  19:00-05:00.
--
(on 3.1.4 you can, but korganisizer doesn't "grey" they work area if you do so)
Comment 1 Reinhold Kainhofer 2004-03-30 20:02:56 UTC
CVS commit by kainhofe: 

Finally, korganizer supports overnight working hours, and allows the user to select which days are working days (using seven check boxes, one for each day of the week).

A few words concerning night shift:
For overnight working hours, I use the day when the shift starts to determine if the shift is on a holiday, and thus shouldn't be drawn as work shift. As an example: If you have working hours Mon-Fri from 20:00 - 05:00, then you'll see the following shifts:
Mon 20:00 - Tue 05:00
Tue 20:00 - Wed 05:00
...
Fri 20:00 - Sat 05:00

But NOT Sat 20:00-Sun05:00 and also not Sun 20:00 - Mon 05:00 (because in these cases the shift starts on a day that is not a working day). The same applies to holidays: If the tuesday is a holiday, the shift from tuesday evening to wednesday morning will not be shown. I hope this is the expected behavior...

CCMAIL: 70053-done@bugs.kde.org, 56611-done@bugs.kde.org


  M +24 -16    koagenda.cpp   1.106
  M +19 -13    koagendaview.cpp   1.133
  M +30 -7     koprefsdialog.cpp   1.93
  M +3 -4      korganizer.kcfg   1.14