Bug 69877 - PNG image displays as black rectangle
Summary: PNG image displays as black rectangle
Status: RESOLVED WORKSFORME
Alias: None
Product: kdelibs
Classification: Unclassified
Component: qt (show other bugs)
Version: 3.2-beta
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-12-08 20:42 UTC by Brad Hards
Modified: 2007-11-07 18:57 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brad Hards 2003-12-08 20:42:18 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc version 3.2 (Mandrake Linux 9.0 3.2-1mdk)
 
OS:          Linux

When opening, http://www.stillhq.com/cgi-bin/getpage?area=christmas&page=twinkletux, the image at http://www.stillhq.com/christmas/twinkletux-videoproj.png is displayed as a black rectange. Some of the following images on that page are also displayed as black rectangles.

The images display fine in kuickshow, but they will not display embedded in konqi (either as part of a HTML page, or alone).
Comment 1 Thiago Macieira 2003-12-08 21:12:17 UTC
I can confirm this behaviour. Valgrind log shows nothing special.

Some images in the page also get sections from other images or from other parts of my windows. Imagine my surprise when I clicked your link above and it showed me a section of an image I had seen previously along with a KSpell dictionary menu under it.
Comment 2 Fred Wells 2003-12-18 21:32:42 UTC
I also am experiencing this problem. 

See http://www.roland-riegel.de/nload/screenshot_en.html
Comment 3 John Firebaugh 2003-12-28 07:37:52 UTC
The first image appears to be slightly bogus: it's 480 x 640, but specifies an offset of -480 x 0 pixels.

Qt 3.3 was fixed and now displays the image in comment #2 correctly.
Comment 4 Fred Wells 2004-05-06 16:55:15 UTC
It appears to have been fixed.  I can't reproduce it in kde3.2.2.
Comment 5 Ismail Donmez 2004-05-06 20:13:23 UTC
Still broken for me . KDE CVS HEAD + Qt Copy
Comment 6 Brad Hards 2004-05-11 12:12:56 UTC
Also still happening for me with CVS HEAD + Qt 3.3.1
Comment 7 Brad Hards 2005-02-03 08:06:53 UTC
This no longer seems to be a problem with current CVS HEAD and qt-copy. Closing