Bug 69236 - Promote semantic rather than physical markup in toolbars, menus, and shortcut keys
Summary: Promote semantic rather than physical markup in toolbars, menus, and shortcut...
Status: RESOLVED FIXED
Alias: None
Product: kile
Classification: Unclassified
Component: general (show other bugs)
Version: 1.6
Platform: openSUSE RPMs Linux
: NOR wishlist with 3 votes (vote)
Target Milestone: ---
Assignee: Jeroen Wijnhout
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-11-28 18:46 UTC by Tristan Miller
Modified: 2007-03-27 17:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tristan Miller 2003-11-28 18:46:43 UTC
Version:           1.6 (using KDE KDE 3.1.4)
Installed from:    SuSE RPMs

This report is on a fine line between a bug and a wish; while the existing font selection features work as intended, their very existence is problematic in that they encourage people to write very poor LaTeX code.

Like HTML, the philosophy of LaTeX is that the user specifies the structure and semantics of the text, while the formatting details are left to the computer.  This is in stark contrast to the word processor approach, where there is little separation of style from content, and the user has a greater responsibility for explicitly setting the margins, font faces, etc.

For this reason, it's a bad idea to prominently provide toolbar buttons and menu commands for the physical styles bold, italicized, and underlined text (\textbf{}, textit{}, etc.) while not providing any for the semantic styles strong and emphasized text (\strong{}, \emph{}).  Copy editors who must review and edit manuscripts routinely find themselves banging their heads against their keyboards when they discover that an author has decided to use underlining (or some other non-standard physical style) for emphasis when the style guide prescribes italics instead.  If the author had used \emph{}, this would be an easy fix; if the author had used \uline{}, however,  then each and every instance of this macro must be manually checked to make sure that the author really did mean emphasis and was not using the underline markup for some other purpose.

I recommend removing the B, I, and U buttons from the default toolbar and replacing them with "strong" and "emphasis" buttons.  (The B/I/U buttons could be made available by customizing the toolbar.)  I also recommend adding keyboard shortcuts for these styles, removing the shortcuts for the existing physical styles if necessary.
Comment 1 Jeroen Wijnhout 2003-12-01 18:08:31 UTC
Subject: Re:  New: Promote semantic rather than physical markup in
 toolbars, menus, and shortcut keys

On Friday 28 November 2003 06:46 pm, you wrote:
> This report is on a fine line between a bug and a wish; while the existing
> font selection features work as intended, their very existence is
> problematic in that they encourage people to write very poor LaTeX code.

That's just a matter of perspective, isn't it? TeX is not a markup language, 
it is a typesetting language. Anyway I do get your point.

> I recommend removing the B, I, and U buttons from the default toolbar and
> replacing them with "strong" and "emphasis" buttons.  (The B/I/U buttons
> could be made available by customizing the toolbar.)  I also recommend
> adding keyboard shortcuts for these styles, removing the shortcuts for the
> existing physical styles if necessary.

I could add some extra toolbar buttons, but that would clutter the the 
toolbars too much. Instead, I think Kile needs to have more standard toolbars 
the user could choose from. One such toolbar would contain Strong and 
Emphasis buttons instead of the B,I, U buttons. I did not plan anything 
yet...

best,
Jeroen

Comment 2 Tristan Miller 2003-12-26 00:08:20 UTC
Subject: Re:  Promote semantic rather than physical markup in toolbars, menus, and shortcut keys

Greetings.

On Monday 01 December 2003 18:08, you wrote:
> That's just a matter of perspective, isn't it? TeX is not a markup
> language, it is a typesetting language. Anyway I do get your point.

TeX may be a typesetting language, but LaTeX is primarily a markup language 
which deliberately obscures the typesetting details.  I was under the 
impression that Kile was aimed more at LaTeX users than TeX users... 
though if I'm wrong, perhaps it would be a good idea to have different TeX 
and LaTeX modes with different default toolbars and settings.

Regards,
Tristan

Comment 3 A T Somers 2004-01-08 17:24:43 UTC
I agree with the reporter of this problem. It seems more LaTeX-like to supply \emph{} and \strong{} rather than B, U and I.
Comment 4 Stefan Borggraefe 2006-06-29 19:12:12 UTC
*** This bug has been confirmed by popular vote. ***
Comment 5 Holger Danielsson 2007-03-27 17:53:22 UTC
Thank you for your bug report.

The bug that you reported has been identified and fixed in the latest 
development (SVN) version of Kile.

Kile now offers possibilities for semantic markup. They are not shown 
in toolbars and also have no shortcut so far, but all users can 
configure these menu entries as they want.

ciao holger