Bug 68878 - Plastik KWin decoration has rendering errors (on PPC)
Summary: Plastik KWin decoration has rendering errors (on PPC)
Status: RESOLVED WORKSFORME
Alias: None
Product: kwin
Classification: Plasma
Component: decorations (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: investigated, triaged
Depends on:
Blocks:
 
Reported: 2003-11-23 21:01 UTC by Ernst Persson
Modified: 2018-10-21 05:06 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot (76.17 KB, image/png)
2003-11-24 17:48 UTC, Ernst Persson
Details
plastik_debug.tar.bz2 (2.92 KB, application/x-tbz)
2004-02-06 12:03 UTC, Ernst Persson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ernst Persson 2003-11-23 21:01:17 UTC
Version:            (using KDE KDE 3.1.93)
Installed from:    Compiled From Sources
Compiler:          gcc 3.3.2 Debian/Unstable
OS:          Linux

Ever since I first tried the Plastik theme the window decorations have had rendering errors.
They don't appear at first, but after a while they may appear on a specific window.
It's usually only one of the active or not-active states that get's affected.

My friend with the exactly same packages compiled on the same distribution but on x86 does not have these errors so I'm guessing it's PPC specific.

Runnning 16-bit color.

I'll add a screenshot as soon as I have compiled kdegraphics too!
Comment 1 Ernst Persson 2003-11-24 17:48:32 UTC
Created attachment 3385 [details]
Screenshot
Comment 2 Ernst Persson 2004-02-04 05:46:20 UTC
Noone is going to touch this?
Comment 3 Sandro Giessl 2004-02-05 18:42:59 UTC
Subject: Re:  Plastik KWin decoration has rendering errors (on PPC)

> ------- Additional Comments From ernstp@home.se  2004-02-04 05:46
> Noone is going to touch this?

Well, I don't own a PPC so I was hoping that someone else would be able 
to fix this bug. I will give it a try but frankly I don't have any clue 
where to begin... :)

- When you are handling such a window which looks broken, are there any 
warnings appearing in your ~/.xsession-errors? You can use "tail -f 
~/.xsession-errors" to watch the file...

- I have added some debug output to 
http://www.tnt22.com/files_sandro/plastik_debug_68878.tar.bz2 . Can you 
please install this package (./conigure ; make ; su -c 'make install' 
etc.), run "kwin --replace 2> plastik_debug" until the error appears 
again and then attach this file.

regards,
  Sandro

Comment 4 Ernst Persson 2004-02-06 12:03:41 UTC
Subject: Re:  Plastik KWin decoration has rendering errors (on PPC)

torsdagen den 5 februari 2004 18.43 skrev Sandro Giessl:

> Well, I don't own a PPC so I was hoping that someone else would be able
> to fix this bug. I will give it a try but frankly I don't have any clue
> where to begin... :)

I tried to look at it a bit too, but it was all just "simple" drawing, no 
strange bit shifts etc.. Hoped the maintainers would have more luck! ;-)

> - When you are handling such a window which looks broken, are there any
> warnings appearing in your ~/.xsession-errors? You can use "tail -f
> ~/.xsession-errors" to watch the file...

Nothing...

> - I have added some debug output to
> http://www.tnt22.com/files_sandro/plastik_debug_68878.tar.bz2 . Can you
> please install this package (./conigure ; make ; su -c 'make install'
> etc.), run "kwin --replace 2> plastik_debug" until the error appears
> again and then attach this file.
>
> regards,
>   Sandro

It got pretty large quite quick. I could not isolate it to only contain output 
from when the error appeared.

regards
//ernst


Created an attachment (id=4536)
plastik_debug.tar.bz2
Comment 5 Ernst Persson 2004-05-10 22:46:33 UTC
I don't think we ever got this right?
Not using my old iMac anymore so it's hard to tell.
Comment 6 Ben Burton 2004-06-15 16:34:15 UTC
Hi.  A PPC user has also reported this issue in the Debian BTS (#237279):

"The Plastik Window Decoration theme often shows artefacts in the windowbar. I've noticed them when a window receives focus. Sometime the artefacts are just dots, a line behind the window title. Sometimes more pixels are involved."

This was with KDE 3.2.1 on Linux 2.4.22-powerpc.  They then add the further comment:

"The artfacts remind me of somewhat similar looking problem in Netscape in the early days of Linux on Macintosh hardware. The problem only occurs on my PPC machine and not on my AMD box.  So I assume it is a litte vs big endian issue."

I can't confirm this, having only an i386 machine myself.  But the problem has been reproduced, with endianness as a possible culprit.

Ben.
Comment 7 Jonas Vejlin 2009-04-04 15:53:28 UTC
Do you stil have this problem with recent version of kwin?
Comment 8 Dario Andres 2009-05-02 23:32:36 UTC
Marking as NEEDSINFO
Comment 9 Andrew Crouthamel 2018-09-19 04:38:12 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please mark the bug as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 10 Andrew Crouthamel 2018-10-21 05:06:15 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!