Bug 67048 - kmail crashes when saving messages to a file
Summary: kmail crashes when saving messages to a file
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-11-02 13:25 UTC by beirne
Modified: 2007-09-14 12:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description beirne 2003-11-02 13:25:36 UTC
Version:           1.5.9 (using KDE KDE 3.1.92)
Installed from:    Compiled From Sources
Compiler:          gcc, probably 2-95 
OS:          Linux

Using Ctrl-A I selected all of the messages in a folder that contains filtered spam. I then hit Ctrl-S to save the messages to a file.  I accepted the default file name and hit enter.  Kmail then crashed.

I unfortunately can't reproduce this at will.  It happens unpredictably.

I'm using the Debian unstable package of libqt3c102-mt, version 3.2.1-6.

Backtrace:

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...[New Thread 16384 (LWP 14701)]

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...0x41a43a66 in waitpid ()
   from /lib/libpthread.so.0
#0  0x41a43a66 in waitpid () from /lib/libpthread.so.0
#1  0x41047c6f in KCrash::defaultCrashHandler(int) ()
   from /extra/kde32/lib/libkdecore.so.4
#2  0x41a42695 in __pthread_sighandler () from /lib/libpthread.so.0
#3  <signal handler called>
#4  0x41bf9087 in memcpy () from /lib/libc.so.6
#5  0x416ae131 in QGArray::duplicate(char const*, unsigned) ()
   from /usr/lib/libqt-mt.so.3
#6  0x08246fd4 in KMSaveMsgCommand::slotSaveDataReq() ()
#7  0x08240966 in KMSaveMsgCommand::qt_invoke(int, QUObject*) ()
#8  0x414118cc in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/libqt-mt.so.3
#9  0x4099db35 in KIO::TransferJob::dataReq(KIO::Job*, QMemArray<char>&) ()
   from /extra/kde32/lib/libkio.so.4
#10 0x4098bd11 in KIO::TransferJob::slotDataReq() ()
   from /extra/kde32/lib/libkio.so.4
#11 0x4099dfb4 in KIO::TransferJob::qt_invoke(int, QUObject*) ()
   from /extra/kde32/lib/libkio.so.4
#12 0x414118cc in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/libqt-mt.so.3
#13 0x41411704 in QObject::activate_signal(int) () from /usr/lib/libqt-mt.so.3
#14 0x4097b3dc in KIO::SlaveInterface::dataReq() ()
   from /extra/kde32/lib/libkio.so.4
#15 0x409782ef in KIO::SlaveInterface::dispatch(int, QMemArray<char> const&) ()
   from /extra/kde32/lib/libkio.so.4
#16 0x40977890 in KIO::SlaveInterface::dispatch() ()
   from /extra/kde32/lib/libkio.so.4
#17 0x40974878 in KIO::Slave::gotInput() () from /extra/kde32/lib/libkio.so.4
#18 0x40976ff8 in KIO::Slave::qt_invoke(int, QUObject*) ()
   from /extra/kde32/lib/libkio.so.4
#19 0x414118cc in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/libqt-mt.so.3
#20 0x41411a2d in QObject::activate_signal(int, int) ()
   from /usr/lib/libqt-mt.so.3
#21 0x4172f212 in QSocketNotifier::activated(int) ()
   from /usr/lib/libqt-mt.so.3
#22 0x4142d8a0 in QSocketNotifier::event(QEvent*) ()
   from /usr/lib/libqt-mt.so.3
#23 0x413b5eaf in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/libqt-mt.so.3
#24 0x413b54bb in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libqt-mt.so.3
#25 0x40fb0852 in KApplication::notify(QObject*, QEvent*) ()
   from /extra/kde32/lib/libkdecore.so.4
#26 0x413a5bfa in QEventLoop::activateSocketNotifiers() ()
   from /usr/lib/libqt-mt.so.3
#27 0x41362578 in QEventLoop::processEvents(unsigned) ()
   from /usr/lib/libqt-mt.so.3
#28 0x413c9698 in QEventLoop::enterLoop() () from /usr/lib/libqt-mt.so.3
#29 0x413c9548 in QEventLoop::exec() () from /usr/lib/libqt-mt.so.3
#30 0x413b6101 in QApplication::exec() () from /usr/lib/libqt-mt.so.3
#31 0x08098b19 in main ()
Comment 1 beirne 2003-11-15 13:56:21 UTC
This also happens with kmail 1.5.93 in the KDE 3.2 beta 1.

[New Thread 16384 (LWP 25973)]
0x41dd3bb8 in waitpid () from /lib/libpthread.so.0
#0  0x41dd3bb8 in waitpid () from /lib/libpthread.so.0
#1  0x41496e60 in __JCR_LIST__ () from /extra/kde32b/lib/libkdecore.so.4
#2  0x413ba7e4 in KCrash::defaultCrashHandler(int) ()
   from /extra/kde32b/lib/libkdecore.so.4
#3  0x41dd27f5 in __pthread_sighandler () from /lib/libpthread.so.0
#4  <signal handler called>
#5  0x4205a8f7 in memcpy () from /lib/libc.so.6
#6  0x41a2f131 in QGArray::duplicate(char const*, unsigned) ()
   from /usr/lib/libqt-mt.so.3
#7  0x4032d414 in KMSaveMsgCommand::slotSaveDataReq() ()
   from /extra/kde32b/lib/libkmailprivate.so.0
#8  0x40326d76 in KMSaveMsgCommand::qt_invoke(int, QUObject*) ()
   from /extra/kde32b/lib/libkmailprivate.so.0
#9  0x417928cc in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/libqt-mt.so.3
#10 0x40dc2685 in KIO::TransferJob::dataReq(KIO::Job*, QMemArray<char>&) ()
   from /extra/kde32b/lib/libkio.so.4
#11 0x40db0891 in KIO::TransferJob::slotDataReq() ()
   from /extra/kde32b/lib/libkio.so.4
#12 0x40dc2b04 in KIO::TransferJob::qt_invoke(int, QUObject*) ()
   from /extra/kde32b/lib/libkio.so.4
#13 0x417928cc in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/libqt-mt.so.3
#14 0x41792704 in QObject::activate_signal(int) () from /usr/lib/libqt-mt.so.3
#15 0x40d9ff2c in KIO::SlaveInterface::dataReq() ()
   from /extra/kde32b/lib/libkio.so.4
#16 0x40d9ce3f in KIO::SlaveInterface::dispatch(int, QMemArray<char> const&) ()
   from /extra/kde32b/lib/libkio.so.4
#17 0x40d9c3e0 in KIO::SlaveInterface::dispatch() ()
   from /extra/kde32b/lib/libkio.so.4
#18 0x40d993c8 in KIO::Slave::gotInput() () from /extra/kde32b/lib/libkio.so.4
#19 0x40d9bb48 in KIO::Slave::qt_invoke(int, QUObject*) ()
   from /extra/kde32b/lib/libkio.so.4
#20 0x417928cc in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/libqt-mt.so.3
#21 0x41792a2d in QObject::activate_signal(int, int) ()
   from /usr/lib/libqt-mt.so.3
#22 0x41ab0212 in QSocketNotifier::activated(int) ()
   from /usr/lib/libqt-mt.so.3
#23 0x417ae8a0 in QSocketNotifier::event(QEvent*) ()
   from /usr/lib/libqt-mt.so.3
#24 0x41736eaf in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/libqt-mt.so.3
#25 0x417364bb in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libqt-mt.so.3
#26 0x41321a5f in KApplication::notify(QObject*, QEvent*) ()
   from /extra/kde32b/lib/libkdecore.so.4
#27 0x41726bfa in QEventLoop::activateSocketNotifiers() ()
   from /usr/lib/libqt-mt.so.3
#28 0x416e3578 in QEventLoop::processEvents(unsigned) ()
   from /usr/lib/libqt-mt.so.3
#29 0x4174a698 in QEventLoop::enterLoop() () from /usr/lib/libqt-mt.so.3
#30 0x4174a548 in QEventLoop::exec() () from /usr/lib/libqt-mt.so.3
#31 0x41737101 in QApplication::exec() () from /usr/lib/libqt-mt.so.3
#32 0x0804ba17 in main ()
Comment 2 Till Adam 2003-12-01 20:12:04 UTC
Beirne, are you still seeing this with current cvs? Ingo fixed a bug in the save-as code that could have caused that crash.
Comment 3 beirne 2003-12-02 04:31:14 UTC
Subject: Re:  kmail crashes when saving messages to a file

On Monday 01 December 2003 02:12 pm, you wrote:
> ------- You are receiving this mail because: -------
> You reported the bug, or are watching the reporter.
>
> http://bugs.kde.org/show_bug.cgi?id=67048
>
>
>
>
> ------- Additional Comments From adam@kde.org  2003-12-01 20:12 -------
> Beirne, are you still seeing this with current cvs? Ingo fixed a bug in the
> save-as code that could have caused that crash.

It still happens fairly regularly.  I'm still on the beta, though.  I'll try 
the cvs and see.


Comment 4 beirne 2003-12-22 18:20:40 UTC
I didn't get the CVS version built but haven't had any trouble with kmail 1.5.94.
Comment 5 Till Adam 2003-12-22 19:38:43 UTC
I'll close it for now, please re-open if it rears its ugly head again.
Comment 6 Kjetil Kjernsmo 2005-01-22 12:08:03 UTC
There seems to be two bug reports in Debian's BTS for this problem, both reported against 3.3. Also, with the recent report of Bug 93912, it seems like this Bug Is Back! ;-)

For the Debian reports, please see
http://bugs.debian.org/279997
http://bugs.debian.org/290617

So, I figure it is time to re-open... 
Comment 7 Pierre Habouzit 2006-05-10 09:18:04 UTC
see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=290617
Comment 8 Philip Rodrigues 2006-10-29 12:15:29 UTC
Anyone still seeing this with KMail from KDE 3.5?
Comment 9 Michael Seiwert 2006-10-29 12:39:42 UTC
Tested with 5 different imap folders with different mailcounts, no crash at all
Comment 10 Philip Rodrigues 2007-01-28 18:52:06 UTC
No reports of this crash with recent versions. Please reopen if you see it again