Bug 66798 - klipper segfaults when editing clipboard content
Summary: klipper segfaults when editing clipboard content
Status: RESOLVED WORKSFORME
Alias: None
Product: klipper
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Esben Mose Hansen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-10-28 22:12 UTC by Riku Voipio
Modified: 2006-04-27 11:05 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Riku Voipio 2003-10-28 22:12:11 UTC
Version:            (using KDE KDE 3.1.2)
Installed from:    Debian testing/unstable Packages

(originally submitted to debian BTS as #198881 by Stephan Niemz.)

(I couldn't reproduce this, but the traceback may be of some intrest anyway.)

I did the following:

- Copy an URL to the clipboard
- Open the action menu for URLs
- Select "Edit contents" there
- Edit the URL

I noticed that just pressing "Ok" there didn't change the clipboard content.
I'm not sure why ... I just tried it again and this time it worked.

Anyways, so I did the following:

- Select the new URL in this editing window
- Maybe press Ctrl-C to copy, but I'm not sure any more
- New action menu pops up automatically while the edit window is still open
- Select an action there (in my case: open in a new Mozilla tab)
- Action happens, edit window is still open, although unvisible because it is
  covered by the Mozilla window
- Close the edit window by pressing "Ok"
- Klipper dies with a segmentation fault.

Thanks,

    - Stephan.

- Stack trace:
(no debugging symbols found)...(no debugging symbols found)...[New Thread 16384 (LWP 1047)]
(no debugging symbols found)...(no debugging symbols found)...0x40f71af9 in wait4 () from /lib/libc.so.6
#0  0x40f71af9 in wait4 () from /lib/libc.so.6
#1  0x40fe4f60 in sys_sigabbrev () from /lib/libc.so.6
#2  0x00000400 in ?? ()
#3  0x40f71aab in waitpid () from /lib/libc.so.6
#4  0x40d9f061 in waitpid () from /lib/libpthread.so.0
#5  0x405c4348 in KCrash::defaultCrashHandler(int) () from /usr/lib/libkdecore.so.4
#6  <signal handler called>
#7  0x40912197 in QObject::activate_signal(int, int) () from /usr/lib/libqt-mt.so.3
#8  0x40b89f35 in QPopupMenu::activatedRedirect(int) () from /usr/lib/libqt-mt.so.3
#9  0x409e264e in QPopupMenu::actSig(int, bool) () from /usr/lib/libqt-mt.so.3
#10 0x409e7589 in QPopupMenu::keyPressEvent(QKeyEvent*) () from /usr/lib/libqt-mt.so.3
#11 0x403aa939 in KPopupMenu::keyPressEvent(QKeyEvent*) () from /usr/lib/libkdeui.so.4
#12 0x4093f503 in QWidget::event(QEvent*) () from /usr/lib/libqt-mt.so.3
#13 0x408be1be in QApplication::internalNotify(QObject*, QEvent*) () from /usr/lib/libqt-mt.so.3
#14 0x408bdda7 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libqt-mt.so.3
#15 0x4056184b in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdecore.so.4
#16 0x4086e2ab in QETWidget::translateKeyEvent(_XEvent const*, bool) () from /usr/lib/libqt-mt.so.3
#17 0x4086a956 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libqt-mt.so.3
#18 0x4087d6b9 in QEventLoop::processEvents(unsigned) () from /usr/lib/libqt-mt.so.3
#19 0x408cf77b in QEventLoop::enterLoop() () from /usr/lib/libqt-mt.so.3
#20 0x408cf638 in QEventLoop::exec() () from /usr/lib/libqt-mt.so.3
#21 0x408be3b8 in QApplication::exec() () from /usr/lib/libqt-mt.so.3
#22 0x411f0390 in main () from /usr/lib/klipper.so
#23 0x0804c56f in strcpy ()
#24 0x00000001 in ?? ()
#25 0x08059958 in ?? ()
#26 0xbffff878 in ?? ()
#27 0x0804c582 in strcpy ()
Comment 1 Esben Mose Hansen 2005-02-04 22:06:18 UTC
I can't reproduce this, hard as I tried. If anyone manages to do so, please reopen.