Bug 66740 - Add icons for context menu on address in readerwin
Summary: Add icons for context menu on address in readerwin
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Unclassified
Component: keys and menus (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 66739 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-10-28 08:50 UTC by Mikolaj Machowski
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Adds icons to context menu on address in readerwin (940 bytes, patch)
2003-10-28 08:51 UTC, Mikolaj Machowski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mikolaj Machowski 2003-10-28 08:50:10 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources

Add icons for actions:
New Message To... (mail_new)
Reply To...       (mail_reply)
Forward To...     (mail_forward)

in RMB menu when clicking on address in readerwin.
Patch attached
Comment 1 Mikolaj Machowski 2003-10-28 08:51:41 UTC
Created attachment 2903 [details]
Adds icons to context menu on address in readerwin

Adds icons to context menu on address in readerwin
Comment 2 Ingo Klöcker 2003-10-28 09:38:06 UTC
*** Bug 66739 has been marked as a duplicate of this bug. ***
Comment 3 Mikolaj Machowski 2004-05-16 19:10:21 UTC
Why not adding those icons?
Comment 4 Mikolaj Machowski 2006-10-27 20:34:32 UTC
Why not adding those icons?
Without them this menu looks like no KDE menu.

OK, if you dont' want it, close it - I won't do it.
Comment 5 Allen Winter 2007-01-28 01:48:13 UTC
SVN commit 627763 by winterz:

merge SVN commit 627761 by winterz:

Fix bug "Add icons for context menu on address in readerwin"
Thanks for the patch Mikolaj.  Hey, we only took 3+ years to commit it! :)

BUGS: 66740


 M  +5 -5      kmreaderwin.cpp  


--- branches/KDE/3.5/kdepim/kmail/kmreaderwin.cpp #627762:627763
@@ -636,13 +636,13 @@
   mSelectEncodingAction->setItems( encodings );
   mSelectEncodingAction->setCurrentItem( 0 );
 
-  mMailToComposeAction = new KAction( i18n("New Message To..."), 0, this,
-                                      SLOT(slotMailtoCompose()), ac,
+  mMailToComposeAction = new KAction( i18n("New Message To..."), "mail_new",
+                                      0, this, SLOT(slotMailtoCompose()), ac,
                                       "mailto_compose" );
-  mMailToReplyAction = new KAction( i18n("Reply To..."), 0, this,
-				    SLOT(slotMailtoReply()), ac,
+  mMailToReplyAction = new KAction( i18n("Reply To..."), "mail_reply",
+                                    0, this, SLOT(slotMailtoReply()), ac,
 				    "mailto_reply" );
-  mMailToForwardAction = new KAction( i18n("Forward To..."),
+  mMailToForwardAction = new KAction( i18n("Forward To..."), "mail_forward",
                                       0, this, SLOT(slotMailtoForward()), ac,
                                       "mailto_forward" );
   mAddAddrBookAction = new KAction( i18n("Add to Address Book"),
Comment 6 Mikolaj Machowski 2007-01-28 11:32:08 UTC
Dnia niedziela 28 styczeń 2007, Allen Winter napisał:
>          Resolution|                            |FIXED
>
> --- branches/KDE/3.5/kdepim/kmail/kmreaderwin.cpp #627762:627763


Thanks. I hope it will be ported to trunk :)