Bug 64286 - Regression: css "position: relative" is placed wrongly inside tables
Summary: Regression: css "position: relative" is placed wrongly inside tables
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: khtml (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-09-14 22:59 UTC by troels
Modified: 2003-10-21 08:41 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description troels 2003-09-14 22:59:55 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources
Compiler:          GCC 3.3.1 
OS:          Linux

Placing elements by using the position: relative css code inside tables seems to use the wrong origin.

I noticed the problem on newz.dk, but isolated the problem to the test case found here:

http://www.tolstrup.org/kde/konqcssbug/test.html

A screenshot of the faulty rendering:

http://www.tolstrup.org/kde/konqcssbug/konq-head-wrong.png

Now what is quite strange is that if one selects the text from the left table cell then "poof", the page is relayouted correctly, screenshot of the result can be found here: (and this is how i would expect it to be rendered in the first place, which mozilla and opera does too)

http://www.tolstrup.org/kde/konqcssbug/konq-head-after-mouse-play.png

I do not know if the problem is limited to tables though

-Troels
Comment 1 Stephan Binner 2003-10-17 11:44:53 UTC
http://kde.ground.cz is affected by this too. :-(
Comment 2 Jason Keirstead 2003-10-20 02:02:46 UTC
I am not 100% sure but I think this is the same bug that is plaguing both the http://kopete.kde.org website and the Kopete Keramick theme. If so those would both be good testcases for it. Just open http://kopete.kde.org in Mozilla to see how it is supposed to render (and how KHTML used to render it).

I would like to also point out that this bug did not exist prior to around Sept. 7, 2003, because when I was creating this Keramick theme it looked fine.

So it has been some CSS regression since then.
Comment 3 Jason Keirstead 2003-10-20 13:42:13 UTC
As of Oct 20 2003 (just updated my HEAD last night ), the rendering bug I mentioned on http://kopete.kde.org and Kopete Keramik is now gone. however the other two testcases still fail. So I guess that bug was unrelated to this.
Comment 4 Stephan Binner 2003-10-21 08:41:54 UTC
*** Bug has been marked as fixed ***.