Bug 62603 - artsdsp crashes
Summary: artsdsp crashes
Status: RESOLVED WORKSFORME
Alias: None
Product: arts
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: VHI critical with 161 votes (vote)
Target Milestone: ---
Assignee: Stefan Westerfeld
URL:
Keywords:
: 64469 65036 73779 77830 78764 80322 81537 81795 86395 93910 94087 96581 103470 104226 106047 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-08-13 16:48 UTC by Erik Schnetter
Modified: 2006-11-18 12:04 UTC (History)
18 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
test program for double-init. (170 bytes, text/plain)
2004-04-06 01:28 UTC, Bastien Nocera
Details
Experimental patch (810 bytes, patch)
2004-12-07 22:21 UTC, Allan Sandfeld
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Schnetter 2003-08-13 16:48:57 UTC
Version:           unknown (using KDE 3.1.3)
Installed from:     (testing/unstable)
Compiler:          gcc version 3.3.1 20030722 (Debian prerelease)
OS:          Linux (i686) release 2.4.21-3-686

Each article on telepolis http://www.heise.de/tp/ leads to nspluginviewer crashing.  Apart from that, the pages can be viewed normally.

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[New Thread 16384 (LWP 11289)]
(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
0x40e30bb5 in waitpid () from /lib/libpthread.so.0
#0  0x40e30bb5 in waitpid () from /lib/libpthread.so.0
#1  0x4070eed0 in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#2  0x40e2f98d in __pthread_sighandler () from /lib/libpthread.so.0
#3  <signal handler called>
#4  0x4210a2ad in Arts::StartupManager::startup() () from /usr/lib/libmcop.so.1
#5  0x420f1ca6 in Arts::Dispatcher::Dispatcher(Arts::IOManager*, Arts::Dispatcher::StartServer) () from /usr/lib/libmcop.so.1
#6  0x41d89b46 in arts_backend_init () from /usr/lib/libartscbackend.so.0
#7  0x400195aa in arts_init () from /usr/lib/libartsc.so.0
#8  0x40014e39 in open () from /usr/lib/libartsdsp.so.0
#9  0x41aa5f89 in PlatformSoundMix::UnlockAudioCallback ()
   from /usr/lib/mozilla/plugins/libflashplayer.so
#10 0x41aa61a9 in UnixSoundOSS::Open ()
   from /usr/lib/mozilla/plugins/libflashplayer.so
#11 0x41aa5775 in PlatformSoundMix::OpenDevice ()
   from /usr/lib/mozilla/plugins/libflashplayer.so
#12 0x41aa5491 in PlatformSoundMix::PlatformConstruct ()
   from /usr/lib/mozilla/plugins/libflashplayer.so
#13 0x41a24a2d in CoreSoundMix::Construct ()
   from /usr/lib/mozilla/plugins/libflashplayer.so
#14 0x41a6dabe in CoreGlobals::Init ()
   from /usr/lib/mozilla/plugins/libflashplayer.so
#15 0x41a441a1 in CorePlayer::CorePlayer ()
   from /usr/lib/mozilla/plugins/libflashplayer.so
#16 0x41a7aae9 in UnixCommonPlayer::UnixCommonPlayer ()
   from /usr/lib/mozilla/plugins/libflashplayer.so
#17 0x41aadf58 in PlatformPlayer::PlatformPlayer ()
   from /usr/lib/mozilla/plugins/libflashplayer.so
#18 0x41ab2f82 in NPP_New () from /usr/lib/mozilla/plugins/libflashplayer.so
#19 0x41ab1a3c in Private_New ()
   from /usr/lib/mozilla/plugins/libflashplayer.so
#20 0x08057188 in NSPluginClass::newInstance(QString, QString, bool, QStringList, QStringList, QString, QString) ()
#21 0x0805aea1 in NSPluginClassIface::process(QCString const&, QMemArray<char> const&, QCString&, QMemArray<char>&) ()
#22 0x407bce6e in DCOPClient::receive(QCString const&, QCString const&, QCString const&, QMemArray<char> const&, QCString&, QMemArray<char>&) ()
   from /usr/lib/libDCOP.so.4
#23 0x407b6eac in DCOPClient::processPostedMessagesInternal() ()
   from /usr/lib/libDCOP.so.4
#24 0x407b68fe in DCOPClient::dcopServerFileOld(QCString const&) ()
   from /usr/lib/libDCOP.so.4
#25 0x407c5a63 in KDE_IceProcessMessages () from /usr/lib/libDCOP.so.4
#26 0x407bdd05 in DCOPClient::processSocketData(int) ()
   from /usr/lib/libDCOP.so.4
#27 0x407bee5b in DCOPClient::qt_invoke(int, QUObject*) ()
   from /usr/lib/libDCOP.so.4
#28 0x40a5914e in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/libqt-mt.so.3
#29 0x40a591ff in QObject::activate_signal(int, int) ()
   from /usr/lib/libqt-mt.so.3
#30 0x40cc1b8d in QSocketNotifier::activated(int) ()
   from /usr/lib/libqt-mt.so.3
#31 0x40a7126c in QSocketNotifier::event(QEvent*) ()
   from /usr/lib/libqt-mt.so.3
#32 0x40a051be in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/libqt-mt.so.3
#33 0x40a04dff in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libqt-mt.so.3
#34 0x406aaad7 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdecore.so.4
#35 0x409e3578 in QEventLoop::activateSocketNotifiers() ()
   from /usr/lib/libqt-mt.so.3
#36 0x0805a10d in QXtEventLoop::processEvents(unsigned) ()
#37 0x40a1677b in QEventLoop::enterLoop() () from /usr/lib/libqt-mt.so.3
#38 0x40a16638 in QEventLoop::exec() () from /usr/lib/libqt-mt.so.3
#39 0x40a053b8 in QApplication::exec() () from /usr/lib/libqt-mt.so.3
#40 0x080595c3 in main ()
Comment 1 George Staikos 2003-08-13 17:06:03 UTC
I can't reproduce this, but I am definitely not surprised. 
Comment 2 George Staikos 2003-09-17 23:37:10 UTC
*** Bug 64098 has been marked as a duplicate of this bug. ***
Comment 3 George Staikos 2003-09-17 23:37:51 UTC
*** Bug 64469 has been marked as a duplicate of this bug. ***
Comment 4 George Staikos 2003-09-29 10:27:26 UTC
*** Bug 65036 has been marked as a duplicate of this bug. ***
Comment 5 Jörg Walter 2003-11-18 17:16:09 UTC
I've seen a crash + backtrace like this in an SDL app. Platform is Gentoo/Athlon-tbird/gcc-3.3/-O3. It went away with recompiling arts in debug mode (-O3 -g3), so I suspect it is a compiler/optimizer bug. Both, crashing and now working version are KDE-3.2beta1 (arts-1.1.93).
Comment 6 George Staikos 2004-01-29 20:03:23 UTC
*** Bug 73779 has been marked as a duplicate of this bug. ***
Comment 7 Justin Jones 2004-03-19 09:42:14 UTC
I got this bug after upgrading Mandrake 9.1 to 9.2 and using thac's multimedia kernel and other sound system apps ( http://rpm.nyvalls.se/index9.2.html). If I enable artsd then sure enough the crash goes away. 
Comment 8 Bastien Nocera 2004-04-06 01:26:52 UTC
I could reproduce this bug with xine, and with the little test case attached below. Compile it and run it in quick succession, half the time it will output a nice "warning: leaving MCOP Dispatcher and still 146 types alive.", the other half it will core dump.

Valgrind tells me there's something dodgy going on with the init:

32173== Use of uninitialised value of size 16
==32173==    at 0x58C5D53: Arts::CpuInfoStartup::startup() (in /usr/lib/libartsflow.so.1.0.0)
==32173==    by 0x13783C2: Arts::StartupManager::startup() (in /usr/lib/libmcop.so.1.0.0)
==32173==    by 0x13577E7: Arts::Dispatcher::Dispatcher(Arts::IOManager*, Arts::Dispatcher::StartServer) (in /usr/lib/libmcop.so.1.0.0)
==32173==    by 0x140E974: arts_backend_init (in /usr/lib/libartscbackend.so.0.0.0)
==32173==
==32173== Invalid read of size 4
==32173==    at 0x13783BC: Arts::StartupManager::startup() (in /usr/lib/libmcop.so.1.0.0)
==32173==    by 0x13577E7: Arts::Dispatcher::Dispatcher(Arts::IOManager*, Arts::Dispatcher::StartServer) (in /usr/lib/libmcop.so.1.0.0)
==32173==    by 0x140E974: arts_backend_init (in /usr/lib/libartscbackend.so.0.0.0)
==32173==    by 0xD1B545: arts_init (in /usr/lib/libartsc.so.0.0.0)
==32173==    Address 0x30202D4 is not stack'd, malloc'd or free'd
Comment 9 Bastien Nocera 2004-04-06 01:28:00 UTC
Created attachment 5547 [details]
test program for double-init.
Comment 10 George Staikos 2004-04-25 19:33:10 UTC
*** Bug 77830 has been marked as a duplicate of this bug. ***
Comment 11 George Staikos 2004-04-25 19:33:24 UTC
*** Bug 80322 has been marked as a duplicate of this bug. ***
Comment 12 Tommi Tervo 2004-05-14 09:49:40 UTC
*** Bug 81537 has been marked as a duplicate of this bug. ***
Comment 13 Tommi Tervo 2004-05-18 13:34:47 UTC
*** Bug 81795 has been marked as a duplicate of this bug. ***
Comment 14 Bastien Nocera 2004-07-29 15:44:54 UTC
This bug is causing quite a few duplicates, both on the KDE and the GNOME bugzilla:
http://bugzilla.gnome.org/show_bug.cgi?id=138830
Comment 15 Stephan Kulow 2004-08-02 14:15:50 UTC
*** Bug 86395 has been marked as a duplicate of this bug. ***
Comment 16 Stephan Kulow 2004-11-29 17:34:49 UTC
*** Bug 94087 has been marked as a duplicate of this bug. ***
Comment 17 Allan Sandfeld 2004-12-07 22:12:52 UTC
Please report used compilers and versions
Comment 18 Allan Sandfeld 2004-12-07 22:21:48 UTC
Created attachment 8566 [details]
Experimental patch

Don't know if it makes any difference, but it might. Please try the patch.
Comment 19 George Staikos 2005-01-12 16:22:18 UTC
*** Bug 96581 has been marked as a duplicate of this bug. ***
Comment 20 George Staikos 2005-01-12 16:23:04 UTC
*** Bug 93910 has been marked as a duplicate of this bug. ***
Comment 21 George Staikos 2005-01-12 16:24:50 UTC
It's just stupid that we still have this problem.  It's very widespread, and all of my attempts to debug it resulted in valgrind/gdb crashes or the bug disappearing.
Comment 22 Brenno J . S . A . A . F . De Winter 2005-03-05 22:38:42 UTC
Sounds like a stability issue to me. So let's do something. 
Comment 23 Peter `MathFox` Roozemaal 2005-03-10 12:11:55 UTC
I got a stack backtrace similar to that in bug #93910 on my gentoo (AMD64) machine. It popped up after recompilation of kdelibs, but disappeared after I recompiled libsdl.
Between the compilation of libsdl and the kdelibs compilation that broke arts gcc was upgraded from 3.3.? to 3.4.3. It looks like some incompatability between gcc 3.3 and gcc 3.4. Compiling all with gcc 3.3 works, just as compiling all with gcc 3.4.
Comment 24 Maksim Orlovich 2005-04-12 05:43:31 UTC
*** Bug 103470 has been marked as a duplicate of this bug. ***
Comment 25 Maksim Orlovich 2005-04-12 05:44:43 UTC
*** Bug 78764 has been marked as a duplicate of this bug. ***
Comment 26 George Staikos 2005-04-21 19:52:17 UTC
*** Bug 104226 has been marked as a duplicate of this bug. ***
Comment 27 Maksim Orlovich 2005-05-21 15:42:58 UTC
*** Bug 106047 has been marked as a duplicate of this bug. ***
Comment 28 oppie 2005-06-10 21:52:45 UTC
Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1238441856 (LWP 4174)]
[KCrash handler]
#3  0xb46cfa64 in X509_get_subject_name () from /usr/lib/libcrypto.so.0.9.7
#4  0xb768f9f8 in KOpenSSLProxy::X509_get_subject_name ()
   from /usr/lib/libkio.so.4
#5  0xb767c768 in KSSLCertificate::getSubject () from /usr/lib/libkio.so.4
#6  0xb7682eb1 in KSSLPeerInfo::certMatchesAddress ()
   from /usr/lib/libkio.so.4
#7  0xb6012ada in KSSLSocket::verifyCertificate ()
   from /usr/lib/kde3/kopete_irc.so
#8  0xb60119b3 in KSSLSocket::slotConnected ()
   from /usr/lib/kde3/kopete_irc.so
#9  0xb6014073 in KSSLSocket::qt_invoke () from /usr/lib/kde3/kopete_irc.so
#10 0xb6b404a6 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#11 0xb6b40354 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#12 0xb71e7a8c in KExtendedSocket::connectionSuccess ()
   from /usr/lib/libkdecore.so.4
#13 0xb71e6ce7 in KExtendedSocket::connectionEvent ()
   from /usr/lib/libkdecore.so.4
#14 0xb71e5f9b in KExtendedSocket::socketActivityRead ()
   from /usr/lib/libkdecore.so.4
#15 0xb71e7b68 in KExtendedSocket::qt_invoke () from /usr/lib/libkdecore.so.4
#16 0xb601403b in KSSLSocket::qt_invoke () from /usr/lib/kde3/kopete_irc.so
#17 0xb6b4052c in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#18 0xb6b4068d in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#19 0xb6e7ef82 in QSocketNotifier::activated () from /usr/lib/libqt-mt.so.3
#20 0xb6b5ccd0 in QSocketNotifier::event () from /usr/lib/libqt-mt.so.3
#21 0xb6ae3bff in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#22 0xb6ae31fe in QApplication::notify () from /usr/lib/libqt-mt.so.3
#23 0xb711df93 in KApplication::notify () from /usr/lib/libkdecore.so.4
#24 0xb6ad360a in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/libqt-mt.so.3
#25 0xb6a8cc33 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#26 0xb6af5f58 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#27 0xb6af5e08 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#28 0xb6ae3e51 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#29 0x080699fd in ?? ()
#30 0xbffff9c0 in ?? ()
#31 0xbffff9a0 in ?? ()
#32 0xbffff9a0 in ?? ()
#33 0x00000000 in ?? ()
#34 0x080a815e in _IO_stdin_used ()
#35 0x00000001 in ?? ()
#36 0x080a94c0 in _IO_stdin_used ()
#37 0x080a7d76 in _IO_stdin_used ()
#38 0x080a7d8b in _IO_stdin_used ()
#39 0x080a7d5c in _IO_stdin_used ()
#40 0x00000000 in ?? ()
#41 0xbffff9a0 in ?? ()
#42 0xb6f86680 in vtable for QGArray () from /usr/lib/libqt-mt.so.3
#43 0x082339c8 in ?? ()
#44 0x0805ec15 in ?? ()
#45 0xb6646e54 in ?? () from /usr/lib/libstdc++.so.5
#46 0xb6f86680 in vtable for QGArray () from /usr/lib/libqt-mt.so.3
#47 0x080f0b58 in ?? ()
#48 0xbffff9e8 in ?? ()
#49 0xb66252ee in operator new () from /usr/lib/libstdc++.so.5
#50 0xb64417f8 in __libc_start_main () from /lib/tls/libc.so.6
#51 0xb6563fcc in ?? () from /lib/tls/libc.so.6
Comment 29 Philip Rodrigues 2006-09-08 18:25:39 UTC
Not much activity on this for a while. Can anyone still reproduce it with KDE 3.5?
Comment 30 FiNeX 2006-10-08 22:25:17 UTC
I've tried to load that website on KDE 3.5.4. I've had no crash. Maybe it was a problem related to some plugin?
Comment 31 Philip Rodrigues 2006-11-18 12:04:11 UTC
OK, then. Presumably it's fixed. Please reopen if anyone is still seeing this problem in 3.5