Bug 60664 - Keyboard shortcut for toggling focus on the terminal
Summary: Keyboard shortcut for toggling focus on the terminal
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist with 145 votes (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 78267 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-07-03 02:24 UTC by Thomas Kjosmoen
Modified: 2008-03-11 20:34 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Kjosmoen 2003-07-03 02:24:29 UTC
Version:            (using KDE KDE 3.1.1a)
Installed from:    Gentoo Packages

I would really like to have a keyboard shortcut that toggles the focus between the terminal and the open document. Is that possible to do without rewriting the terminal emulator?
Comment 1 Thomas Kjosmoen 2003-07-03 02:38:59 UTC
Uhm, I feel a little stupid. I just found another old bugreport wanting the same feature: 
http://bugs.kde.org/show_bug.cgi?id=36152 
 
Given that, I guess mine is a duplicate. BTW, that bugreport is from january 2002, 
marked "New", and the feature is not implemented yet. Does that mean that it will not 
be implemented? 
 
Comment 2 Alexander Kuit 2003-08-18 15:20:54 UTC
This is actually the same wish I have. Currently I assign F2 to the "Show Terminal" function. It 
would indeed be nice to have a predefined key for this. 
It would also be nice to have the keyboard focus set correctly after switching, so it would not 
be necessary to click the window before starting to type. 
Comment 3 Tero Kontkanen 2004-10-29 14:50:40 UTC
"so it would not be necessary to click the window before starting to type. "

That is what also I have been missing since beginning of Kate. I hardly never use embedded terminal just because it needs mouse to focus it.
Comment 4 Anders Lund 2004-10-29 15:09:29 UTC
Since the konsole part does not allow us to add shortcuts -- it eats all keyboard presses -- we *can not* define a shortcut to unfocus it. We are waiting for konsole part to provide us with an option.

For now, the best work around is to set a shortcut to show/hide the terminal.
Comment 5 Jeroen Wijnhout 2004-10-29 15:13:46 UTC
On Friday 29 October 2004 15:09, Anders Lund wrote:
> Since the konsole part does not allow us to add shortcuts -- it eats all
> keyboard presses -- we *can not* define a shortcut to unfocus it. We are
> waiting for konsole part to provide us with an option.

This is not my experience, in Kile I have Ctrl+Alt+K to switch to the Konsole 
tab and Ctrl+Alt+O to switch to the Output tab for example. It works, however 
I do remember having some difficulties in finding a keyboard shortcurt that 
works (Konsole is hungry for keyevents but it doens't eat them all :-) ).

best,
Jeroen
Comment 6 Andreas Kling 2006-07-11 19:46:39 UTC
*** Bug 78267 has been marked as a duplicate of this bug. ***
Comment 7 Grzegorz Oledzki 2006-10-09 14:55:40 UTC
And? After 3-4 years nothing has changed?
Comment 8 Dominik Haumann 2006-10-09 17:05:43 UTC
Grzegorz: you are welcome to fix it. see you on irc.
Comment 9 Anders Lund 2007-10-04 22:21:43 UTC
SVN commit 721219 by alund:

Add an action that toggles the focus between the konsole and the active document.
Because of a bug in konsole that means that the terminal widget doesn't get focus, 
this only works after the terminal has been clicked, or if it was open at launch time, 
in which case it for some reason *does* get focus. I'll try to fix this inside the 
konsole part.
FEATURE:60664


 M  +27 -0     kateconsole.cpp  
 M  +5 -0      kateconsole.h  
 M  +2 -1      ui.rc  


WebSVN link: http://websvn.kde.org/?view=rev&revision=721219
Comment 10 Milian Wolff 2008-03-11 20:34:49 UTC
Since Anders Lund comment relates to what I'm about to say, I don't open a new bugreport:

The "focus terminal" shortcut is still much less then perfect.

How it's like now:
------------------

- document is focused
- press defined "focus terminal" shortcut
- press any button (since one would think the terminal is focused) => nothing happens
- press tab and start typing => it works
- press the defined "focus terminal" shortcut which should unfocus the terminal and refocus the document
- start typing => nothing happens
- it seems like the terminal widget is focused again => press the focus terminal shortcut _again_
- document is focused

How it should be like
---------------------
- document focused
- press shortcut, terminal is focused (no tab-press required)
- press shortcut, document is focused again (shortcut should not be pressed twiced)

I _really_ hope this gets fixed. It would make my Kate experience _much_ better. Thank you all.

I'm using kate from kde trunk rev 784529, manually compiled.

PS: if this should become its own bugreport, please tell me so.