Bug 57797 - crashes when redoing screen after executing cvs update
Summary: crashes when redoing screen after executing cvs update
Status: RESOLVED FIXED
Alias: None
Product: cervisia
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Bernd Gehrmann
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-04-28 12:34 UTC by Achim Herwig
Modified: 2003-06-07 13:21 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Achim Herwig 2003-04-28 12:34:57 UTC
Version:            (using KDE KDE 3.1.1)
Installed from:    SuSE RPMs
OS:          Linux

When I update (or status) the current repository, cervisia executes the cvs command, and, after writing out [fertig] (german for "ready" or "done"), it crashes with SIG 11

Backtrace:
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[New Thread 1024 (LWP 13399)]
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...0x40fc2299 in wait4 () from /lib/libc.so.6
#0  0x40fc2299 in wait4 () from /lib/libc.so.6
#1  0x410302e8 in __DTOR_END__ () from /lib/libc.so.6
#2  0x40e87317 in waitpid () from /lib/libpthread.so.0
#3  0x40602d31 in KCrash::defaultCrashHandler ()
   from /opt/kde3/lib/libkdecore.so.4
#4  0x40e84e9d in pthread_sighandler () from /lib/libpthread.so.0
#5  <signal handler called>
#6  0x40a00ac8 in QListView::widthChanged ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#7  0x409fc890 in QListViewItem::widthChanged ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#8  0x409f6533 in QListViewItem::setup () from /usr/lib/qt3/lib/libqt-mt.so.3
#9  0x409f6f3b in QListViewItem::setPixmap ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#10 0x4004a00c in UpdateDirItem::updateEntriesItem ()
   from /opt/kde3/lib/libcervisia.so.1
#11 0x4004ad0a in UpdateDirItem::syncWithEntries ()
   from /opt/kde3/lib/libcervisia.so.1
#12 0x4004e18f in UpdateView::syncSelection ()
   from /opt/kde3/lib/libcervisia.so.1
#13 0x4004db93 in UpdateView::finishJob () from /opt/kde3/lib/libcervisia.so.1
#14 0x4004ee91 in UpdateView::qt_invoke () from /opt/kde3/lib/libcervisia.so.1
#15 0x409533c5 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0x40953743 in QObject::activate_signal_bool ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0x40050292 in ProtocolView::jobFinished ()
   from /opt/kde3/lib/libcervisia.so.1
#18 0x4004f85e in ProtocolView::childExited ()
   from /opt/kde3/lib/libcervisia.so.1
#19 0x400502fd in ProtocolView::qt_invoke ()
   from /opt/kde3/lib/libcervisia.so.1
#20 0x40953324 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0x405cf969 in KProcess::processExited () from /opt/kde3/lib/libkdecore.so.4
#22 0x405ce916 in KProcess::processHasExited ()
   from /opt/kde3/lib/libkdecore.so.4
#23 0x405d0741 in KProcessController::slotDoHousekeeping ()
   from /opt/kde3/lib/libkdecore.so.4
#24 0x405d0b7d in KProcessController::qt_invoke ()
   from /opt/kde3/lib/libkdecore.so.4
#25 0x40953324 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0x409534af in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0x40bafc3d in QSocketNotifier::activated ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#28 0x4096a13f in QSocketNotifier::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0x4090a1d3 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0x40909fd7 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0x4059fd2f in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#32 0x408ee137 in QEventLoop::activateSocketNotifiers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0x408d175b in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#34 0x4091a720 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#35 0x4091a667 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#36 0x4090a346 in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#37 0x804ec06 in QWidget::imStartEvent ()
#38 0x40f35c5f in __libc_start_main () from /lib/libc.so.6
Comment 1 Christian Loose 2003-05-13 20:47:31 UTC
Hi Achim, 
 
right now, I can't reproduce this crash. So I need some more information: 
 
- Do you use version 2.0 of Cervisia that came with KDE 3.1.1? 
- What Qt version do you use? 
- Did you use Cervisia as stand-alone program or embedded in Konqueror or 
  Quanta? 
- Does the repository contain a binary file? 
 
Thanks in advance for your answers... 
 
Christian 
 
Comment 2 Achim Herwig 2003-05-14 11:00:02 UTC
> - Do you use version 2.0 of Cervisia that came with KDE 3.1.1?   
 yes:  
#rpm -qi kdesdk3  
Name        : kdesdk3                      Relocations: (not relocateable)  
Version     : 3.1.1                             Vendor: SuSE AG, Nuernberg, Germany  
Release     : 25                            Build Date: Mit 26 M
Comment 3 Christian Loose 2003-05-22 22:21:58 UTC
Thanks a lot Achim for your very detailed reply!! 
 
This bug is really strange, because Cervisia didn't really change between 
the KDE 3.1.1 release and the current KDE_3_1_BRANCH which will be 
KDE 3.1.2. 
 
So when Cervisia works for you on your Gentoo system, something must have 
changed outside of Cervisia's source code. 
 
Since the dump is (naturally) without debug information, I can't extract enough 
information from it to fix or reproduce the bug. 
 
I change the bug status to resolved for now. Please reopen this report if this bug still 
exists after SuSE switched to KDE 3.1.2. 
 
Bye 
Christian 
Comment 4 Achim Herwig 2003-05-23 19:17:25 UTC
I have to reopen the bug: It still exists in KDE 3.1.2 (RPMs from SuSE website, this 
tuesday) and it is there again on Gentoo (kdesdk 3.1.2) as well. 
 
I see the problem with the debug output. I tried to compile a debug version on the 
Gentoo system, but I do not understand enough of the build process (KDE+portage). 
I ended up again with stripped binaries... 
 
But another thing I did: I ran cervisia with valgrind (on the SuSE machine). It 
produces lots of output (valgrind seems not to be used much around the KDE 
developers and Trolltech....), but I include only the final statement before the crash 
here: 
 
==2794== Invalid read of size 4 
==2794==    at 0x40C3BAC5: QListView::widthChanged(QListViewItem const *, int) 
(in /usr/lib/qt3/lib/libqt-mt.so.3.1.2) 
==2794==    by 0x40C37890: QListViewItem::widthChanged(int) const (in 
/usr/lib/qt3/lib/libqt-mt.so.3.1.2) 
==2794==    by 0x40C31533: QListViewItem::setup(void) (in 
/usr/lib/qt3/lib/libqt-mt.so.3.1.2) 
==2794==    by 0x40C31F3B: QListViewItem::setPixmap(int, QPixmap const &) (in 
/usr/lib/qt3/lib/libqt-mt.so.3.1.2) 
==2794==    Address 0x98 is not stack'd, malloc'd or free'd 
==2794== Warning: client attempted to close Valgrind's logfile fd (2). 
==2794==    Use --logfile-fd=<number> to select an alternative logfile fd. 
KCrash: Application 'cervisia' crashing... 
 
From what I read, at least one QListViewItem doesn't know the correct QListView to 
call. Or maybe that's because *this is corrupted... 
 
When I come around to it, I will try with a debug version and look what happens... 
 
Achim. 
Comment 5 Andre Woebbeking 2003-05-24 00:12:20 UTC
Subject: Re:  crashes when redoing screen after executing cvs update

Hi Achim,

On Friday 23 May 2003 19:17, Achim Herwig wrote:
> ------- Additional Comments From achimh+kdebugs@ccc.uni-erlangen.de 
> 2003-05-23 19:17 ------- I have to reopen the bug: It still exists in
> KDE 3.1.2 (RPMs from SuSE website, this tuesday) and it is there
> again on Gentoo (kdesdk 3.1.2) as well.

do you use one of the hide options from the view menu and if so, can you 
reproduce the crash if you turn all hide options off?

> But another thing I did: I ran cervisia with valgrind (on the SuSE
> machine). It produces lots of output (valgrind seems not to be used
> much around the KDE developers and Trolltech....), but I include only

it's used by many developers but maybe it should be used more often :-)


Andr
Comment 6 Achim Herwig 2003-05-26 16:20:48 UTC
Hi Andr
Comment 7 Andre Woebbeking 2003-06-07 13:21:51 UTC
Subject: KDE_3_1_BRANCH: kdesdk/cervisia

CVS commit by woebbe: 

Fix BR #57797:

Removed the own implementation of the QListViewItem visible property 
which could lead to a crash when an invisible item was changed 
(for invisible items listView() was 0).

CCMAIL: 57797-done@bugs.kde.org


  M +6 -0      ChangeLog   1.22.2.9
  M +2 -54     listview.cpp   1.3.2.1
  M +0 -6      listview.h   1.3.2.2


--- kdesdk/cervisia/ChangeLog  #1.22.2.8:1.22.2.9
@@ -1,2 +1,8 @@
+2003-06-07  Andr