Bug 57516 - 1st player's turn when dead
Summary: 1st player's turn when dead
Status: RESOLVED FIXED
Alias: None
Product: konquest
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: RedHat Enterprise Linux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Russell Steffen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-04-21 17:39 UTC by tom
Modified: 2003-05-11 01:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tom 2003-04-21 17:39:34 UTC
Version:            (using KDE KDE 3.1KDE 3.0.4KDE 1.2)
Installed from:    RedHat RPMsRedHat RPMsRedHat RPMs
OS:          Linux

If the 1st player no longer has any planets at the begining of each round it's the 1st player's turn instead of it being the 1st alive person's turn. So you have to press the end turn botton.
Comment 1 tom 2003-04-30 02:19:43 UTC
Subject: Re:  1st player's turn when dead

Hi Russell

I'm the one who reported this bug, I haven't had a look at the code, but I've written a few games and I'm guessing that there's a method for the next players turn. In my Java code it looks like this:

   public void nextPlayer()
     {
      if (currentPlayer < noOfPlayers-1)
        {
         currentPlayer++;
        }
      else
        {
         currentPlayer = 0;
        }
     }

Assuming there's something similar it's probably a case of changing the else part select the next alive player. Although this is where you'll have to work your magic because my C isn't very good.

Hope this helps

Tom
tom@tomk.homelinux.org


On 29 Apr 2003 05:40:38 -0000
Russell Steffen <rsteffen@bayarea.net> wrote:

> ------- You are receiving this mail because: -------
> You reported the bug, or are watching the reporter.
>      
> http://bugs.kde.org/show_bug.cgi?id=57516     
> rsteffen@bayarea.net changed:
> 
>            What    |Removed                     |Added
> -----------------------------------------------------------------------
> -----
>              Status|UNCONFIRMED                 |ASSIGNED
>       everconfirmed|0                           |1

Comment 2 Russell Steffen 2003-05-11 01:31:53 UTC
Fixed in both HEAD and KDE_3_1_BRANCH (I think that means it wil be in KDE 3.1.2). 
 
Added a loop at the beginning of a new turn to look for the first player that's still in the 
game. 
Comment 3 Russell Steffen 2003-05-11 01:32:09 UTC
*** Bug has been marked as fixed ***.